Jump to content


Photo

Relative filenames for multimedia


  • Please log in to reply
3 replies to this topic

#1 diver864

diver864

    New Member

  • Members
  • Pip
  • 4 posts

Posted 04 October 2006 - 02:30 PM

Hi,

like some of the other folks whose posts I've read, I like to take my data on the road with me on my laptop, then bring it back home and restore it on my PC. This causes a problem with multimedia files, though. For multimedia files, it would be nice if RM would either:

i) allow relative filenames (e.g. .\my sources\picture.jpg) or
ii) search the multimedia default directory for a file, in case it can't find the file under the explicit directory in the record entry.

I've read about the workarounds, and they do work, but those are less than convenient if one travels often. When my RM data is on the laptop, I keep it in something like c:\...\personal\genealogy\ and source images and multimedia in c:\...\personal\genealogy\my sources\. When it's on the PC, it's in d:\...\genealogy\ and d:\...\genealogy\my sources\. I just copy the entire \genealogy folder and contents back and forth. Relative file addressing or the other suggestion would support this.


#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3493 posts

Posted 04 October 2006 - 11:28 PM

QUOTE(diver864 @ Oct 4 2006, 04:30 PM) View Post
For multimedia files, it would be nice if RM would either:

i) allow relative filenames (e.g. .\my sources\picture.jpg) or

RootsMagic supports relative filenames ;-)
Next time you're adding a multimedia item...
-Browse and select the item...
-Then erase the Drive letter from the File name: block and continue on!
(or use Search-->Search & Replace -->Multimedia filenames and replace all references to C: -or- whatever_
It works fine, still. biggrin.gif

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 diver864

diver864

    New Member

  • Members
  • Pip
  • 4 posts

Posted 13 October 2006 - 10:45 AM

QUOTE(kbens0n @ Oct 5 2006, 07:28 AM) View Post
-Then erase the Drive letter from the File name: block and continue on!

Hmmm, that would work if the directory tree is the same, but in my case it's not:

"C:\Documents and Settings\username\My Documents\Personal\Genealogy\My Sources"

is not the same as

"D:\Genealogy\My Sources"

so just dropping the drive letter doesn't do it. If one could input a path relative to the current RootsMagic data directory, or a directory declared in the preferences, then one could use relative path naming.

I did try banging in the relative paths " .\Genealogy\My Sources\filename.jpg" or just "Genealogy\My Sources\filename.jpg" but neither of those were accepted.



#4 Ludlow Bay

Ludlow Bay

    Advanced Member

  • Members
  • PipPipPip
  • 875 posts

Posted 13 October 2006 - 02:31 PM

QUOTE(diver864 @ Oct 13 2006, 09:45 AM) View Post

Hmmm, that would work if the directory tree is the same, but in my case it's not:

"C:\Documents and Settings\username\My Documents\Personal\Genealogy\My Sources"

is not the same as

"D:\Genealogy\My Sources"

so just dropping the drive letter doesn't do it. If one could input a path relative to the current RootsMagic data directory, or a directory declared in the preferences, then one could use relative path naming.

I did try banging in the relative paths " .\Genealogy\My Sources\filename.jpg" or just "Genealogy\My Sources\filename.jpg" but neither of those were accepted.



Why don't you simply make the two paths be the same?