Jump to content


bad rootsmagic.ini file


  • Please log in to reply
9 replies to this topic

#1 Guest_Frankie Bredenheisen_*

Guest_Frankie Bredenheisen_*
  • Guests

Posted 22 December 2005 - 06:18 PM

Every time I try to start RM 3.04, I get the "RootsMagic.exe has generated errors and will be closed by Windows. You will need to restart the program." Every time.

So I delete the RootsMagic.ini file and the program starts normally. Close the program, and next time I try to open it I get the same error, and must delete the same ini file. Always.

What's up with that?



#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3444 posts

Posted 22 December 2005 - 07:42 PM

Just a thought,
One scenario that has been reported:

~SOMETIMES~ users accidentally open and then minimize "multiple" copies of many databases over the course of use. Minimized windows become hidden behind those in use... THEN they close RM and skip all backups. If the option is set for RootsMagic to open ALL "previously-open" databases AND there were a lot of them open... you get RootsMagic trying to use ~way~ too many resources and crashes can ensue.

After you delete the RootsMagic.ini and restart RM, close ~all~ databases one at a time, until only the RootsMagic toolbar along the top is visible. Then close RM and restart. Open one, two or three databases and try closing and restarting again.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 22 December 2005 - 08:21 PM

QUOTE
So I delete the RootsMagic.ini file and the program starts normally. Close the program, and next time I try to open it I get the same error, and must delete the same ini file. Always.


Did you go to the options and uncheck the "Open databases from last session" when you got RootsMagic open after deleting the ini file?

This is usually the problem, the corrupted database is trying to load as soon as the program starts and that shuts down the program.

If no databases are loaded at startup, you can manually open them one at a time and see which one is causing the problem.

===========
But, it sounds like you are opening the database with no problem.
I don't know what is different about having the program open it on startup than you opening it after the program is loaded. Maybe it checks more on startup.

In any case, after your database is opened, try exporting a complete GEDCOM file. That accesses all the data in the database. If there is a problem with the database, you should get an error message there.
Alfred

#4 Guest_Frankie Bredenheisen_*

Guest_Frankie Bredenheisen_*
  • Guests

Posted 22 December 2005 - 11:37 PM

QUOTE(kbens0n @ Dec 22 2005, 06:42 PM)
Just a thought,
One scenario that has been reported:

~SOMETIMES~ users accidentally open and then minimize "multiple" copies of many databases over the course of use. Minimized windows become hidden behind those in use... THEN they close RM and skip all backups. If the option is set for RootsMagic to open ALL "previously-open" databases AND there were a lot of them open... you get RootsMagic trying to use ~way~ too many resources and crashes can ensue.

After you delete the RootsMagic.ini and restart RM, close ~all~ databases one at a time, until only the RootsMagic toolbar along the top is visible. Then close RM and restart. Open one, two or three databases and try closing and restarting again.

View Post




Sorry, no - I've only ever had one database, period.

#5 Guest_Frankie Bredenheisen_*

Guest_Frankie Bredenheisen_*
  • Guests

Posted 22 December 2005 - 11:39 PM

QUOTE(Alfred @ Dec 22 2005, 07:21 PM)
Did you go to the options and uncheck the "Open databases from last session" when you got RootsMagic open after deleting the ini file?

This is usually the problem, the corrupted database is trying to load as soon as the program starts and that shuts down the program.

If no databases are loaded at startup, you can manually open them one at a time and see which one is causing the problem.

===========
But, it sounds like you are opening the database with no problem.
I don't know what is different about having the program open it on startup than you opening it after the program is loaded. Maybe it checks more on startup.

In any case, after your database is opened, try exporting a complete GEDCOM file. That accesses all the data in the database. If there is a problem with the database, you should get an error message there.

View Post




As I answered previously, I have only ever had one database, and it opens fine as long as there is no ini file beforehand. Gedcom exports work fine too, I do them all the time. Where would I find this error message and what would it say?

#6 Guest_Frankie Bredenheisen_*

Guest_Frankie Bredenheisen_*
  • Guests

Posted 23 December 2005 - 01:43 PM

QUOTE(Frankie Bredenheisen @ Dec 22 2005, 10:39 PM)
As I answered previously, I have only ever had one database, and it opens fine as long as there is no ini file beforehand.  Gedcom exports work fine too, I do them all the time.  Where would I find this error message and what would it say?

View Post




Where do I go for more help? This program is not useful to me at all with this irritating problem.

#7 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 23 December 2005 - 02:34 PM

In rootsMagic, click the help menu and choose "Technical support"


Would you like to send me a copy of that RootsMagic.INI file, copied just before you shut down or just before you have to remove it to restart the program, maybe both, if shutting down is changing it. Just attach it/them to an email to me. Use something like "RootsMagic-ini" as the subject so I don't miss it. If you do send both, tell me which is which.

adeller@santel.net

I can look it over to see if I can find anything unusual in it.
Alfred

#8 Guest_don_*

Guest_don_*
  • Guests

Posted 23 December 2005 - 02:53 PM

Did you add or update any anti-spyware, anti-virus, or firewall software about the time this problem started?

#9 aplucinik

aplucinik

    Advanced Member

  • Members
  • PipPipPip
  • 591 posts

Posted 23 December 2005 - 03:17 PM

Frankie,

Send me a backup copy of your database. I'm curious to see whether I get the same error and see the same behavior you see.

allan@sevenarrow.com

#10 silicon

silicon

    Member

  • Members
  • PipPip
  • 12 posts

Posted 23 December 2005 - 06:56 PM

Frankie,

Is your copy of RM new? By that I mean did you have a copy of RM before version 3.+?
I recall somewhere that some users including myself had some problems with the .ini file when we upgraded to version 3..
I was frusterated myself until I ran a search under windows and found that the location for my RM version 2 ini file was in another directory, and some of my problems had come from it being read instead of the version 3 ini file.

My rootsmagic 3 ini file is located under:
C:\Documents and Settings\All Users\Application Data\RootsMagic

Older one's were located under c:\windows if memory serves me right.

Suggestion, if you have one under windows, create a directory say ini files, and move it there.

Then, go to Start\Control Panel\System\System Restore and turn off System Restore by removing the check in the box to enable system restore.

Close down your computer by closing all open programs and shut down the computer. This will clear the system restore directory, and then restart your system.

Try running you RM program then and if it works, go back to the control panel and re-enable your system restore. It should find the correct ini file and should run OK.