Jump to content


RobJ's Content

There have been 55 items by RobJ (Search limited from 20-July 18)


By content type

See this member's


Sort by                Order  

#85968 dragging and dropping

Posted by RobJ on 15 September 2017 - 06:44 AM in Discussion

My apologies, Emile, a very troublesome girl Irma has sidelined me for awhile, with lots of volunteering before, during, and afterward, then hugely increased job demands afterward due to working for one of the few places with partial power (but not air conditioning!).  I have a lot of catching up to do with just about everything, especially computer stuff.

 

I can't think of anything to help though, as I haven't worked with reporting yet, except a specific report for troubleshooting.  Sounds like some of the family linking is not set up correctly.  I think there are others here with much more related experience that might have ideas about fixing that.




#85804 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 02 September 2017 - 02:03 PM in Issues

Thank you for your comments!

 

* Phantoms: The second Patrick O'Brien (in Rec#7) never had a spouse or child. I just added him to his parents for completeness, with practically no data.  That means Marriage Rec#7 should have belonged to another couple, but since there is no data in it (except his name) I don't know where it came from.  The phantom 'Unknown' person in Rec#18 can't be directly displayed, but I found I could get to him 'sideways' by clicking on a legitimate person, changing to Family View, then clicking on the '[Unknown]' person.  He had no name, but did have a birth and death fact identical to Anna's true spouse Laurence (1890-1985 Hamden).  And he has a child with no name but the same identical birth and death facts (1890-1985 Hamden).  Clicking on the child just highlights the [Unknown] person in the left list.  On a right-click, deletion and unlinking options are presented, but they don't work.  (This is all after the new 7.5.3 db cleanup.)  Thankfully, the Drag & Drop version of this db cleared him out completely, but it would be nice if the database cleanup tools could also do that, as well as remove any marriage records with only one spouse (unless intentionally added? with an unknown spouse?  not my problem! for RM to figure out!).

 

* Missing MRIN's: should be harmless, similar to deleting records, there would be missing record numbers.  In my picture above, Rec#14 and #15 are missing, no issue.  The Drag & Drop produces a db with them all renumbered from one, so if the missing ones bother you, a complete Drag & Drop should clean all of that up.  One thing I forgot to mention about Drag & Drop is that I was concerned whether the new db would be still connected to Ancestry.com.  (I'd completely forgotten about Jerry's comments about successfully dragging over one person!)  I can confirm the completely new db was still fully connected, every person to its Ancestry counterpart, *and* the hints were still 'Confirmed', no repeat of the hints.

 

* New marriage routine: that sounds like a good and safe way to do it, avoiding the potential issues.  Hopefully RM will figure it all out, and it won't be needed in the future.  Integrating partially incompatible systems is always hard.

 

* Sanity checks: (just a suggestion for the developers) it's been awhile since I was programming complex systems, with multiple programmers and subsystems, but one thing I used to like to do was add sanity check mechanisms, either fully doubly linked lists where I could completely rebuild systems on either side, no matter where the corruption occurred; or to add simple sanity check flags or ID's, that allowed early detection of issues before further corruption or errors occurred.  It could be as simple as adding a bitfield to the person record, where you could reserve a single bit for each critical item, like 'is there a marriage fact', 'a birth fact', 'a death fact', etc.  A db or record integrity check could easily and at any time determine if something is missing, wrongly linked, corrupted.  It could be a little more advanced by adding an additional marriage fact bit, 2 of them so that it can count 0, 1, 2, or '3 or more' marriage facts.  It requires a little more error checking logic, but pays off in cleaner records and systems, easier debugging, until you achieve a well-tested and stable system.




#85789 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 01 September 2017 - 04:04 PM in Issues

A follow-up, belated I know - I used Drag & Drop to create a new db, and used the new 7.5.3 db cleanup tools on a copy of the original corrupted db, just to compare.  Both worked roughly the same, producing a cleaner db with no marriage record corruption, but neither was perfect.  Both retained all marriage records with their correct couples, and both removed the wrongly linked data (marriage years and places) of the corrupted records.  Both removed the corrupted Rec#5, and kept the good Rec#5 with '1865'.  The Drag & Drop did not bring over the bad [Unknown] [Unknown] person, but left Anna Marion Nolan with the extra Marriage record with a phantom spouse (her only spouse is Laurence).  The new db cleanup did not remove the [Unknown] person, and in fact I could not find anyway to select them for deletion or unlinking.  They don't appear to have a person record, so they seem to be another kind of phantom that could be removed.

 

Neither removed Rec#7, with the second Patrick O'Brien and no spouse (a phantom spouse).  And the Drag & Drop created a second phantom spouse when it removed the phantom person.  This too seems like another cleaning improvement that could be made in the db cleanup tools.

 

Because of the problems still existing in the records, and all of the duplicated, tripled, and quadrupled facts in some records, I think it's best if I give up and use TreeShare to re-download the db from Ancestry.




#85555 duplicating a tree

Posted by RobJ on 25 August 2017 - 09:25 PM in Discussion

Check out the Drag and Drop video




#85520 Place Details - Comments and Thoughts

Posted by RobJ on 24 August 2017 - 05:34 PM in Discussion

I'm happy to see this passion!  It's my opinion that data portability is going to become a very important product feature, in the near future.  That means widespread GEDCOM agreement, a consensus on a GEDCOM 6, whatever it may turn out to be.  GEDCOM HAS to win widespread acceptance, and genealogical companies need to be required to declare and maintain full compatibility with current standards.  The recent loss of certain ancestry tools (TMG, FTM, etc) has caused pain among a segment of genealogical users, and reminded others of the risks of all your eggs in one basket.  In my view, DNA testing and features are also causing some migration, especially toward public 'one world' trees.  Data portability should be an important requirement of all your tools.  It's clearly not now.

 

It's difficult for me to see how widespread agreement can be accomplished without the current gorilla, Ancestry.com.  But I believe it's in everyone's interest to get together and agree, even if it means Ancestry dictates some part of the agreement, parts of which may not be desirable to others.  To me, the most important requirement is that round trip data integrity between tools and sites is ensured. After that, the emphasis should be on allowing, importing, and exporting as much detail as possible, even if your tool cannot handle as much detailed info as another tool, or breaks it up differently.  There will probably always be some incompatibilities in field layouts.




#85451 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 21 August 2017 - 09:44 AM in Issues

I was going to ask about that, but figured I would wait until it seemed closer to a resolution,so not to bother anyone too much - then Renee read my mind and answered it anyway!  Amazing!   :D




#85424 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 19 August 2017 - 11:18 PM in Issues

I checked a lot of lists, reports, and charts, and almost all do show the RIN, but not the Marriage List, the Surname Stats List, and I believe the Narrative Reports.  So I added them by hand, to the image above.

 

Your idea looks very plausible.

* The 1872 marriage fact was supposed to be in Rec#4, for the couple with RIN's 5 and 6, but instead is written into an extra Rec#5 and Rec#6.

* The 1947 marriage fact was supposed to be in Rec#3, for the couple with RIN's 4 and 20, but instead is written into Rec#4.  If it also attempted to write into Rec#20, I wonder if that would cause a 'Range error', since Rec#19 was the last one.




#85420 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 19 August 2017 - 05:53 PM in Issues

Really great suggestion!  I'm still unfamiliar with so many features RM has, that it took me awhile to find it.  (This is a small tree I was doing for someone else, just to help out.  Turned out to be a LOT more trouble than I expected!)  As far as I know, no names below are living.

 

* Rec#3 should be '1947 Hamden', currently in Rec#4.

* Rec#4 should be '1872 Charlestown', currently in both Rec#6 and the second Rec#5.

* Ones before and after that are correct.

* There appear to be 2 Rec#5's, one of which is correct ('1865').

* There are 2 Patrick O'Briens in the tree, the second of which is in Rec#7, but he does NOT have a spouse, and there should be no marriage rec here.

* Anna Marion Nolan has one spouse, Laurence Stephan Nolan, with no marriage fact yet.  But somehow there is another spouse attached to her, with the name 'Unknown Unknown', RIN 1240100.

 

RM_marriage_fact_issue2.jpg




#85419 Downloading an Existing Ancestry Tree Crashes RootsMagic

Posted by RobJ on 19 August 2017 - 04:31 PM in FamilySearch Family Tree

Please see this thread




#85415 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 19 August 2017 - 07:52 AM in Issues

You've added some nice detail, that I hope will help the developers.  Clearly, there's a problem with the marriage fact linking wrongly.  But the cause of it may be hard to pin down, as we got there in different paths.

 

Perhaps the database checking tools could be enhanced to detect when a marriage fact is linked to the wrong couple.  Or when a couple has 2 marriage facts applying, one in the fact list and another in the family summary, this one used to check for aging errors.




#85411 Marriage Dates Not Always Displaying Correctly

Posted by RobJ on 18 August 2017 - 06:53 PM in Issues

I'm not sure from your description if my issue is the same, but please check the following post, and see if it matches what you see, and the circumstances leading up to it.

 

http://forums.rootsm...ing/#entry85186




#85393 Informal list of abbreviations

Posted by RobJ on 17 August 2017 - 05:04 PM in Discussion

Thank you Tom, I've added them.  I've seen AMT a couple of times, and thought it might be Ancestry related from the context, but could not figure out what the M and T were for.

 

Of course, how useful the list will be depends on how widespread the usage is.  No one can control the language of a culture.




#85376 Informal list of abbreviations

Posted by RobJ on 16 August 2017 - 08:31 PM in Discussion

Thank you Renee!  I've added them.

 

  ( Sounds like you're a gamer!  :) )




#85373 Informal list of abbreviations

Posted by RobJ on 16 August 2017 - 03:57 PM in Discussion

After seeing multiple forms of Ancestry.com, shorter and longer, and being too lazy to write out the longer forms, I thought it might be useful to have an agreed list for RM forum users of abbreviations for the more common names we use.  I'm in no way trying to tell people what to use.  Anyone can write them any way they like.  But if someone is wondering what a good shortcut would be, here's a suggested list.

 

If you prefer something different, no problem, suggest it.  I'll edit this, and use whatever seems to have a consensus.  Yes, A is short, but so what, it's frequently needed, clear in context, without a conflict (and saves typing!).  The only ones that are brand new are A and TS.

 

RM - RootsMagic (the company, or assumed to be the current version of the software)

RM6 - RootsMagic version 6

TS - TreeShare

Db - Database, e.g., RMDb

 

FS - FamilySearch

FSFT - FamilySearch Family Tree

FSID - Family Search ID

 

A - Ancestry.com

AMT - Ancestry Member Tree

FTM - FamilyTreeMaker

MH - MyHeritage

FAG - FindAGrave

BG - BillionGraves

FMP - FindMyPast

TMG - The Master Genealogist

PH - Personal Historian

FO - Family Origins




#85277 What if the repository is not a building?

Posted by RobJ on 10 August 2017 - 10:03 PM in General Messages

I have to admit that I for one don't understand the questions, so anything I say may be way off the mark.

 

A repository is just a place where records are kept.  It could be your home, it could be a library, it could be a corporate datacenter, it could be a government data archive.  I can't think of any process involved, and I don't know what costs you are asking about.  When asked about a repository, you are simply being asked where the record is.  If *you* have the document, your place is a repository, and you can call your place anything you want.  Is it possible that you are over thinking it?




#85212 Just new here

Posted by RobJ on 08 August 2017 - 08:03 AM in General Messages

I looked around here, and it doesn't take much to advance.  A user with 5 posts was a 'Member', and another with 32 posts was an 'Advanced Member'.  But so was Renee with 6925 posts.  So it looks like:

1 - 4 posts : New Member

5 - 29 posts : Member

30 - * : Advanced Member

 

Be nice to see higher member classes, for all of the really helpful people on here, like zhangrau, TomH, Jerry, Renee, and number of others, like:

200 - 999 : Hero Member

1000 - * : Super Hero Member

 

I know from other forums that finding ways to show some appreciation and recognition for especially helpful users really pays off for a small company, and is totally cost effective, as in free.  Getting the 'Like This' button and system working would be another cheap and easy and rewarding tool.  And just saying 'thank you' when a user does something especially helpful.  It costs nothing to do, and has long term benefits for the community, *and* the company.




#85186 RM keeps freezing

Posted by RobJ on 06 August 2017 - 06:31 PM in Issues

I was making changes to a tree on Ancestry, then sync'ing it to RM, then to FamilySearch, and back again the other way.  (Kind of using RM as the transition tool, that integrates profiles on Ancestry and FamilySearch.)  I ran TreeShare to sync them, had quite a lot of changes, and succeeded with most, but one of them required a surname change (a maiden name had been discovered), and that one caused a range error.  Since only the surname change resulted in a range error, that might be a good place to start debugging.  I did not freeze, but no matter what I tried, clicking 'Accept Changes' resulted in the 'Range Error', on that person.

 

Later, I discovered that most of the facts on that RM record were in triplicate.  The Ancestry record appeared to be updated correctly, with no apparent issues, and the FamilySearch record appeared to be fine.  Only the RM record looked corrupted.  I then tried all 4 database tools, no issues found, but no improvement either.  I repeated the database tools several times.  Then I discovered that the marriage fact (in triplicate in this record) was not showing up top in the birth, death, and married summary.

 

And then I discovered the marriage fact was now applied to the parents of the tree's original person, the home person.  This marriage fact now appeared in their top summary, even though they had their own valid marriage fact, and modifying it and saving it had no effect on the posted marriage fact.  Since the fact was completely wrong for them, errors appeared on each of them and their children, that the parents had married at 95yo, even though they hadn't lived that long.  Clearly database corruption, but the database tools did not help.

 

I'll leave it this way in case someone wants to test something, or wants screen pics.  Then I'll delete the person with all the triplicate facts, and add them back from Ancestry (I *think* that should work).

 

Edit: I should add that anyone seeing a 'Range Error' should check for corruption in that record - duplicated facts, and facts now applying to other persons.




#85160 Small GEDCOM issue

Posted by RobJ on 04 August 2017 - 04:32 PM in Issues

It's been quieter here lately, so I hope Renee doesn't mind this report!  My current workflow is somewhat different than others, I've been creating RM trees using TreeShare, then selecting one or more individuals to export in a GEDCOM, then import into WikiTree.  Not surprising, there are a number of issues.  I finally discovered the RM export option "Extra details (RM specific)", and turned that off, and that dropped a LOT of extraneous info from the resultant GEDCOM.  But the GEDCOM still includes some RM specific info, that I have to manually remove.  Every image, and that includes the image of every source page, includes RM GEDCOM tags (with leading underscores).  Here's an example (and there are dozens per person):

 

3 OBJE
4 FILE Z:\Data\RootsMagic\Lynch1_media\31111_4330101-00182.jpg
4 FORM jpg
4 _TYPE PHOTO
4 _SCBK N
4 _PRIM N

(This is attached to a source.)  WikiTree's handling of this is partly at fault, and I have to take that up with them.  WikiTree drops the file path (a real problem!  lots of info about the image but no image or even the file name of the image), and it drops '_PRIM N', but keeps the rest, in translated forms.

   'FILE Z:\Dat...jpg' becomes 'File   '

   'FORM jpg' becomes 'Format: jpg'

   '_TYPE PHOTO' becomes 'PHOTO     '

   '_SCBK N' becomes 'Scrapbook: N '

 

My fix request: please consider _TYPE and _SCBK as RM specific, and don't include them if the option is off.  An Ancestry.com GEDCOM does not include them, is relatively clean (at least for an Ancestry.com export!).

 

Related issue: (sorry, no example here) before I found and turned off RM specific info in the export, the sources in the GEDCOM included a lot more garbage, including (for each source citation) 3 copies of the publishing statement, one in parentheses, one not in parens but often missing a random amount from the beginning, and a third that literally included the terms PUBPLACE, PUBYEAR, and PUB something else.  It also included a repeat of much of the source name.  While I could use global replace for some problems, every source required considerable editing, much of it by hand, one by one.  Edit: I should have said that this may be partly or wholly the fault of WikiTree, being ill-equipped to handle RM specific tags.  Edit2: I created a GEDCOM with RM specific stuff turned on, to see if I could find an example of corrupted truncated data to show here, but could not find any.  That would seem to implicate WikiTree as the 'truncator'.  They clearly don't know what to do with it all, but try anyway and concatenate everything as part of a 'citation', including 3 variant copies of the publishing statement, 'TID 439', and the 'Publisher', 'PubPlace', and 'PubDate' tags.  Obviously I shouldn't have included RM specific data in the export.

 

Additional comments:  something I find quite striking is the media included with the TreeShare download.  An Ancestry.com GEDCOM does not include any media (for a tree that I had not added any media).  If I use TreeShare to create an RM tree, a whole bunch of media (much of it in duplicate) is downloaded, into a Media folder, and consists of images of all of the census pages and other source documents.  What is particularly amazing to me is how fast these images are downloaded, as the whole lot of them are generally downloaded faster than I could access just one of them within Ancestry.com!  Clearly, Ancestry must be caching these images, and providing immediate access through the API, but if you try to view one within the Ancestry interface, it appears to ignore the cached version and slowly search and retrieve the original image all over again.  (I won't mention the cryptic names assigned, or the media file duplication, has been reported by others elsewhere.)




#85134 Suggestions for documenting person not on census

Posted by RobJ on 03 August 2017 - 01:41 PM in Discussion

Are you trying to *invent* data?   :)

 

If instead, you are trying to document his absence, when other relatives were at that address, that *is* a problem, worth documenting, but hard to do.  I've a similar case where a 15 year old son is missing from a census record, with older sons and other children still there.  He was reported to have had a tough childhood, and kicked his own son out of the house when he had kids.  But using various genealogical tools, I've had a difficult problem linking a census record when the name isn't present.  First of all, you can't even search for it, you can't search for what ain't there!  You can find it in connection with someone that was present, but you then have to manufacture facts and notes to tell the story, without being able to directly link the census page.  I'd be interested in others' ideas.




#85117 RM keeps freezing

Posted by RobJ on 03 August 2017 - 06:38 AM in Issues

Earlier reports of 'range errors', and my own experience, have pointed toward saving to FamilySearch.  I've had no freezes, and the errors have not been fatal.  I've been able to try again, after doing something else I think, and it would often succeed.  A few could not, unknown error (sorry), possibly the '400 Bad request' error mentioned above (not fatal though).  I've been unable to spot an obvious pattern.




#85036 Roots Magic 7.5.1

Posted by RobJ on 30 July 2017 - 09:01 PM in Issues

I hope you won't be offended by this, but I don't believe you can find any computer or security professional that would ever recommend McAfee.  Most of us would consider McAfee the real problem, and would quickly uninstall every shred of it, then look for any tentacles it tried to leave behind.  Your computer will thank you and run faster with less problems.  If you have to have an anti-malware, try the Microsoft one, or MalwareBytes, or a free one, with unnecessary protections turned off.  Don't listen to hype.  McAfee is a master of hype, but then so are many products.




#84739 Roots Magic 7.5.1

Posted by RobJ on 22 July 2017 - 07:44 AM in Issues

There are hidden characters at the end of that URL.  Just remove them, back to the slash or the 7.




#84695 Removing Reference No. Facts

Posted by RobJ on 20 July 2017 - 08:29 AM in Discussion

Jerry, if the "Like this" button was working, I would certainly have used it!  (it works fine on other IPS forums)




#84677 Family Tree Maker 2017, Roots Magic 7.5 and Ancestry

Posted by RobJ on 19 July 2017 - 07:45 AM in Discussion

And it would be really helpful (if you have the time and interest) if you could document here what you find in your testing, what doesn't work well, what doesn't survive the trip between the 3 products, and what workarounds you find that make it work better.




#84675 Use of Programmable Function Keys

Posted by RobJ on 19 July 2017 - 07:27 AM in RootsMagic Wish List

That's a good idea.  It's small but free.

 

The clipboard manager I have long used is not free, and I see the price has gone up, but it is so powerful!  ClipCache Pro

 

It lets you organize saved snips into folders, like boilerplate etc, and you can assign any key combination to any of them as hotkeys.  You can also set it up to do a series of pastes in order.  Plus at any time access the clipboard history, and lots more (but not free).