Jump to content


owlsquest's Content

There have been 8 items by owlsquest (Search limited from 11-April 20)


By content type

See this member's

Sort by                Order  

#83830 Microsoft Access Project Add-on after Tree Download with RM7.5

Posted by owlsquest on 29 June 2017 - 07:07 PM in Discussion

Thanks mjashby.  Thought as much.  I had just finished a TreeShare on the BETA RM7 earlier in the day then saw the new email.  Removed all BETA files to start fresh with RM7.5  and was hoping that I had not left bits and pices behind to 'muck' up the brand new build.

And RM7.5 is smooth as silk, opens quickly, easy to move from screen to screen, add info and media.  The competitor is soooo sluggish to start, still has buggies and the working screen format is horrible. 

I am very happy to get back to doing what I love, documenting my family's history.




#83790 Microsoft Access Project Add-on after Tree Download with RM7.5

Posted by owlsquest on 28 June 2017 - 09:36 PM in Discussion

First, congratulations to all the BETA testers out there and to RootsMagic for the finished product.  First Beta testing that I have done that met its goal so quickly.

 

Downloaded the new RM 7.5 a few hours ago and from the information on the final BETA email announcing the new RootsMagic version, I started to download the full tree from Ancestry.com and prepared to wait the usual 12-15 hours for my 31K people, 6.82GB media file to download.

 

Was greatly surprised and pleased to see that the full download with all media intact took 4 hours and 2 minutes.  Then a strange 4.86 MB file that I did not see either while Beta testing nor on the previous regular RM7 program showed up, timed at one minute after RootsMagic finished downloading my tree.

 

It carries the same name as the newly downloaded tree with a Microsoft Access Project extension.  Tried to open the file as Properties states it will open with M$ Access 2013 but an error code "Access Data Projects are no longer supported in this version of Access" comes up.

 

Was able to open the file with Notepad++.  Seems to have something to do with SQLite format 3.

Topics that I can see in

Line 1

MatchTable    CREATE INDEX

RecID INTEGER PRIMARY KEY, DupID INTEGER, rmID INTEGER, anID TEXT, Score FLOAT, Percent INTEGER, Name TEXT

(RecID INTEGER PRIMARY KEY, ID1 INTEGER, ID2 TEXT, Linked INTEGER, Name TEXT COLLATE RMNOCASE, Modified INTEGER

Line 18

sets of numbers

C340105609119:1030:1128879      Ù C340105624205:1030:112887946;ø      q C340105623579:1030:112887946:        C340105622946:1030:1128879467Þ  š C340105622330:1030:1128879466

Line 28

CREATE TABLE DupTable (RecID INTEGER PRIMARY KEY, ID1 INTEGER, ID2 TEXT, Linked INTEGER, Name TEXT COLLATE RMNOCASE, Modified INTEGER

Line 30

begins to list people in the tree

   unsure how the order of people is decided and it only appears to be full name - Ref ID.

 

And a notice just popped up saying that the ADP file is gone - confirmed it is gone, though it is still holding on Notepad++ editor.  Full tree now has a modified time approx one hour later that it originally said.

 

Questions are:

  • Is this a legit part of the finalized RootsMagic product?
  • Does the ADP file [since it has now disappeared] mean that the file was still completing the download or sorting of the tree?
  • If it happens again can I work on the tree immediately after TreeShare or will any work done on RootsMagic be lost?
  • Is it something to be concerned about?
  • Is this related to the large size of the downloaded tree? rmgc = 65.08MB; Media folder = 6.82GB, 10713 files.

Thanks for any help

Theresa

 

Computer Specs: ASUS G771J, Windows 7 Pro SP1, Processor: 2.50GHz, RAM: 12.0GB, System: 64-bit

 




#82912 RM7.2.3.0 stalling on backup

Posted by owlsquest on 29 March 2017 - 11:22 AM in Issues

Mervyn,

Firstly, love your Snoopy icon.  Have more Snoopy scrub tops than you could imagine and an awesome Snoopy/Tardis hoodie my kids bought me last Christmas.

 

My son and I believe we have solved almost all of the import problems.  Full tree download took far less time than expected, about 3 hours vs. the 18+ hours last December, very nervous about that.  The latter file had almost 1K people less than this newest download so I was sceptical.  Properties on that newly downloaded tree now show FTM version 2014.1 even though I do not have the macKiev program on my laptop.  This newly downloaded tree still opened in my FTM 2014 which I checked through Help to confirm that my original software version had not been changed.  Tried to export to FTM2012 but FTM stalled, “export process failed because an error occurred”.  Would export to FTM2012 just fine last week during this mess, just would not then import to RM.  Took the full backup suggestion from Renee, changed format to zip and it opened in RM just fine.

Did a quick check of media for some problem people to find it was still missing, red 'x' noted.  Checked with those specific people on Ancestry tree only to find that many of the media that had been uploaded from my laptop over the past few months now had the dreaded grey "missing" icon.  Unsure how many more there are.

 

I also opened the newest email from macKiev last night about FTM2017 which now, at least to me, explains why I have been having so much trouble over the past month, the last week in particular.  $$$$ signs come to mind.  With the loss of Treesync expected tonight and the major jump in cost if you don't buy in before midnight Thursday, I reluctantly purchased the upgrade, hopefully so my online tree will not be damaged any more than it has while I await the upgrade for RM7.  BTW, a FTM2017 family license for three computers is an additional $30 Canadian on top of the upgrade price.  Did not purchase that license.  Just checked and Rootsmagic still grants a family licence, which saved my buns as I worked through this FTM mess over the past week.

 

I am unsure how to sort the RM7 media file for all the broken media in my tree so am scrolling through the file image by image and noting red x’s and their related person.  I have 10.5+K media items to check through and it appears that on rough estimate [left off at 1012 media items] that about 10% are red x’s; not in any particular order, tagged to a person, date image uploaded or saved to the tree from another AMT.

 

I am heartbroken over all the work I have put in over the past 20+ years as our family historian with my family members depending on me to "pull it together" only to have a company treat its customers with such distain.  I only moved from Ancestral Quest (over 20+ year usage) to FTM in August 2015, so my family could follow my progress online.  I feel so abused by Ancestry over the past while and am still angry when they left thousand plus to swing in the wind in Dec 2015.

 

I eagerly await when RootsMagic brings out their sync update.  RM has been much more reputable and upfront in insisting that their product have as many bugs removed and be stable before bringing it out to the public plus they are very courteous and informative when I chat or call.  Once my tree is imported to the updated RM7, I will never go back to FTM again.

 

Last thoughts.  "Bad Form!!!!" to Ancestry and macKiev.  You have forgotten what you learned in kindergarten and have forgotten how to play in the sandbox.

Theresa




#82864 RM7.2.3.0 stalling on backup

Posted by owlsquest on 26 March 2017 - 06:01 PM in Issues

After doing some work on Ancestry.com today, I ran a sync in preparation to doing another FTM backup.  Couldn't figure out where it sent the profile as I shutdown so we could go out to Geocache, so had to do a search on Mydocs and found a new FamilyTreeMaker folder that I didn't make.  When clicking on the FTM file to open it, noticed that the icon on the bottom tray looked different and now said FTM 2014.1.  I didn't agree to anything on the sync, just the usual download but my son (the IT specialist) said Ancestry may have added 2014.1 capability to all sync function even though my FTM program still says it is 2014.  He said the change to 2014.1 may be miniscule enough that my original non-macKiev program can run the family tree which is why I didn't notice a change.

I made 3 FTM backups to three different locations over the past week hoping that one of them was not corrupted only to now find that they are all of macKiev 2014.1 formatted.

Opened an older file from last summer into the 2014 program, did a backup and now it too says 2014.1 format.  My son checked Ancestry.com's EULA but didn't see anything specific to accepting an update to the macKiev format but it does say you agree to any program changes when you use the program.

Looks to both of us that there is now something in the sync download that changes the file though possibly only the newest media and people changes have been affected which has caused RM to stall when importing.  Graeme suggested I start from scratch again so am in the process of downloading the full tree so everything has the 2014.1 update.  Download will probably take until tomorrow for all media to come in.  Will then do an export at the FTM2012 level and try an RM7 import.

Frustrating if Ancestry.com has forced an update on subscribers making it difficult to import their tree to Rootsmagic.  Very bad form.

Theresa




#82854 RM7.2.3.0 stalling on backup

Posted by owlsquest on 26 March 2017 - 08:58 AM in Issues

Renee,

My laptop is on its second reformat right now and my son said he will do a third before Win7Pro 64x will be installed again. 

So loaded RM7 and installed updates to my daughter's laptop (running Win10Pro 64x) as well as the older copy of FTM2014 program saved to external from Sep 2016.  Bypassing 2014.1 and a newer FTM version from January 2017 this time after thinking the FTM update last January may have had bits of macKiev in it and causing grief. 

Downloaded a fresh tree from Ancestry.com to do another import to RM.  Compacted FTM tree, confirmed all media present in folder,  so zipped ftmb.  First attempt and Media again needing to be linked to RM tree as expected, so link repair started.  Assumed daughter's computer had stalled after about 9 hours, stuck at about 85% and shut down RM through Task Manager. Download from Ancestry took more than 7 hours so assumed that import would take that long.

Redid a fresh import to RM7 yesterday and as expected Media needed to be relinked to RM7 tree again.  Looked like it was going to take more time (already at 9 + hours) and as FTM media folder is quite large at 5.85GB, left it at about 85% complete and running overnight to finish. 

This morning still showing at about 85% complete now, more than 17 hours later.  Task Manager showed Rootsmagic still running happily and responding but track on "Relinking media" bar not moving even after waiting another hour or so this morning, so shut down program through Task Manager.

Unsure now what I am missing.  RM from import itself looks fine on opening and if I ignore missing media, people info appears to be where it should be, no error 'flags' on a quick go through.  Media that I do see is present with a few red 'x' present.

Could something on the downloads from Ancestry be the problem or maybe the size of my tree - 29781 people, the media file at 5.85GB.  RM 7 was working fine until the last backup about a week ago.  My tree size has been growing over the past six months or so as I add new media and people, but the stats I keep show that previous backups were still working with over 25K people and a media file larger than 4 GB and with media not needing to be relinked.

I agree with zhangrau that I need to keep the character line shorter but RM7 backup and now Media relinking seem to be affected now.   Maybe the backup program copies on my external are corrupted by being in contact with my laptop?  Possibly grasping at straws but I am frustrated.  My son says it is a possiblilty that something downloaded from Ancestry to cause problems and could have in the background fussed with other programs but then all the programs on my laptop started giving grief after installing that tax program.  Doesn't explain why same thing is happening on my daughter's OS.  Definitely something is not happy working with others in the sandbox.  Will need to rethink this through.

Thank you both for your assistance in this.  I have two 12 hour shifts Monday and Tuesday but am on Spring Break from the school I work at so have more free time later in the week to reload programs to my 'clean' laptop.  Will have another go over the next few days with the new OS install and post back results.

Theresa




#82828 RM7.2.3.0 stalling on backup

Posted by owlsquest on 23 March 2017 - 09:06 AM in Issues

zhangrau
Thanks for the quick reply.
I am running Win 7 Pro 64-bit.  Avoiding Win10 like the plague after M$ snuck it in back in Sep 2015.  Took 3 re-formats to get back to a stable Win 7.

So threw the whole path into Notepad++, Word 2013 and Corel WPX7 for character count charac with no spaces  116  (103), charac without blanks 134 (122); brackets are for rmgc file.

C:\Users\Snowy\Documents\A N C E S T R Y\___RootsMagic\FTM2014 for new file\All the Strength of Our Ancestors - 2016-12-24-17.04 Media
and
C:\Users\Snowy\Documents\A N C E S T R Y\___RootsMagic\FTM2014 for new file\All The Strength of Our Ancestors - 2017-03-19.rmgc

Then opened new folder [Rootsmagic] on MyDocs, removed spaces from file name [AllTheStrengthofOurAncestors-2017-03-19] and import worked fine.  Drilldown is not so long now.  RM opened fine and was able to move around people without problems.  Backup worked quicker than I thought it would.  There is an 'rmgb' file on MYDocs but nothing in the Rootsmagic folder I directed the backup to go to.  There is no media file in either that folder or in the MyDocs folder.  Checked through 'search' in case the Media folder went somewhere unexpected but nothing.  Deleted the rmgb and redid a backup request again directing backup to the Rootsmagic folder but had same results.

 

Now thinking maybe one of the media names may be the problem thought I number code my own media.  May have picked up a long character from Ancestry.com that I missed as I did +++ work over the past few weeks before the last sync.  Will go through the FTM media folder tonight looking for that.

Renee  (eight hours after I did above)
Imported FTM file as you suggested and to a single folder on MyDocs [Rootsmagic2], assuming a similar problem as zhangrau above suggested.  Imported fine from opened zip file.  Now all media are showing with red X.  

 

UPDATE - 23 Mar at 0900 MDT

Now suspecting that installation of a 2016 Income Tax program last week, which demanded massive uploader updates to Windows before it would open may have caused major problems to the OS.  Been using the same tax product for more than 20 years and this is the first time it gave no end of grief on install and running.  Now other programs on this laptop are not working as cleanly as before.  Did a System Restore back three points and still having grief.  My son who is IT trained is coming on the weekend to see if M$ has caused the problems.

I do want this to be fixed, so should I repost to this same topic on Saturday if we do or do not resolve the problem(s) or let this topic close out and start a new one.  The new topic if there are still problems or if my son and I have been able to repair the OS, might be useful to anyone else who suddenly has similar problems.

 

Thank you for your patience.

Theresa




#82813 RM7.2.3.0 stalling on backup

Posted by owlsquest on 21 March 2017 - 10:08 PM in Issues

zhangrau,

Media are stored Local drive  as in "Documents\A N C E S T R Y\___RootsMagic\FTM2014 for new file\All the Strength of Our Ancestors - 2016-12-24-17.04 Media"

 

Renee,

FTM file was compacted 2.4% while it was open in FTM2014 then that file was imported to RM.

 

kbens0n

Tried backing up to external drive and to local drive in Documents.  Just tried again.   First backup without checking 'Backup media files' worked fine.  Second try with 'Backup media files' to same backup folder in MyDocs stalled.  Shut down after more than 30 minutes with no activity.

 

Could the media file be too large for RM to handle?  Currently sitting at 5.87 GB with 10,431 files.  Don't believe that backup file without media could be the problem as it appears to backup fine but FTM file is 132 MB and when imported to RM is 52.5 MB.  Was importing compacted FTM files and backing up just fine until this last try.  Made sure that the FTM tree has not been updated to macKiev 2014.1.

 

Now that I think about it, there was an update to RM just before I had problems.  Could the update not have installed properly?  Can I go back to an earlier version to confirm the problem started with the newest update or that the FTM file does open and backup in an earlier version?

 

Frustrating as RM was working fine and I was spending more time with it and only imported the larger tree so I wouldn't need to manually enter more than 200 people/media as RM doesn't sync yet.

 

Would really like to find a fix for this as RM is definitely more user friendly, especially with this large tree of almost 30K people.

Thanks for all your help.




#82794 RM7.2.3.0 stalling on backup

Posted by owlsquest on 19 March 2017 - 07:59 PM in Issues

FTM file will import to RM7.2.3.0 but will not make backup file either by using toolbar or by clicking Exit which then prompts to backup.  On backup, file hangs for up to 30 minutes, maybe longer but shutdown program after that through Task Manager which shows 'Not Responding' all three times.  Have tried this three times.  *.rmgc file does show in proper folder , file opens easily in RM and a quick check after opening file in RM7 program shows that media is linked but still cannot backup file.
FTM database was compacted before attempting to load FTM file into RM and I have confirmed that file is FTM2014 v.22.0.0.1410 and not 2014.1.
First time this has happened.  Imported FTM file with 29,698 people and 5.2GB of media end of February without problems.  File now is 29,731 people and 5.82GB of media.
I am running Win 7 Pro 64x.

Problem Signature shows two sets of hang signature; 71f1 and 2048 after three failures.  Details below.

Thank you for assistance.

 

Problem signature:
  Problem Event Name:    AppHangB1
  Application Name:    RootsMagic.exe
  Application Version:    7.2.3.0
  Application Timestamp:    5887b2fc
  Hang Signature:    71f1
  Hang Type:    2048
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    4105
  Additional Hang Signature 1:    71f15326c811962bae229b54141ef98d
  Additional Hang Signature 2:    632f
  Additional Hang Signature 3:    632f937eea3a5597e73535463e09944a
  Additional Hang Signature 4:    71f1
  Additional Hang Signature 5:    71f15326c811962bae229b54141ef98d

 

Below seen with first and third backup hang.

Problem signature:
  Problem Event Name:    AppHangB1
  Application Name:    RootsMagic.exe
  Application Version:    7.2.3.0
  Application Timestamp:    5887b2fc
  Hang Signature:    60ac
  Hang Type:    2048
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    4105
  Additional Hang Signature 1:    60ac140cd2ca6017c6c490e4cf84b13e
  Additional Hang Signature 2:    6fb2
  Additional Hang Signature 3:    6fb2552852a9c8e3fdc6e76f68678db3
  Additional Hang Signature 4:    60ac
  Additional Hang Signature 5:    60ac140cd2ca6017c6c490e4cf84b13e
  Additional Hang Signature 6:    6fb2
  Additional Hang Signature 7:    6fb2552852a9c8e3fdc6e76f68678db3