Jump to content

kcard's Content

There have been 58 items by kcard (Search limited from 12-April 20)

By content type

See this member's

Sort by                Order  

#73602 Update to 7.0.7????

Posted by kcard on 08 August 2015 - 08:57 AM in RootsMagic for Mac

Well, I finally got 7.0.7. The directions aren't very clear, IMHO. Download first from the newsletter link to get to 7.0.6, then download the update from within RM.

#73601 Update to 7.0.7????

Posted by kcard on 08 August 2015 - 07:29 AM in RootsMagic for Mac

I got the newsletter which said to click the link to get version 7.0.7 for the Mac. I did but when I checked from the RootsMagic menu, I get Version 7.0 ( When I check from within RM->Help menu>About RM, I get Version 7.0.6 (16 July 2015). So, what should I do now? I followed the directions update from their link but that only got me to 7.0.6.

#73595 Best way save your pics on a Mac, iphotos or file on desktop?

Posted by kcard on 07 August 2015 - 06:53 PM in RootsMagic for Mac

I don't know if its still this way, but it used to be that a lot of files on your Mac Desktop tended to slow down the computer. At any rate, I only use the Desktop as a temporary holding area for things I'm currently working on. All other files need to go in your Home Folder. I store all my genealogy files in a folder I call Family History Files. Within that are many, but the main ones are Surnames for all my documents filed under various surnames/given names; and my Genealogy Photos folder. By the way, if you want to have your Genealogy folder on the Desktop, I would create an alias of it to store there for easy access and move the original folder to your User/Home folder.



#73564 Saving a blank file?

Posted by kcard on 06 August 2015 - 09:46 PM in Discussion

Tom ..... I'm guessing this will not work on a Mac on RM under MacBridge?

#73554 Saving a blank file?

Posted by kcard on 06 August 2015 - 03:10 PM in Discussion

I've been thinking about this business of creating a new, blank database that has the complete environment of your old database, except with no people. For years, the wish from many users on this forum has been for a way to do a bulk delete of people from a database. There are several ways that such a feature would be useful. For example, you could just copy a database and then delete all the people from the copy of the database. Your new (and now empty) database would have the desired characteristic of having all the lists from your previous database.


RM has stated that they will never implement a bulk delete feature because of the danger that a user will do a bulk delete of everybody from their production database and not have a backup. I believe that a bulk delete could be made safe by incorporating a required backup into the bulk delete procedure. But I'm not the designer of RM and I'm not the vendor, so fair enough.


Nevertheless, I wonder if RM might consider the following to be safe enough. Suppose there was a new feature that could be invoked as File->Create blank database from current database. It would differ from the Import Lists process in that it would preserve everything from the old database except the people, including sentence template customizations from the old database. The old database would not be deleted, and indeed the old database would not be changed at all. Hence, there would be no bulk delete.


I very much appreciate the new Import Lists feature, but it doesn't  completely meet the need to create a new, blank database just like an existing one except with no people. The failure to include sentence template customizations for built-in facts in the Import Lists feature is a real killer for me.




Jerry, I TOTALLY agree with your idea! There has to be something that can be done in future versions to implement the ideas you put forth. Other programs have accomplished it. For example, Reunion 11 for Macs, allows you to export a Family File and you choose the options ..... to save all or a portion of people, sources, multimedia, and Logs. This allows you to export a blank family file with no people but that includes sources with their types and fields (templates). It's very helpful once you've gotten one family file set up the way you want it. Hopefully, RM will consider something like it.

#73553 Saving a blank file?

Posted by kcard on 06 August 2015 - 02:59 PM in Discussion

Alt Birth is not a built-in fact so its sentence template should import just fine. I just did a test, and it imported for me just fine. Are you sure that your Alt Birth fact had a sentence template in the original database? Are you sure you imported the fact list?



Yes to both.

#73550 Saving a blank file?

Posted by kcard on 06 August 2015 - 01:31 PM in Discussion

Yes in RM 7.

Create a new database. Go to File, Import lists in the new database.

Pick the database you want to import the lists from and mark which lists to import.

User defined fact default sentences will be imported. You will need to copy and paste changed RM defined fact sentences, added roles, and role sentences from the other database as wanted.

Backup the new template database and restore it as you want to use it amd rename the new database. Or, just copy the database and give it your new database name. I just copy the template database.

I just tried this and the sentences that I created for Fact Types are NOT being imported.  For instance, there was no default sentence for Alt. Birth so I made one in the Template file I created. From my main file, I did the Import Lists and chose the Template File and the lists I wanted. But it did not get imported into my main file.... that one still says [NEED TO DEFINE SENTENCE: Alt.Birth. Should this be imported as a User defined fact sentence? If it doesn't, then this Import Lists tool isn't as helpful as I thought it would be!

#73547 Saving a blank file?

Posted by kcard on 06 August 2015 - 11:56 AM in Discussion

Thank you, Laura. That's exactly what I wanted to know.



#73541 Saving a blank file?

Posted by kcard on 06 August 2015 - 08:20 AM in Discussion

I am using RM7 under MacBridge ...... but I imagine that this question applies to all versions ..... I am currently updating and modifying the sentence templates in my Fact Type List. When I'm finished with it, is there a way to save a backup of this family file WITHOUT any people, just everything else such as the Fact Type List and Source Templates? That way I could use the "empty" file to import other files into as needed and have all the sentence and source templates I have worked on in place.



#72906 EMERGENCY! Changed path for saving file, now cannot find saved files

Posted by kcard on 22 June 2015 - 11:37 AM in RootsMagic for Mac

Thank you, Renee. It it is good to know that it's still being worked on! I will look forward to it.

#72878 EMERGENCY! Changed path for saving file, now cannot find saved files

Posted by kcard on 19 June 2015 - 09:02 PM in RootsMagic for Mac

Just not possible to make that feature work using MacBridge. We need the native Mac version to be able to upload directly to Dropbox. That is why the feature doesn't even appear in the File menu. The best you can do is set the folder to backup to Dropbox. Go to Tools>Program Options>Folders and set it to your Dropbox location on your Mac.

So, Renee, are we getting close to a native Mac version? I think it's sorely needed!

#70120 Floating Point errors

Posted by kcard on 20 January 2015 - 05:48 PM in RootsMagic for Mac

I tried to overlook this error, but it's become more of a pain making it not worth using MacBridge. I have moved away from RM and gone back to Reunion. At least that works all of the time.  And, by the way, this error reared its ugly head whenever I went into another program and returned back to RM. It would be nice if this could get fixed and not just hear that the problem is being worked on, or passed on, or whatever.

#69400 Invalid floating point operation

Posted by kcard on 01 January 2015 - 01:38 PM in RootsMagic for Mac

I just noticed something strange .... at least I think so. Like a lot of others, I was getting the floating point error very often..... every time I left RM to work in another app. So, I tried out CrossOver for a few days with RM7 and decided I didn't like it enough to purchase it. I was using the same database but two different copies of the RM app. So, back I went to using RM under MacBridge. In the last two days since I've been back using RM under MacBridge, I have not had one, single floating point error! Not being a programmer or software engineer of any type, I don't know if that is significant to figuring out this problem? I just wanted to report it. 

#69329 Invalid floating point operation

Posted by kcard on 29 December 2014 - 12:00 PM in RootsMagic for Mac


Great. (That is why I like the RM forums - lots of followers who are happy to chip in when they can.)


On the DPI front, I've decided that 200 is too high and am now back down to 160. It is a compromise, but am doing a lot of FSFT stuff this afternoon (UK time) and the side by side display was displaying too little at 200.


Well, these old eyes are using 140 dpi.  :)  Now if I could just get it to close a window when I press command+w rather than bring up web tags, I'd be totally happy.  :)

#69327 Invalid floating point operation

Posted by kcard on 29 December 2014 - 11:12 AM in RootsMagic for Mac

As an experiment, I've just played with my RM7 under CrossOver setup. At present, the bottle is set to Windows XP. When I go into modify the folders using the browse "...", it hangs and I have to force quit RM7. However, if I type into one of the fields, it will quite happily accept a change. Have you tried just typing in the full path name, such as Y:\Documents\RM\CO-RM7\Files. The Y disk is mapped by CrossOver to your Mac home directory. Note the direction of the (back) slashes. 

LOL ....... That worked! I just pasted in the path in all fields that I wanted and it all worked as it should. (From CrossOver using Win XP virtual machine.) That was just way too easy, which is why I didn't figure it out myself, LOL. Functional fixedness, that's me.  :)  Anyway, thank you again J P!

#69324 Invalid floating point operation

Posted by kcard on 29 December 2014 - 10:38 AM in RootsMagic for Mac

Sorry but I'm out of ideas - it just worked for me. I'm a little confused by your reference to playing with RM7 under CrossOver. That suggests that you were using an RM file without problems and I assume that it was being stored somewhere. Am I missing something?

Just one thing, though. Until you get things working OK (note the confident tone there), I would suggest that you use separate directories for MacBridge and CrossOver. Just duplicate what you have already and, when you can, point the folder definitions as required.


I have been using RM7 under MacBridge with success except for the invalid floating point issue popping up quite often and the font size issue. I decided to try using CrossOver directly as I'd read that those problems were not an issue using CO. I just had hoped to avoid the above issues with CrossOver.


RM7 is in two directories on my computer ....... the normal Applications folder and the CrossOver folder within my user directory/Applications. I was already using RM7 when I started with CrossOver and downloaded a fresh copy of RM7 to use with it. I am using the same database file for each copy of the app but not at the same time. 


As an experiment, I just duplicated my database file and moved it to another location. I launched RM7 from CrossOver (Win 7 VM). It launched OK but when I tried to open the duplicate database file I had moved to another location, I got the error message.


Oh well. It's not a huge deal. I would have liked to get it working correctly, to use RM without the floating point error and the font size problem. But, I will just continue to use RM7 under MacBridge and wait impatiently for a native Mac version.


Thank you for trying to help!

#69321 Invalid floating point operation

Posted by kcard on 29 December 2014 - 08:43 AM in RootsMagic for Mac

Thank you, J P for your quick reply. That gave me the needed info......... But, it didn't work for me. I changed to Win 7, clicked apply, then OK, and launched the RM7 from CrossOver. Before I can do anything, though, I get an error message coming up "External Exception C06D007F." It won't allow me to do anything. Before trying to change the folder settings, I had been playing with RM7 under CrossOver and can see that the floating point error never occurred and I was able to change the DPI settings to something more acceptable for me. Now to figure out this folder setting issue. Any ideas on what this error is all about? I do have my original RM7 under MacBridge still installed...... but not open. Both use the same database,

#69315 Invalid floating point operation

Posted by kcard on 28 December 2014 - 11:14 PM in RootsMagic for Mac

I run both RM6 and RM7 under CrossOver, though as my "production" use is still on RM6, I have used that more than RM7 in the last few weeks. However, I have NEVER seen the problem under CrossOver, only under MacBridge, both with RM6 and RM7.

What are you wanting to know about the RM7 installation under CrossOver? I used the unofficial Tie for RM7 - CrossOver officially supports RM3 to RM6, but not RM7 (unless that has changed recently). The only problem I had was in defining the folders for my RM files - for some reason the RM "file manager browse" function just hangs in the latest couple of levels of CrossOver V14, but the way round that is to switch the Virtual machine type from Windows XP to Windows 7, use the browse function to point to the folders, and then switch the virtual machine type back to Windows XP. (This has been accepted by CossOver as a bug with RM6 and they suggested the bypass, which has worked fine for me on both RM6 and RM7.)

I'm currently using Yosemite 10.10.1, though was running Mavericks 10.9.5 until the beginning of December.

Does that help? Please feel free to ask any supplementaries.

I'm trying out CrossOver. I have the same problem not being able to define the folders ..... it hangs. So, my question is ..... how do I change the virtual machine type from Win XP to Windows 7? 



#67956 Place Database download?

Posted by kcard on 28 November 2014 - 05:39 PM in RootsMagic for Mac

OK. Thank you!

#67906 Place Database download?

Posted by kcard on 28 November 2014 - 09:46 AM in RootsMagic for Mac

Is there any reason for a MacBridge user to download the Place Database 7? Will it even work under MacBridge or is it just for RM Windows?

#67905 Data Clean

Posted by kcard on 28 November 2014 - 09:40 AM in RootsMagic for Mac

I was so happy to see Data Clean in the new MacBridge 7/RootsMagic 7! What a great tool to clean up your data and make your naming conventions and places consistent. 


I'm really pleased with RootsMagic and look forward to when the Mac version comes out, with, hopefully, a full feature set ..... like mapping.  :)


Thank you to all you RM folks for all your efforts. It is very much appreciated!

#67904 Opening older RM files in MacBridge7

Posted by kcard on 28 November 2014 - 09:30 AM in RootsMagic for Mac



You should be able to open your RM6 files under MacBridge 7 without having to gedcom them over. In my case, I was using RM6 within Windows on my Mac by using Parallels. I had set it up long ago to store my database files and all my documents and media on my Mac side. So, the file system was already in place when I started using MacBridge. At this point, the only "problem" I have had, is that to create a gedcom from my MB, the file paths are wrong. For instance, the path might be Y:\Users\Documents\Genealogy\..... I have to open the gedcom in TextEdit, replace all \ with / and replace the Y drive with my own hard drive. It's pretty quick and easy to do. 


Could this file path issue by your problem? Or file permissions if you're copying files from a PC to your Mac?

#67660 Group for Source Research Notes?

Posted by kcard on 25 November 2014 - 01:46 PM in Discussion

Thank you, Laura and Rene!! That did the trick. Appreciate your help.

#67655 Group for Source Research Notes?

Posted by kcard on 25 November 2014 - 01:25 PM in Discussion



I did what you suggested, using all four of the fields. It did return more names, but many are still missing. The ones I know for sure that are missing are census entries .... and that's a lot. I had converted a lot (but not all) of my census entries to show household info in the Source Detail text (research notes) rather than have that info in each Note field for the census. Nothing I have put into that Detail Text field in the Edit Source window (that shows in the Research Notes field) appears in my group. These sources are mostly Free Form, having come over from Legacy. Could that have something to do with it?


Hmmm.....I just ran another test..... This time I created a new source from one of the templates (not free form) and added it to an individual who does NOT appear in this group I created. I re-marked the group and that person still does not appear in it. So, it would appear that the problem is that anything in that particular field is not able to be marked for inclusion in a group. That's not good.

#67649 Group for Source Research Notes?

Posted by kcard on 25 November 2014 - 11:59 AM in Discussion

I am trying to create a group that will show all people using Sources that contain any comment, either in the Master Text field or the Detail Text field. This is what I'm doing, but I'm not getting the results I want:


  1. Create a new group
  2. In Select People screen I click Mark People/Select people by data fields
  3. In the next window I choose:
  4. Source (general) --- comment is not blank  OR
  5. Source (general) --- research note is not blank   OR
  6. Source (general) --- detail comment is not blank
  7. I click OK and it returns with a group of people. But this list only seems to include people using sources that have a Master Text which shows in the citation manager window as Source text/comments. No one on the list has source entries that include Detail text (Research notes/comments in Citation Manager window) as I would expect. 

The Detail Text field is what I've been using to document, for instance, other members in a household for the census. I would like to keep track of these kinds of entries.


What am I doing wrong?