Jump to content


Emilito's Content

There have been 9 items by Emilito (Search limited from 14-November 18)


By content type

See this member's

Sort by                Order  

#37689 Estimating ages with "before, after, between, appx." dates

Posted by Emilito on 13 July 2010 - 09:16 AM in RootsMagic Wish List

Even when dates are qualified (before 1844, between 1923 and 1938, etc), the calculated ages are presented as absolute E.g. for someone known to be born in 1800 that was listed as having died between 1850 and 1860, the current listing is "died between 1850 and 1860 at the age of 50" ... I would prefer that ages calculated by qualified dates be qualified themselves. E.g. that it say "died between 1850 and 1860 between the ages of 50 and 60") ... same for before, "before 1850 less than 50 years old", for after "after 1850 more than 50 years old" ... or something like that. (similarly for "approximately" ... )

Emil Signes



#36626 Corrupt Database, Backups & Recovery Therefrom

Posted by Emilito on 14 June 2010 - 07:37 AM in Issues

As the person that first reported this problem, I can report that Parallels WAS the culprit... And to the comment something to the effect that "I don't see why old backups were corrupt," this was an insidious bug: when I restored those (good) backups, the resulting db was immediately corrupted. I installed the suggested fix (thanks to kbens0n for explaining that the trailing period was causing the link not to work; I hadn't figured that out). Yesterday I was able to apply the fix and it worked. Ironically the fix was to an add-on to Parallels (Parallels Tools) not Parallels itself, so even after applying the fix there was no new version number, nothing to indicate Parallels was updated. Bottom line, however, it works.

Apologies to all those that were panicked by my issues; hopefully there aren't too many Parallels users that have had similar stories (though I can't imagine I'm the only one).

The guilty version was released in mid-March; I restored a backup from early March. Between that time and now I only added one person (and I know who that is) and possibly made a few minor changes to the db. In the end, for me this potential "life's work disaster" has ended up as a very nerve-wracking time-consuming issue with no significant data loss.

I am very surprised however, that this Parallels issue, potentially damaging to so many other users of Windows database products (Quicken, etc etc - apps that I also use), was so little known. And am thrilled that the info was posted here.

Finally, as we now know that backups cannot be verified till they are restored, what is the recommended procedure for assuring that backups are, indeed, good? This still has potentially very scary outcomes.

Emil



#36624 Corrupt Database, Backups & Recovery Therefrom

Posted by Emilito on 14 June 2010 - 07:00 AM in Issues

Above link is failing because the trailing period is being included in the URL. Here's a working link:

http://kb.parrallels.com/en/8296




#35955 Corrupt Backup

Posted by Emilito on 21 May 2010 - 03:29 PM in Discussion

Background: I am running RM 4 on XP running on Parallels on a Mac... I have been running RM this way for more than a year, perhaps two.This morning I updated to 4.0.8.4 (which I don't think had anything to do with my problem, but ... to give you all the info I have).

I was working on the db for the first time in a few weeks.

While I was working, I suddenly got a message that said "SQLite Error 11 - database is malformed" ... I couldn't get it to work again.

Roots Magic Support said this was a corrupt database and that I'd have to restore from a backup. My last backup was May 1. And this is probably the last time I worked on RM, so I wasn't too worried.

I restored the backup and everything seemed ok, and I was navigating around and everything seemed to work. Then, to check the number of records (I had this number 9539 in my head) I clicked on "File - Properties" ... and I got the SQLite Error 11 message again.

When I checked with RM Support I was told that you don't know if a backup is good till you restore it.

Well, that just fills me with terror ... I tried to export to GEDCOM, and it only got up to 570 people and then gave me the same error.

So - what do I do now? Yes, I know I can go back to the April backup, and then the March, etc ... but Lord knows what I'll have missed ... I've got a large part of my life invested in this entire project, and now it seems as though, even though I back up everytime I add a person or two, there is no guarantee that the backup is good ... What do I do to ensure that? Export every backup to GEDCOM and then reimport into another db?

It's a very frightening prospect and I hope someone out there has some suggestions!!

(PS - I'm pretty sure the db I have up right now has all the records in it - is there a way I can find out what the error is?)

Emil Signes



#31507 Search gives improper results

Posted by Emilito on 19 November 2009 - 11:30 PM in Issues

Hello friend,

Yeah, it's other than the Discussion Forums:

http://support.roots...in/Default.aspx

Click on <Submit a ticket>


I just discovered something curious (besides no action taken)... At the beginning of the "Go"s, there's a Göbel and a Gödel, then Godoy, then ... then Goetz ... later, after González and others, there's a Görl ... this is curious because in the case of the umlaut, this is sorting as I would like it to, o and ö sorting together ... according to what I've been told about Unicode, all the Gö's should occur either before or after all the Go's (depending on where o and ö stand with respect to each other." But they don't ... Odd ...



#31506 Search gives improper results

Posted by Emilito on 19 November 2009 - 11:23 PM in Issues

OK, thanks, support ticket submitted. My curiosity is overwhelming :(

emilio




#31102 Search gives improper results

Posted by Emilito on 02 November 2009 - 08:51 PM in Issues

Hello friend,

Yeah, it's other than the Discussin Forums:

http://support.roots...in/Default.aspx

Click on <Submit a ticket>


OK, thanks, support ticket submitted. My curiosity is overwhelming :(

emilio



#31098 Search gives improper results

Posted by Emilito on 02 November 2009 - 07:37 PM in Issues

The "González González" instance might have something to do with having a space separator, maybe.
Not getting Goetz with proper leading characters is the most confusing.


Yep, wierd. And try this...checking and unchecking Alternate Names will result in different results when typing those leading characters, even though neither result is an Alternate Name itself. Must be the Unicode search routines still need to be refined or a bug squashed. I had suggested that Emilio submit a support ticket, but am not sure he has...


Oh, I thought you meant I should post this problem here ... I guess I don't know how to submit a support ticket ... I'll look to figure it out, or drop me a note ... sorry ...



#31057 Search gives improper results

Posted by Emilito on 01 November 2009 - 07:03 PM in Issues

There are several aspects to this. The most glaring is the following. I have people in my database named "Goetz" ... when, however, I search for them, I type the letters "Go" and the search skips right by them (and also names like Godoy, Goldman, Goldstein, and goes to González. (granted there is an accented letter in González, but it is in the 5th place and should not affect this search.) I have to cursor back line by line to get to all these previous names. Other aspects of this topic - but not include the inability to use a generic letter to search for both the unaccented and accented versions, which was possible in RM3. This latter issue has been blamed on Unicode, but there is no reason for the former: Goetz should be found. I have shared my database with advanced and knowledgeable users and they too are baffled. None of these issues was present in RM3 and they are a huge problem.