Jump to content


Jillaine Smith's Content

There have been 4 items by Jillaine Smith (Search limited from 07-August 19)


By content type

See this member's

Sort by                Order  

#97688 RM7 on Mac 10.14 (Mojave) - wine pre-loader?

Posted by Jillaine Smith on 10 July 2020 - 06:52 AM in RootsMagic for Mac

Second use after all that broohah up there seems to be better, more stable. No error messages or freezing... yet.  I have to go back to work so I won't get to more messing around until later.

 

Thanks again for your help.




#97687 RM7 on Mac 10.14 (Mojave) - wine pre-loader?

Posted by Jillaine Smith on 10 July 2020 - 06:35 AM in RootsMagic for Mac

Okay... I removed RM7 per above. Then I installed the beta RM7+wrapper for Catalina because it says it will work on previous OS's. Upon installation, it said an update was available so I installed the update.

 

I was able to open the rmgc file that I'd created before with the gedcom import.

 

I went to the source check mark and double clicked. I got the message to install gecko.  The beta wrapper instructions said to select install. So I did.

 

I started to get the dull-thud sound again and things appeared to be frozen. I did see I was able to select Quit RootsMagic from the File menu, so I did.

 

I got the typical backup or skip message. I skipped. AND THEN instead of quitting, it brought me to the source screen for the source I had previously selected before getting the "install gecko" message. 

 

THEN the screen cleared and I got a small error message box that says: "Access violation at address 00593857 in module 'Rootsmagic.exe'. Read of address 00000010."

 

Going back in...

 

P.S. when I clicked OK on that error message, another message appeared briefly about a control window. I didn't catch the exact wording.




#97686 RM7 on Mac 10.14 (Mojave) - wine pre-loader?

Posted by Jillaine Smith on 10 July 2020 - 06:07 AM in RootsMagic for Mac

Thank you both. Unfortunately, my old rmgc file is older than my gedcom. I must have used Reunion in between at some point. (I had both on the old computer that died.)

 

I believe there are uninstall / reinstall instructions somewhere... I'll go look.

 

What is Mac OS Beta? 

 

Should I upgrade my Mac OS to 10.15 ?

 

FYI, while waiting (and because I was anxious to get at my sources), I downloaded and installed Gramps. Blech... 




#97683 RM7 on Mac 10.14 (Mojave) - wine pre-loader?

Posted by Jillaine Smith on 09 July 2020 - 01:54 PM in RootsMagic for Mac

I had a long hiatus from RootsMagic when my old Macbook died last year.

 

I now have a Macbook Air running macOS Mojave 10.14.6.

 

I just re-installed RM7, imported my old GEDCOM.

 

All seemed to be going okay. I went to look at a source on a particular fact. When I double-clicked on the source checkmark next to the fact, I got some weird message about a wine pre-loader.  Specifically, it said: 

 

"Wine could not find a Gecko package which is needed for applications embedding HTML to work correctly. Wine can automatically download and install it for you.  Note: it is recommended to use our distribution's packages instead. See https://wiki.winehq.org/Geckofor details."

 

EDITED TO ADD: I just went to that website, and it's scary as all get-out. Can someone just tell me what I need to do in order to run RM7 on my Mac?

 

My options were CANCEL and INSTALL.  I cancelled.  The "wine..." error message box went away.

 

And basically RM froze.  When I went to force-quit, I saw two entries for wine pre-loader. I force-quit them. 

 

So I'm going back in... My recently created rm file doesn't show up in Open Recent...

But I was able to find it with Open File using windows (which is weird, because it brought up the typical Apple file open dialog box).

 

I had exactly the same experience as before (though this time I clicked on "Sources" button under "Person details" instead of the check mark in the Source column of the fact line), but this time, after clicking CANCEL on the error message, and after the error message window closed,  I got that dull-thud sound any time I tried to do anything else. I was able to command-tab to another app (this one where I'm typing this right now). 

 

So I force-quit RM7 instead. 

 

I'm thinking that my next option is to select INSTALL instead, but I haven't a clue what WINE is other than reading here about it being some sort of alternative to Crossover which apparently no longer works.

 

Please advise me; I really want to be able to see my details and sources. (I haven't tried to do anything else in RM yet.)

 

Many thanks. (I"d like to say it's good to be back, but um... not yet...)

 

 

Now when I look at the Force Quit menu, there is no "wine..." listed.