Jump to content


Bob Bance's Content

There have been 6 items by Bob Bance (Search limited from 10-December 18)


By content type

See this member's

Sort by                Order  

#28153 RM3 failing

Posted by Bob Bance on 16 July 2009 - 12:01 PM in RootsMagic 3

Saga continues;
I have seen kb/63382 from MS. Does not seem to apply.
Other programs run without incident. The trouble occured after a few years of usage. In this particular computer , there is one drive. NTFS No partition, strickly XP pro .

At this stage RM3 has been re-installed no Database yet.

At this moment, unless there is a good suggestion of solution, I am about to reformat the drive , reinstall XP and RM3. All data from other programs have been backed up in CD/ RW.

Bob.*



#28100 RM3 failing

Posted by Bob Bance on 14 July 2009 - 12:38 AM in RootsMagic 3

Are you currently or have you tried running RM3 in XP's Compatibility Mode? Is the error occuring upon opening RM (but before selecting a database to be opened) or is it when a database name is chosen for opening

Actually RM3 was uninstalled and reinstalled without problem. and there is no Dbase yet.
After a little research , I used the following :
CACLS % systemroot%\System32\*.dll /E /G BUILTIN\Users:R
CACLS % systemroot%\System32\*.ocx/E /G BUILTIN\Users:R

and this seems to have cleaned up something as I no longer have the error of Application failing to initialize.

But I still have this error : -R6009 not enough space for environment. and of vourse no RM running

I did editing in the Comspec line as suggested.

We are still digging for a solution

Bob.*



#28099 RM3 failing

Posted by Bob Bance on 14 July 2009 - 12:25 AM in RootsMagic 3

QUOTE(kbens0n @ Jul 13 2009, 12:46 PM) View Post

Just a guess, honestly! In searching for the error related to not enough space for enviroment, I came across several mentions of this particular system variable (also the "shell=" statement in Config.sys), so when this link:
http://www.foxite.com/archives/environment-space-in-xp-0000075114.htm
showed relation to FoxPro 2.6 (I believe RM originally started life in this Xbase ancestor), I offered it up for consideration. Most searches surrounding the inexact text of your errors seem to relate to DOS operations(and by extension that is XP's cmd.exe environment) meaning the Comspec variable and it's effect upon environment space (which reserves memory space to hold the values of such variables).

Are you currently or have you tried running RM3 in XP's Compatibility Mode? Is the error occuring upon opening RM (but before selecting a database to be opened) or is it when a database name is chosen for opening?




#28088 RM3 failing

Posted by Bob Bance on 13 July 2009 - 12:24 PM in RootsMagic 3

Thanks for replying,
Followed your instructions and edited /e:32768 that was missing. Would you explain the purpose of this addition to the Comspec line? Is it a switch to activate Environment Variables? Or is there any relation with the error cited below ?
But I am still getting this error :The application failed to initialize properly (0x0000142).Click Ok to terminate the application. After so many years, I cannot understand what could cause such a problem, only with RM3. I have not wiped my drive clean, but reinstalled Windows XP, hoping to catch and correct whatever went astray.



#28087 RM3 failing

Posted by Bob Bance on 13 July 2009 - 12:08 PM in RootsMagic 3

QUOTE(kbens0n @ Jul 13 2009, 02:02 AM) View Post

For the above error you might try this:

Click on Start--> Settings---> Control Panel
Locate and click on System in Control Panel
Click on the "Advanced" tab
Click on "Environment Variables"
Look in lower pane marked "System Variables" and locate COMSPEC entry
If COMSPEC entry exists, click on it to highlight; click Edit button. If COMSPEC entry does not exist, click New button and create COMSPEC entry.
The entry should read:
%SystemRoot%\system32\cmd.exe /e:32768

Click OK on Edit System Variable window
Click OK on Environment Variables window
Click OK on System Properties window




#28081 RM3 failing

Posted by Bob Bance on 13 July 2009 - 01:12 AM in RootsMagic 3

For years , I have used Family Origins( all versions) and now Roots Magic ( 1 ; 2; 3)
This version 3 , one day quit and errored : Failed to initialize. Luckily, I was able to install in another computer and transfered my database. Now I have reinstalled Windows Xp in my original computer ( Drive: 70G). and original CD, re-installed RM3 OK. [ Icon on desktop] At first run, got the error : Not enough space for environment and on retry < back to same error >:Failed to initialize ( 0x0000142)
What could possibly be the trouble? Help !
Bob Bance