Jump to content

kcard's Content

There have been 58 items by kcard (Search limited from 23-September 19)

By content type

See this member's

Sort by                Order  

#66175 Invalid floating point operation

Posted by kcard on 23 September 2014 - 12:45 PM in RootsMagic for Mac

I am encountering this error, too. Like some others, it seems to happen when I switch to another running program on my computer. When I switch back to RM, the error is there. It just happened on the Family view for me when I switched back from using Safari. 


I am running 10.9.4 on my MacBook Pro. No, I'm not using the same RM database on my Mac and on my copy of RM in Parallels. RM is not even running on Parallels, which is, in fact, not running at all (Parallels).

#66182 Invalid floating point operation

Posted by kcard on 23 September 2014 - 02:53 PM in RootsMagic for Mac

Just got another one ..... I left RM, worked in other apps, left RM the frontmost app with the Edit Person screen active and the computer went to sleep. Upon waking the computer, the error was there. I believe I've gotten them with every screen/view in RM.

#66192 Invalid floating point operation

Posted by kcard on 23 September 2014 - 04:24 PM in RootsMagic for Mac

This last time was on the Family view. I had been working in it, stopped to answer the phone, and the error message popped up before my eyes. Hopefully with this feedback, you folks can figure it out. It seems fairly random to me.

#69315 Invalid floating point operation

Posted by kcard on 28 December 2014 - 11:14 PM in RootsMagic for Mac

I run both RM6 and RM7 under CrossOver, though as my "production" use is still on RM6, I have used that more than RM7 in the last few weeks. However, I have NEVER seen the problem under CrossOver, only under MacBridge, both with RM6 and RM7.

What are you wanting to know about the RM7 installation under CrossOver? I used the unofficial Tie for RM7 - CrossOver officially supports RM3 to RM6, but not RM7 (unless that has changed recently). The only problem I had was in defining the folders for my RM files - for some reason the RM "file manager browse" function just hangs in the latest couple of levels of CrossOver V14, but the way round that is to switch the Virtual machine type from Windows XP to Windows 7, use the browse function to point to the folders, and then switch the virtual machine type back to Windows XP. (This has been accepted by CossOver as a bug with RM6 and they suggested the bypass, which has worked fine for me on both RM6 and RM7.)

I'm currently using Yosemite 10.10.1, though was running Mavericks 10.9.5 until the beginning of December.

Does that help? Please feel free to ask any supplementaries.

I'm trying out CrossOver. I have the same problem not being able to define the folders ..... it hangs. So, my question is ..... how do I change the virtual machine type from Win XP to Windows 7? 



#65973 Invalid floating point operation

Posted by kcard on 15 September 2014 - 04:33 PM in RootsMagic for Mac

I have the same error coming up under the same circumstances which seems to indicate a bug. As a Mac user, I very much appreciate that RootsMagic is being made available to us natively on our Macs. I look forward to the real deal for Macs!

#69321 Invalid floating point operation

Posted by kcard on 29 December 2014 - 08:43 AM in RootsMagic for Mac

Thank you, J P for your quick reply. That gave me the needed info......... But, it didn't work for me. I changed to Win 7, clicked apply, then OK, and launched the RM7 from CrossOver. Before I can do anything, though, I get an error message coming up "External Exception C06D007F." It won't allow me to do anything. Before trying to change the folder settings, I had been playing with RM7 under CrossOver and can see that the floating point error never occurred and I was able to change the DPI settings to something more acceptable for me. Now to figure out this folder setting issue. Any ideas on what this error is all about? I do have my original RM7 under MacBridge still installed...... but not open. Both use the same database,

#69400 Invalid floating point operation

Posted by kcard on 01 January 2015 - 01:38 PM in RootsMagic for Mac

I just noticed something strange .... at least I think so. Like a lot of others, I was getting the floating point error very often..... every time I left RM to work in another app. So, I tried out CrossOver for a few days with RM7 and decided I didn't like it enough to purchase it. I was using the same database but two different copies of the RM app. So, back I went to using RM under MacBridge. In the last two days since I've been back using RM under MacBridge, I have not had one, single floating point error! Not being a programmer or software engineer of any type, I don't know if that is significant to figuring out this problem? I just wanted to report it. 

#69327 Invalid floating point operation

Posted by kcard on 29 December 2014 - 11:12 AM in RootsMagic for Mac

As an experiment, I've just played with my RM7 under CrossOver setup. At present, the bottle is set to Windows XP. When I go into modify the folders using the browse "...", it hangs and I have to force quit RM7. However, if I type into one of the fields, it will quite happily accept a change. Have you tried just typing in the full path name, such as Y:\Documents\RM\CO-RM7\Files. The Y disk is mapped by CrossOver to your Mac home directory. Note the direction of the (back) slashes. 

LOL ....... That worked! I just pasted in the path in all fields that I wanted and it all worked as it should. (From CrossOver using Win XP virtual machine.) That was just way too easy, which is why I didn't figure it out myself, LOL. Functional fixedness, that's me.  :)  Anyway, thank you again J P!

#69329 Invalid floating point operation

Posted by kcard on 29 December 2014 - 12:00 PM in RootsMagic for Mac


Great. (That is why I like the RM forums - lots of followers who are happy to chip in when they can.)


On the DPI front, I've decided that 200 is too high and am now back down to 160. It is a compromise, but am doing a lot of FSFT stuff this afternoon (UK time) and the side by side display was displaying too little at 200.


Well, these old eyes are using 140 dpi.  :)  Now if I could just get it to close a window when I press command+w rather than bring up web tags, I'd be totally happy.  :)

#69324 Invalid floating point operation

Posted by kcard on 29 December 2014 - 10:38 AM in RootsMagic for Mac

Sorry but I'm out of ideas - it just worked for me. I'm a little confused by your reference to playing with RM7 under CrossOver. That suggests that you were using an RM file without problems and I assume that it was being stored somewhere. Am I missing something?

Just one thing, though. Until you get things working OK (note the confident tone there), I would suggest that you use separate directories for MacBridge and CrossOver. Just duplicate what you have already and, when you can, point the folder definitions as required.


I have been using RM7 under MacBridge with success except for the invalid floating point issue popping up quite often and the font size issue. I decided to try using CrossOver directly as I'd read that those problems were not an issue using CO. I just had hoped to avoid the above issues with CrossOver.


RM7 is in two directories on my computer ....... the normal Applications folder and the CrossOver folder within my user directory/Applications. I was already using RM7 when I started with CrossOver and downloaded a fresh copy of RM7 to use with it. I am using the same database file for each copy of the app but not at the same time. 


As an experiment, I just duplicated my database file and moved it to another location. I launched RM7 from CrossOver (Win 7 VM). It launched OK but when I tried to open the duplicate database file I had moved to another location, I got the error message.


Oh well. It's not a huge deal. I would have liked to get it working correctly, to use RM without the floating point error and the font size problem. But, I will just continue to use RM7 under MacBridge and wait impatiently for a native Mac version.


Thank you for trying to help!

#67150 Using RM's User Defined Facts as Todo Lists and Research Logs

Posted by kcard on 02 November 2014 - 06:42 PM in Tips and Hints

Thank you, Jerry. I will do that.

#67347 Using RM's User Defined Facts as Todo Lists and Research Logs

Posted by kcard on 12 November 2014 - 10:04 PM in Tips and Hints

Thank you, Jerry!

#67144 Using RM's User Defined Facts as Todo Lists and Research Logs

Posted by kcard on 02 November 2014 - 05:20 PM in Tips and Hints



The Description field can be made visible in People View, and the Note cannot. You can see both from Edit Person, and you can display both with RM's custom reports.



Jerry, I'm new at this....... I figured out how to create a group of people who I need to do certain research for....... using your methods. How can I make a custom report for each of these facts? Possibly to print out as a To Do list of sorts to take with me on a Library trip? Something that would print out the Notes for that Fact type? Is there a way?


Thank you!

#67131 Using RM's User Defined Facts as Todo Lists and Research Logs

Posted by kcard on 02 November 2014 - 09:40 AM in Tips and Hints

Actually, Jerry, I find it very helpful and thank you for sharing your methods. I'm using RM under MacBridge and find the ToDo and ResearchLogs to be almost unusable. The fonts are so small as to be impossible to read without a magnifying glass or utility, even after adjusting the font size for the program. It does not apply to these items.


So, if I understand you correctly, you create one flag for each "item" you are researching? Marriage, death, grave, land purchase, etc? And then all notes on that go into the Note field for the flag/fact?



#67143 Using RM's User Defined Facts as Todo Lists and Research Logs

Posted by kcard on 02 November 2014 - 04:49 PM in Tips and Hints

Can I suggest that if you haven't already raised this issue of the impossibly small font size that you should raise it as an issue. There may well be some changes that could be made to MacBridge - not something you can change - but we need to agitate or things may never improve.

You're right, J. R. I will do that. Thanks for the reminder.

#66803 Question regarding citing frequently used sources

Posted by kcard on 15 October 2014 - 05:27 PM in Discussion

I also choose to have one source per census year. I had actually created these and converted all my citations over in another program, prior to using RM6.  In the move to RM, they came over as Free Form sources. In the Source List, I added an * at the start of each census source so they sort at the beginning of the list.


Whenever I use a census source, I choose it, then add the details (usually I just copy these rom Ancestry) in the Source Details field.


The result looks like this:


1930 U.S. census, Ancestry.com, Digital images (National Archives and Records Administration, n.d.), T626, Decoto, Alameda Co., California, enumeration district (ED) 346, p. 248, dwelling 384, family 396, Henry Andrade household.

#66485 OSXFUSE Update - seems to fixed floating point

Posted by kcard on 02 October 2014 - 11:56 AM in RootsMagic for Mac

Please tell them not to take away from the development of the native mac version... we can handle a floating point every now and then until the native version is done.



I agree, Allen ..... it's just a minor annoyance..... as long as whatever is causing it doesn't impact the native Mac version in some way.

#73601 Update to 7.0.7????

Posted by kcard on 08 August 2015 - 07:29 AM in RootsMagic for Mac

I got the newsletter which said to click the link to get version 7.0.7 for the Mac. I did but when I checked from the RootsMagic menu, I get Version 7.0 ( When I check from within RM->Help menu>About RM, I get Version 7.0.6 (16 July 2015). So, what should I do now? I followed the directions update from their link but that only got me to 7.0.6.

#73602 Update to 7.0.7????

Posted by kcard on 08 August 2015 - 08:57 AM in RootsMagic for Mac

Well, I finally got 7.0.7. The directions aren't very clear, IMHO. Download first from the newsletter link to get to 7.0.6, then download the update from within RM.

#65852 MacBridge font?/unlock

Posted by kcard on 10 September 2014 - 09:15 AM in RootsMagic for Mac

For a font, I'm using Constantia 18 and 16. I feel that it works well. BTW, I also ran into that problem of having to Force Quit. Besides the red button, I also found that clicking the door (Windows exit) then choosing either to backup or skip, exits the program also. Not very Mac-like but I think this is a work in progress. I'm looking forward to future improvements and DEFINITELY the Mac version!



#65796 MacBridge for RootsMagic

Posted by kcard on 07 September 2014 - 12:40 PM in RootsMagic for Mac

I have used RM on my Mac via Parallels for some time but was pleased to see that it's being made available to Mac users via MacBridge. I downloaded it and have been trying it out but I do have a couple of issues/questions.....


1) When in the Edit Person window, and I select a fact, clicking in one of the fields on the right (any field even the proof popup) often, but not always, makes the view jump to another fact for that person. It doesn't happen every time, but often enough to be a pain. Also, just clicking in a blank spot in the right side of the window, often moves the fact selection to something different.


2) How do I do a search/find for some text that I would like to have grouped together? Such as searching for all people who have a burial place that equals Holy Sepulchre Cemetery? I can do the find from the RM Explorer but the results are not what I expected! The list is filled with the people I know were buried there, but also hundreds of people who never even were in the USA, lol. Why is that?


 I look forward to the Mac version of RM!!


Kathy ....... Oh, I would dearly love the ability to copy an entire fact complete with source and notes so that it could be used for others sharing the event  (like Legacy does) ...... without having to use the Share Fact capability which doesn't transfer via gedcom.

#66017 MacBridge for RootsMagic

Posted by kcard on 17 September 2014 - 11:09 AM in RootsMagic for Mac


The reason it is jumping is because the focus has not changed to that fact. For some reason your computer is not recognizing the single click as selecting that new fact. When you click on the field on the right it is jumping to the fact that is still in focus.


I'm not sure what is different in your computer setup or how you are clicking on the fact. Can you tell me what Mac version you are using? Are you tabbing or clicking on the fact? After you click on the fact the cursor should automatically be in the first field to begin typing. Let us know any steps you are taking that may help us pin-point why this is happening. Obviously double-click works but we don't know why a single click is not good enough on your computer. So far I don't have anyone else reporting this. 

I am using Mac OS 10.9.4.


I select a Fact on the left, say Death. In the pane on the right side, it shows Death as the Fact selected with the fields, date, etc. displayed. When I click in one of those fields, the cursor jumps to whichever Fact is on the same horizontal plane on the left side of the window, such as Census. It's crazy, I know ...... leave it to me to have a problem no one an figure out, lol! But, I'm not too concerned. It doesn't happen every single time and when it's a problem, I smile and double click as I stated above. It's definitely not a deal breaker for me. I enjoy using RM on my Mac and appreciate the effort it took to make this possible.

#65801 MacBridge for RootsMagic

Posted by kcard on 07 September 2014 - 09:21 PM in RootsMagic for Mac

Laura .... OK. I see it now and that makes sense. I did expect different behavior, but I see now how RM is set up to work. So, I did a find:  Burial, Place Details, contains, cemetery name and could move forward and backwards thru the RM Explorer to each of those people. NOW...... is there a way to be able to put these results into some kind of a Group? A report or list?


Thank you for your help!



#65809 MacBridge for RootsMagic

Posted by kcard on 08 September 2014 - 11:40 AM in RootsMagic for Mac


So far I don't have anyone else reporting this issue. I will watch to see if there is a pattern. For now I'm not sure why that is happening. Are you only seeing this behavior using MacBridge for RootsMagic, and not when you were using RootsMagic with Parallels on the Mac?

It only happens in MacBridge for RM. RM under Parallels works as expected. 

#65811 MacBridge for RootsMagic

Posted by kcard on 08 September 2014 - 11:57 AM in RootsMagic for Mac

Renee .... I just noticed something else regarding this issue ...... WHEN I see this behavior,


1) Select a Fact on the left which makes the details for the Fact show on the right

2) Clicking in a field for the details, such as Date

3) The fact on the left that lies directly on the same horizontal level as the field I just clicked in is where the selection gets moved to.

4) As an example, I just selected an Occupation fact. When I click in the Date field on the right, the selection jumped to the individual's name on the left...... which was the field on the left that was on the same line. 


This seems to be happening about 40% of the time.