Jump to content


goldster25847

Member Since 04 Apr 2014
Offline Last Active Apr 04 2014 12:15 PM
-----

Topics I've Started

What Version of Android needed to run RootsMagic?

04 April 2014 - 12:15 PM

I have an older tablet that is running Android version 2.0. Will RootsMagic run on this tablet?