Jump to content


Photo

RootsMagic TO GO


  • Please log in to reply
No replies to this topic

#1 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 26 February 2011 - 10:08 AM

I found a way to use the relative addresses for media files on a USB flash drive.
( or toggled up a work around ) At least it should work no matter what drive letter the computer assigns the USB device.

Create a Sharable CD of the database you want on the USB drive. Don't burn it to a CD, but REMEMBER where it is located.
(This puts all the media items in the one folder, "Pictures" and changes all the media the linkages in the resulting RMGC file to that folder, relatively.)

Do the RootsMagic TO GO, transferring the program normally, enter your registration code when asked for it, and then, transfer the RMGC file from the sharable CD folder.

Then, using Windows Explorer copy the Pictures FOLDER and all it's contents from the Sharable CD location to the USB drive's RootsMagic-4 folder, where the program files are, NOT a data folder below it. (the picture folder must be a sub folder of the RootsMagic-4 folder, not the data folder.)

====== observation =====
SO, the pictures can be relatively addressed in a subfolder of the program, but not of the the database.
This location doesn't work on the local hard drive because the program is in the area protected from us by the Windows "Big Brother."

====== Experimentation ======
NOW, I tried copying my regular photo file structure, with quite a few subfolders with more subfolders etc to the program folder on the USB drive, then used the search and replace to delete the reference to C:\ --- it didn't work.

That one pictures folder made with the sharable CD does seem to work though.
But the sharable CD places the database in the same folder as the program--HMMMM
I then moved the database to the program folder and the pictures on my transferred file structure worked fine?

======= conclusion =======
SO, in conclusion, everything goes into the root drive or folder except the pictures folder(s) and any other sub folders for backups, GEDCOMS etc.
I can enter just the subfolder for GEDCOMS, Backups etc, but without the drive letter, it seems to default to the root folder anyway.
I locked up RootsMagic trying to scann a photo from both the USB program and the regular one, I don't usually scan through RM so I don't know if this is new or not. When scanned with IrfanView & placed it in the Pictures folder to add it later, It would only work with complete address.
SO, it doesn't seem that we can add new photos relatively to the USB.
Alfred