Jump to content


Photo

Source Bug


  • Please log in to reply
2 replies to this topic

#1 RWells1938

RWells1938

    Advanced Member

  • Members
  • PipPipPip
  • 216 posts

Posted 24 December 2010 - 03:24 PM

There is a bug in the program where if you set up a source then add the source to some facts. Once these sources have been added you go back and add a field to the source. Then if you set the source up to not print unless something is entered into the new field you have to go back and blank out all of the sources with the field added or they will print with nothing in the field.

#2 Kevin Wornell

Kevin Wornell

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts

Posted 26 December 2010 - 01:59 PM

There is a bug in the program where if you set up a source then add the source to some facts. Once these sources have been added you go back and add a field to the source. Then if you set the source up to not print unless something is entered into the new field you have to go back and blank out all of the sources with the field added or they will print with nothing in the field.


I wonder if this is related to the issue I have seen where you add an existing source to a fact, then memorize it and add it to additonal facts. If you made a mistake or typo in the source when you add it originally you have to manually go and find all the places where you pasted that source and correct it in them as well.

It looks like an existing source added to a fact is not stored as a unique item and then referenced in multiple places but rather constructed and then stored multiple times, once for each fact it is associated with. It would be so much easier to correct mistakes in sources associated with multiple facts like death certificates, birth certificates, etc. if the source was stored once and then referenced.

#3 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6268 posts

Posted 26 December 2010 - 03:48 PM

There is a bug in the program where if you set up a source then add the source to some facts. Once these sources have been added you go back and add a field to the source. Then if you set the source up to not print unless something is entered into the new field you have to go back and blank out all of the sources with the field added or they will print with nothing in the field.


Can you outline your procedure? I don't understand this description. Is it the Source Template sentence that you have a problem with? A solution might be:

< ?[printfield] | desired footnote sentence | >

If the printfield field has a non-null value, then the desired footnote sentence value (the footnote template with all the other fields) should be outputted; if it is null, then nothing should be outputted. The second "|" could be omitted and should have the same result.

If that is what you have tried and find that it does not work on souces that had previously been created from that Source Template, then I have understood the problem.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.