Jump to content


Photo

MEDIA GALLERY - Remove Media Problem


  • Please log in to reply
16 replies to this topic

#1 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 29 November 2010 - 01:26 PM

I just noticed a problem in the Media Gallery, I have been going through duplicate thumbnails, showing where they are used and deleting those with some of the incorrect links which have somehow crept into my file.

After using the "Remove Media" button I then cannot highlight a subsequent thumbnail without closing the Media Gallery and opening it again. <_<

This is on my Win7 build, I will try it on XP tomorrow, hopefully someone else could confirm or deny this before then. I do hope 4.1 is thoroughly tested in all areas and functions before release, I seem to remember this function working previously and we appear taking backward steps at times.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#2 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 29 November 2010 - 05:00 PM

I can update this topic with the findings that it is a particular file in which some corruption has obviously crept in.

I first mentioned this in this post and being the only small file I do try to maintain in RM4 you can imagine my disappointment. Basically numerous duplicate thumbnails were showing and when I looked at there they were used, one was usually correct and the second had completely incorrect links and maybe more than one.

I now don't know how much I should trust this file and am currently undecided on how best to try and repair it. This being the forth occassion I have found myself faced with file problems in RM4 does not leave me feeling very happy, I remember calls for file integrity checkers and an index rebuild function so maybe that needs to be revisited.

I have tried gedcom export/import and the problem remains.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#3 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 30 November 2010 - 01:55 PM

After using the "Remove Media" button I then cannot highlight a subsequent thumbnail without closing the Media Gallery and opening it again. <_<

I was able to successfully remove duplicate images (that I manually created) from the media gallery, without having to close the screen to highlight another one. I am using XP.
Renee
RootsMagic

#4 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 30 November 2010 - 02:02 PM

I was able to successfully remove duplicate images (that I manually created) from the media gallery, without having to close the screen to highlight another one. I am using XP.

Renee, I have discovered this relates to one particular file, see second post, I tried it on a manual test later and it worked fine.

This file has somehow become corrupted in some way, most of the duplicate items show as having links I would never have made. My problem now is I don't know when in time this happened, whether there is other file corruption and should I trust this file once the media items are cleaned.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 01 December 2010 - 01:25 PM

Renee, I have discovered this relates to one particular file, see second post, I tried it on a manual test later and it worked fine.

This file has somehow become corrupted in some way, most of the duplicate items show as having links I would never have made. My problem now is I don't know when in time this happened, whether there is other file corruption and should I trust this file once the media items are cleaned.

I agree that your file appears to be corrupted. If you would like us to look at your file and see if the RootsMagician can repair it please submit a ticket.
http://support.roots...in/Default.aspx
Renee
RootsMagic

#6 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 01 December 2010 - 01:35 PM

I agree that your file appears to be corrupted. If you would like us to look at your file and see if the RootsMagician can repair it please submit a ticket.
http://support.roots...in/Default.aspx

Renee, I will try to extract enough individuals and send in the file so Bruce might see the problem, it won't be for a day or two though.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#7 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 02 December 2010 - 08:12 AM

I agree that your file appears to be corrupted. If you would like us to look at your file and see if the RootsMagician can repair it please submit a ticket.
http://support.roots...in/Default.aspx

Renee the file backup might be around 8mb, will that go through the ticket system attachment OK or should I email to Bruce?

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#8 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 02 December 2010 - 10:16 AM

Renee the file backup might be around 8mb, will that go through the ticket system attachment OK or should I email to Bruce?

That size should work. Uploads have to be 10MB or less.
Renee
RootsMagic

#9 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 02 December 2010 - 10:54 AM

That size should work. Uploads have to be 10MB or less.

It went through by email and also the ticket system so you should definately have it, I look forward to the verdict.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#10 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 07 December 2010 - 11:13 AM

That size should work. Uploads have to be 10MB or less.

Renee, did you receive my file OK?

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#11 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 08 December 2010 - 09:56 AM

Renee, did you receive my file OK?

I see your ticket and backup file in Kim's que. He's not online right now for me to ask details on it.
Renee
RootsMagic

#12 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3407 posts

Posted 08 December 2010 - 10:35 AM

I see your ticket and backup file in Kim's que. He's not online right now for me to ask details on it.

That's no problem, as long as you have the file it might help understand how the it got corrupted and maybe help Bruce build in some prevention or at least an integrity check for the future.

We are all limited by our visions and abilities

Whilst we can borrow from the visions of others we cannot always deliver.

 

User of Family Historian 6.2.7, Rootsmagic 7.6.0, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#13 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6252 posts

Posted 14 December 2010 - 10:51 PM

I had a look at vyger's database and could not replicate the problem in the Media Gallery

After using the "Remove Media" button I then cannot highlight a subsequent thumbnail without closing the Media Gallery and opening it again.

. Maybe OS related - I'm on XP, his problem was on Win7.

There was some thought that the database was corrupted - using SQLite Developer to run a SQLite database integrity check, this file passed as well as any RootsMagic file (it consistently reports a problem with an index on the SourceTemplateTable which is of no consequence, at least for this case).

Multiple duplicate thumbnails - I confirmed that there were many pairs of records in the MultimediaTable pointing to the same filename but on two different drives with (otherwise) the same path. Moreover, I found multiple identical records, except for the ID, in the MediaLinkTable connecting a person, family, fact, place or source to a record in the MultimediaTable (i.e., multiple links to the same file). In one case, a Place had 42 identical links. There are likely multiple causes for this proliferation, one of which is the probable merging of two databases having many identical persons and places with media, one having the media in drive D, the other in E. I then developed SQLite queries to correct the duplicate file names (all now on drive D) and duplicate links - that will not do anything for what vyger reports as erroneous links.

This investigation has led to a new page on the SQLiteToolsForRootsMagic4 Wiki: Media Repair Queries, and to a revision of RMGC_Properties - Query to incorporate counts of duplicate media file names and links.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#14 lacarr04

lacarr04

    New Member

  • Members
  • Pip
  • 3 posts

Posted 06 April 2011 - 09:00 PM

I'm having the problem of duplicates in the media gallery on XP. When I "see where media is used" one will have a location and the other one or two are blank. When I remove one of unwanted medias I also have to close out and go back in in order to delete another one.

This has happened on two separate databases. The first database I was able to manually remove the unwanted media and go to the next one I wanted to remove with no problem.

With the second database I have to close out of "Media Gallery List" and go back into it before I can delete another media.

I entered some photo media today and it shows up twice in the media gallery list. The files are showing the same thing.

Is there a simple way to solve this problem? I've got version 4.1.1.1.

Thanks in advance for any help or suggestions.

#15 John James

John James

    Advanced Member

  • Members
  • PipPipPip
  • 222 posts

Posted 07 April 2011 - 12:59 PM

With the second database I have to close out of "Media Gallery List" and go back into it before I can delete another media.

I have also had similar preblems, duplicates where I could never have attached them and problem moving to next file without closing media gallery. I did put it down to corruptionn at some point as others were not reporting the same. I'm not using the gallery much now as I find it time consuming, i just keep adding new files each time in the hope something better comes along.

#16 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6252 posts

Posted 07 April 2011 - 06:21 PM

I have also had similar preblems, duplicates where I could never have attached them and problem moving to next file without closing media gallery. I did put it down to corruptionn at some point as others were not reporting the same. I'm not using the gallery much now as I find it time consuming, i just keep adding new files each time in the hope something better comes along.

Apart from submitting a request for Help to Support, I can only suggest SQLiteToolsForRootsMagic4 Wiki: Media Repair Queries, and RMGC_Properties - Query which counts duplicate media file names and links

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#17 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 13 April 2011 - 02:53 PM

Yes, please do submit a request for help (ticket) on this behavior, along with a backup of your database and notes on what items to check.

I have not checked our requests to see if you have already done so.

Submit a request for help - look for link under the home tab and the name RootsMagic Support
http://support.rootsmagic.com/home
Renee
RootsMagic