Jump to content


Photo

Family multimedia scrapbook


  • Please log in to reply
9 replies to this topic

#1 Fred B

Fred B

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 30 September 2010 - 12:06 AM

I purchased Rootsmagic4 (4.0.9.6) and used it to import a Family Origins 4 database.

The problem is, I lost all my links to the images that were in the Family multimedia scrapbooks for every person.

Unfortunately, I didn't notice this failure until I made major changes to the new program files.

How can I recover from this? Why are all the Family multimedia scrapbooks missing? How can I get help with this???

Thanks in advance for any help I receive.

#2 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 30 September 2010 - 12:20 AM

You shouldn't have lost any links if the new database is on the same computer and you didn't move any media files.

UNLESS, you used a relative path in Family Origins, RootsMagic doesn't seem to like that very well.
RootsMagic has a facility in the Search menu you can use to search and replace multimedia filenames.

There is also a tool in the Lists - Multimedia Gallery to "fix broken media links."
That is supposed to find the media files and fix their path links.
(Some people report this doesn't work too well for them.)
Alfred

#3 Viking

Viking

    Member

  • Members
  • PipPip
  • 17 posts

Posted 30 September 2010 - 06:43 AM

I purchased Rootsmagic4 (4.0.9.6) and used it to import a Family Origins 4 database.

The problem is, I lost all my links to the images that were in the Family multimedia scrapbooks for every person.

Unfortunately, I didn't notice this failure until I made major changes to the new program files.

How can I recover from this? Why are all the Family multimedia scrapbooks missing? How can I get help with this???

Thanks in advance for any help I receive.


I recently change the structure of my multimedia folders and used the fix broken links and it did find all the broken links. It did take some time since it searched all my disks. It would be nice if the search started at the multimedia folder selected in the Program Options.

#4 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3906 posts

Posted 30 September 2010 - 07:09 AM

UNLESS, you used a relative path in Family Origins, RootsMagic doesn't seem to like that very well.
RootsMagic has a facility in the Search menu you can use to search and replace multimedia filenames.


Alfred it's a bit outside the main thrust of this thread, but could you speak a little more about relative paths? I know what they are in general (I use them in all the pages on my personal Web site, for example), but I'm not really sure how to set them up in RM4. For example, I would like to set up my RM4 Folder Options relative to the My Documents folder rather than relative to the root of the C: drive. Is that possible? If so, how do you do it?

The reason it matters to me right now is that I'm using RM4 on both a Windows 7 machine and a Windows/XP machine, and the absolute paths for folders such as My Documents are different between the two operating systems.

Jerry Bryan

#5 Fred B

Fred B

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 30 September 2010 - 10:12 AM

Thanks for the replies, however "fix broken media links" generates an "Access violation" error on my Windows 7 -64bit machine.
Posted Image

The media that was in the family multimedia scrapbook for each person was not detected or added to the new RM4 database. It took me a while to notice it. The images are just not there in the media display.

#6 Fred B

Fred B

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 30 September 2010 - 10:14 AM

Thanks for the replies, however "fix broken media links" generates an "Access violation" error on my Windows 7 -64bit machine.
Error Image

The media that was in the family multimedia scrapbook for each person was not detected or added to the new RM4 database. It took me a while to notice it. The images are just not there in the media display.

#7 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 30 September 2010 - 12:05 PM

Family Media is not attached to any one person, only to a pair of people.

I would imagine that Windows 7 is complaining that the search is looking into a folder that it thinks it should not.

If you highlight the media item with the broken link, it should show the listed file name and path in the "Media Properties" column to the right.
If the media items are not in that listed place, then you need to do a search and replace media file-names to tell it where they are actually located.

Windows does not like to have any data items in it's Program Files location.
It is getting more like "Big Brother" in that it dictates what we can and cannot do in order to protect us from ourselves.

----- ----
Did you copy the multimedia items from the old computer to the new one? There are no pictures in the database itself, only links to them, The path and filename.
Alfred

#8 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3485 posts

Posted 30 September 2010 - 12:23 PM

Thanks for the replies, however "fix broken media links" generates an "Access violation" error on my Windows 7 -64bit machine.
Error Image

The media that was in the family multimedia scrapbook for each person was not detected or added to the new RM4 database. It took me a while to notice it. The images are just not there in the media display.

That message was discussed in the following thread:

http://forums.rootsm...95-the-gallery/

Presumably, it was this fix:

http://www.facebook....comments&ref=mf

"CHANGED AND FIXED

Pasting into RM notes now preserves bold, italics, and underlining
Sped up duplicate search, SmartMerge, and ShareMerge
Sped up scrolling through the list of potential duplicate records
Sped up incremental search in the place list (for databases with large number of places)
Fixed crashing when doing some “Fix broken media links” commands "

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#9 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8687 posts

Posted 30 September 2010 - 12:53 PM

Thanks for the replies, however "fix broken media links" generates an "Access violation" error on my Windows 7 -64bit machine.
Error Image

The media that was in the family multimedia scrapbook for each person was not detected or added to the new RM4 database. It took me a while to notice it. The images are just not there in the media display.

Could you please double check in Help>About RootsMagic that you are indeed running version 4.0.9.6.
Renee
RootsMagic

#10 Fred B

Fred B

    Advanced Member

  • Members
  • PipPipPip
  • 45 posts

Posted 30 September 2010 - 01:22 PM

Running 4.0.9.6

Issue resolved via phone support...THANKS!!!