Jump to content


Photo

Search gives improper results


  • Please log in to reply
15 replies to this topic

#1 Emilito

Emilito

    Member

  • Members
  • PipPip
  • 9 posts

Posted 01 November 2009 - 07:03 PM

There are several aspects to this. The most glaring is the following. I have people in my database named "Goetz" ... when, however, I search for them, I type the letters "Go" and the search skips right by them (and also names like Godoy, Goldman, Goldstein, and goes to González. (granted there is an accented letter in González, but it is in the 5th place and should not affect this search.) I have to cursor back line by line to get to all these previous names. Other aspects of this topic - but not include the inability to use a generic letter to search for both the unaccented and accented versions, which was possible in RM3. This latter issue has been blamed on Unicode, but there is no reason for the former: Goetz should be found. I have shared my database with advanced and knowledgeable users and they too are baffled. None of these issues was present in RM3 and they are a huge problem.

#2 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 558 posts

Posted 02 November 2009 - 02:13 AM

There are several aspects to this. The most glaring is the following. I have people in my database named "Goetz" ... when, however, I search for them, I type the letters "Go" and the search skips right by them (and also names like Godoy, Goldman, Goldstein, and goes to González. (granted there is an accented letter in González, but it is in the 5th place and should not affect this search.) I have to cursor back line by line to get to all these previous names.


It sounds like the problem I had in an earlier version of RootsMagic (4.0.4.0). Are you using the latest version of RootsMagic?
~ Debbie

#3 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6254 posts

Posted 02 November 2009 - 09:11 AM

It sounds like the problem I had in an earlier version of RootsMagic (4.0.4.0).

Debbie, did you try Alfred's suggestions of:

1. Backup and restore

2. GEDCOM export and import to new database

Results?

I loved Family Origins because it used a database I could view and manipulate the raw contents of with any db software that supported xBase, e.g., dBase, MS Access et al. That allowed me to fix corruption that couldn't be fixed by FO because it couldn't open it and to do major changes and custom checking of data that couldn't be done (or only one person at a time) in FO. I wish RM was as open...

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#4 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 558 posts

Posted 02 November 2009 - 09:18 AM

Debbie, did you try Alfred's suggestions of:

1. Backup and restore

2. GEDCOM export and import to new database

Results?

I loved Family Origins because it used a database I could view and manipulate the raw contents of with any db software that supported xBase, e.g., dBase, MS Access et al. That allowed me to fix corruption that couldn't be fixed by FO because it couldn't open it and to do major changes and custom checking of data that couldn't be done (or only one person at a time) in FO. I wish RM was as open...


I did the backup and restore. But then a RootsMagic update came. And since then, I've got Windows7 instead of Vista. So far, I'm not seeing any of the things I complained about in that other post.
~ Debbie

#5 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 02 November 2009 - 12:37 PM

Try a search and replace, surnames
Edit one of the Goetz people, Highlight and copy the surname to the Windows Clipboard, [Ctrl]+[c]
Open the search menu,and choose Search and Replace (OR, [Ctrl]+[h] )
Choose Surname,
Paste the contents of the Windows clipboard into the search for field, [Ctrl]+[z], it should look like "Goetz"
NOW, Type "Goetz" into the Replace with field (without the quotation marks)
Click OK
If it finds one, replace all

Now try your RootsMagic Explorer and see if Goetz is in the right place.

I suspect that either the o or the e was entered as something other than a regular English alphabetical character and therefore it doesn't sort as it looks like it should.
Alfred

#6 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 02 November 2009 - 03:32 PM

Hi Alfred! Check your inbox for an email I sent with attached database sample belonging to Emilio, to see what he refers to. ;)

Try a search and replace, surnames
Edit one of the Goetz people, Highlight and copy the surname to the Windows Clipboard, [Ctrl]+[c]
Open the search menu,and choose Search and Replace (OR, [Ctrl]+[h] )
Choose Surname,
Paste the contents of the Windows clipboard into the search for field, [Ctrl]+[z], it should look like "Goetz"
NOW, Type "Goetz" into the Replace with field (without the quotation marks)
Click OK
If it finds one, replace all

Now try your RootsMagic Explorer and see if Goetz is in the right place.

I suspect that either the o or the e was entered as something other than a regular English alphabetical character and therefore it doesn't sort as it looks like it should.


---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#7 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 02 November 2009 - 07:10 PM

OK! I obviously don't have the answer.
I have no idea what is going on.

Why does it jump to "González González" instead of the first "González"
Why does the search and replace find "Goetz" just fine?

This just keeps getting curiouser and curiouser! :unsure:
Alfred

#8 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 02 November 2009 - 07:18 PM

OK! I obviously don't have the answer.
I have no idea what is going on.

Why does it jump to "González González" instead of the first "González"
Why does the search and replace find "Goetz" just fine?

The "González González" instance might have something to do with having a space separator, maybe.
Not getting Goetz with proper leading characters is the most confusing.

This just keeps getting curiouser and curiouser! :unsure:

Yep, wierd. And try this...checking and unchecking Alternate Names will result in different results when typing those leading characters, even though neither result is an Alternate Name itself. Must be the Unicode search routines still need to be refined or a bug squashed. I had suggested that Emilio submit a support ticket, but am not sure he has...

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#9 Emilito

Emilito

    Member

  • Members
  • PipPip
  • 9 posts

Posted 02 November 2009 - 07:37 PM

The "González González" instance might have something to do with having a space separator, maybe.
Not getting Goetz with proper leading characters is the most confusing.


Yep, wierd. And try this...checking and unchecking Alternate Names will result in different results when typing those leading characters, even though neither result is an Alternate Name itself. Must be the Unicode search routines still need to be refined or a bug squashed. I had suggested that Emilio submit a support ticket, but am not sure he has...


Oh, I thought you meant I should post this problem here ... I guess I don't know how to submit a support ticket ... I'll look to figure it out, or drop me a note ... sorry ...

#10 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3459 posts

Posted 02 November 2009 - 07:56 PM

Oh, I thought you meant I should post this problem here ... I guess I don't know how to submit a support ticket ... I'll look to figure it out, or drop me a note ... sorry ...

Hello friend,

Yeah, it's other than the Discussin Forums:

http://support.roots...in/Default.aspx

Click on <Submit a ticket>

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#11 Emilito

Emilito

    Member

  • Members
  • PipPip
  • 9 posts

Posted 02 November 2009 - 08:51 PM

Hello friend,

Yeah, it's other than the Discussin Forums:

http://support.roots...in/Default.aspx

Click on <Submit a ticket>


OK, thanks, support ticket submitted. My curiosity is overwhelming :(

emilio

#12 Emilito

Emilito

    Member

  • Members
  • PipPip
  • 9 posts

Posted 19 November 2009 - 11:23 PM

OK, thanks, support ticket submitted. My curiosity is overwhelming :(

emilio



#13 Emilito

Emilito

    Member

  • Members
  • PipPip
  • 9 posts

Posted 19 November 2009 - 11:30 PM

Hello friend,

Yeah, it's other than the Discussion Forums:

http://support.roots...in/Default.aspx

Click on <Submit a ticket>


I just discovered something curious (besides no action taken)... At the beginning of the "Go"s, there's a Göbel and a Gödel, then Godoy, then ... then Goetz ... later, after González and others, there's a Görl ... this is curious because in the case of the umlaut, this is sorting as I would like it to, o and ö sorting together ... according to what I've been told about Unicode, all the Gö's should occur either before or after all the Go's (depending on where o and ö stand with respect to each other." But they don't ... Odd ...

#14 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 20 November 2009 - 01:10 AM

I thought that maybe RootsMagic 4.0.7.0 might have some bearing on this, it doesn't seem to.

But, I did try dragging and dropping everyone in the largest tree to a new empty database.
Thete, the search for Goetz works fine.

Then I tried dragging and dropping everyone in the original database to a new, empty database and the search goes wrong again, only this time, searching for "Goetz" I end up at "Laureano Gozalo Arévalo" -- And, now, so does the original copy of the database, which I haven't tried since the first day.

BUT, the drag and drop of only the largest tree lets the search work as it should?
I wonder - :o - WHAT is going on??????? :huh:
Alfred

#15 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 558 posts

Posted 16 May 2010 - 06:39 AM

This problem is still occurring. Windows 7. RM Version 4.0.8.4

I submitted a ticket: 291-1382A290-4045

Ctrl + F to bring up RootsMagic Explorer. Start typing a last name (Plogmann). After typing Plog, the name is not found in the list. The blue highlight stops on the second instance of the last name Plon and skips over Plogmann. Strangely, it did not find the first instance of the name Plon, Christian.This does work: Searching for the name Plogmann using the NameFind button.

In the edit screen, I have retyped the last names for Plogmann and the two Plon (Christian)'s, but the RM Explorer still does not find them.

I had the same problem in 2009. In that post, I gave an example when searching for Mula. But now, when searching for Mula, RM Explorer does find it correctly.


~ Debbie

#16 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8470 posts

Posted 29 June 2010 - 01:52 PM

I have updated the previous bug reports with these new examples of RM Explorer search errors.
Renee
RootsMagic