Jump to content


Photo

Memory errors after creating multiple reports


  • Please log in to reply
1 reply to this topic

#1 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1518 posts

Posted 26 August 2009 - 11:02 AM

In most of my multi-hour work sessions, I create a number of reports to help me match new info to existing individuals. The most common report is generated by Reports | Lists | Individual List | Select From List, with 3 fields selected, typically:
1. Surname (Birth or married)
2. and Any Fact | Place
3. and another Any Fact | Place
-
The problem is that RM runs out of memory after creating several reports during a single work session.
-
I haven't actually counted the number of reports before the memory error occurs, but I'd say it's less than 10. Each time I receive a dialog box asking to report the problem, and I do. After exiting the report dialog, it's essential to exit and restart RM in order to continue working, or else the memory error will re-occur with every report generated.
-
I'm running WinVista64 with 4 GB RAM, and I have not seen similar errors in other programs, which makes this appear to be an RM bug. <_<

#2 Ken Rury

Ken Rury

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 26 August 2009 - 02:12 PM

I'm running Windows 7 with 6GB of memory, I don't get the memory error, but after a couple of reports, for the same person, where I'll look at it see a problem, go fix the detail and come back and rerun the report, it will come up blank. I can selete other people and their report comes up blank or even a different type of report like Descendant rather than Ancestor and still blank. I often have to exit RM and come back in. I did not have this problem before this last update.