Jump to content


Photo

Removing item from Media Album hangs system


  • Please log in to reply
14 replies to this topic

#1 TreeTraverser

TreeTraverser

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 14 July 2009 - 02:29 PM

It seems that whenever I remove an image from one of my media albums, the entire system hangs and I cannot even click over to another program like my Internet browser. I eventually get an Out of Memory error from RootsMagic.

#2 Jack

Jack

    Advanced Member

  • Members
  • PipPipPip
  • 834 posts

Posted 15 July 2009 - 03:38 AM

QUOTE(TreeTraverser @ Jul 14 2009, 03:29 PM) View Post
It seems that whenever I remove an image from one of my media albums, the entire system hangs and I cannot even click over to another program like my Internet browser. I eventually get an Out of Memory error from RootsMagic.




Same here! Another reason that I believe RM doesn't handle memory very well. I allowed the program to send error two msgs to RM yesterday evening. Hopefully, this will be repaired.



Jack


Jack

a posteriori

#3 wardie

wardie

    Member

  • Members
  • PipPip
  • 5 posts

Posted 18 July 2009 - 03:34 AM

I have this problem if the link within the media properties is not correct.

I am new to the Roots Magic software and so I am trying to find the best way to link the My Media files to my family groups. I started with a single folder but then moved the folder position and added sub folders. I thought I had re-linked all my media files but I have found that I get the 'out of memory' message if I try to remove an item where the link is not correct. The media shown on the left pane shows the 'broken link' icon. (You can check this out by selecting the media button).

Once I sorted this out so that I did not see the broken link icon everything is OK.

Wardie

#4 TreeTraverser

TreeTraverser

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 18 July 2009 - 11:33 AM

This seems to happen when removing media from the source media and source detail media albums. The image links are not broken.

#5 tio-geo

tio-geo

    Member

  • Members
  • PipPip
  • 11 posts

Posted 22 July 2009 - 08:24 AM

Same here. I have found that if you add another photo first (I have rearranged my photo subdirectories, for example), and then delete the one you don't want, it deletes very quickly. (Agree this is some kind of memory/data pointer problem.)

#6 Jack

Jack

    Advanced Member

  • Members
  • PipPipPip
  • 834 posts

Posted 24 July 2009 - 02:39 PM

The other problem I have with media files occurs whenever I zoom in on a pix to get a better look. If I then try to cancel, I get a box asking me if I want to save the new image.
Jack

a posteriori

#7 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3504 posts

Posted 24 July 2009 - 06:14 PM

The other problem I have with media files occurs whenever I zoom in on a pix to get a better look. If I then try to cancel, I get a box asking me if I want to save the new image.

Personally I would prefer RM to presume you are viewing the image rather than editing it. In that case you would not get any prompt to save changes. My reason for this is that although it is nice for RM to have the editing capability, I don't see it as an image editor, I do that in other programs.

This was a deliberate default change in RM4 and not one that I welcomed but it may well suit many other users.

Customers should never be frustrated by things they cannot do - demand better

 

User of Family Historian 6.2.7, Rootsmagic 7.6.3, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root


#8 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1582 posts

Posted 24 July 2009 - 08:38 PM

Personally I would prefer RM to presume you are viewing the image rather than editing it. In that case you would not get any prompt to save changes. My reason for this is that although it is nice for RM to have the editing capability, I don't see it as an image editor, I do that in other programs.

This was a deliberate default change in RM4 and not one that I welcomed but it may well suit many other users.


1. I have also experienced RM 4.0.4.0 crashing/locking up when I remove a media link. I attach almost all of my images at the Fact | Media level, only very few at the Source | Media or Place | Media levels. For example, earlier today I realized that I had attached a media link (city directory scan) to an occupation fact, and I wanted on the residence fact. I added it to the residence first, and then removed it from the occupation -- crash. A dialog box popped up requesting to send info to RootsMagic (I've seen this same box several times now ... and I always approve the transmission) Afterwards, my computer was running very slowly - most noticeably in downloading data from the internet. I re-booted and the the slowdown issue disappeared. Related? Memory issue? I can't say, programming is not my expertise.

2. I noticed the new default behavior of the image viewer, and I've pretty much trained myself to hit Cancel instead of Close. These kinds of feature/behavior changes should be user-configurable, not static within the programming.

#9 Laura

Laura

    Advanced Member

  • Members
  • PipPipPip
  • 4276 posts

Posted 24 July 2009 - 09:54 PM

Highlight the photo thumbnail you want to view and not edit.

Click on Properties instead of double clicking on the thumbnail.

IMO, double clicking on the thumbnail of a photo should open the Properties screen not the Edit screen. That would make the Edit screen the button you would have to consiously choose to edit a photo.

Laura

#10 Romer

Romer

    Advanced Member

  • Members
  • PipPipPip
  • 2082 posts

Posted 24 July 2009 - 10:05 PM

Laura, I agree with the Properties double-click default behavior.

#11 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 24 July 2009 - 10:24 PM

But. if you click cancel first, rather than Ok, even from the Edit Multimedia, you don't have to answer the "Replace Image?" question.

I do think that the View and Edit should be separated though.
Alfred

#12 mew20176

mew20176

    Member

  • Members
  • PipPip
  • 5 posts

Posted 10 August 2009 - 06:25 AM

It seems that whenever I remove an image from one of my media albums, the entire system hangs and I cannot even click over to another program like my Internet browser. I eventually get an Out of Memory error from RootsMagic.


I find that this happens when I am deleting the last image.
Michael Winters
mew20176@gmail.com

#13 cdr9436

cdr9436

    New Member

  • Members
  • Pip
  • 3 posts

Posted 14 August 2009 - 08:57 PM

Memory
I'll be working along and suddenly my program seems to go into it's own zone, freezing my computer to the point of having to perform a hard boot. This has already affected other programs I utilize and I have 2.00 GB's of memory on this machine.

Media
RM4 seems to be randomly reattaching my *.jpg files where ever it wants them. I delete, reattach and and the image will suddenly appear attached to another name. I've been trying to attach two images for a couple hours now and every time I delete, and reattach, the same image shows up somewhere else. I've tried pulling them from my media file, attach one, and then adding the second and attaching. Nope, the image just appears attached to the previous name. I've not had this issue before. Any suggestions?

#14 djc

djc

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 08 September 2009 - 10:07 AM

I am also having the problem of my computer hanging up when I try to remove a media item. Have I missed a fix on this?

Debbie

#15 Vyger

Vyger

    Advanced Member

  • Members
  • PipPipPip
  • 3504 posts

Posted 15 September 2009 - 06:33 PM

I have also experienced this problem, it has been well publicised so should be no secret to RM.

I'm not aware of any acknowledgement or indication from RM of when it might be fixed though. <_<

Customers should never be frustrated by things they cannot do - demand better

 

User of Family Historian 6.2.7, Rootsmagic 7.6.3, Family Tree Maker 2014 & Legacy 7.5

 

Excel to Gedcom conversion - simple getting started tutorials here

 

Root