Jump to content


Photo

GEDCOM default folder not working


  • Please log in to reply
6 replies to this topic

#1 BarryEvans

BarryEvans

    Advanced Member

  • Members
  • PipPipPip
  • 70 posts

Posted 16 April 2009 - 08:08 AM

Even though I have set a default folder for GEDCOMs in Tools/Program Options/Folders, I am not taken there when I File/Import/GEDCOM/I know where the file is.
Rather I seem to be taken to the last folder I used while using the program, e.g. media folder or something.

Anyone else?


#2 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 559 posts

Posted 16 April 2009 - 09:41 AM

I'm seeing the same thing. The last folder I opened is what is shown to me when I choose "I know where the file is"
~ Debbie

#3 Jaymikal

Jaymikal

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 16 April 2009 - 12:18 PM

Remembering previous views is more of a Windows trait than that of a program setting. Happens for any downloads you might make, or uploads, or pretty much any situation that requires a window to be opened and for you to specify a file. Windows will typically remember which window you were using last until you restart your computer.

Unfortunately, I'm not aware of any method to disable this feature. There probably is, in the registry, but I don't tinker with the registry unless I absolutely have to.

#4 BarryEvans

BarryEvans

    Advanced Member

  • Members
  • PipPipPip
  • 70 posts

Posted 16 April 2009 - 12:48 PM

Jaymikel- I don't think that is the case, plenty of programs over ride the Windows system. What is the point of having the Folders list otherwise?

And, I'm growing a little weary of saying this, it worked fine in RM3 sleep.gif



#5 Ken Funk

Ken Funk

    Advanced Member

  • Members
  • PipPipPip
  • 105 posts

Posted 16 April 2009 - 01:19 PM

QUOTE(BarryEvans @ Apr 16 2009, 09:08 AM) View Post

Even though I have set a default folder for GEDCOMs in Tools/Program Options/Folders, I am not taken there when I File/Import/GEDCOM/I know where the file is.
Rather I seem to be taken to the last folder I used while using the program, e.g. media folder or something.

Anyone else?


The folder that you created is where the GEDCOM files will go when you create them, not the default folder when you open them.


#6 Romer

Romer

    Advanced Member

  • Members
  • PipPipPip
  • 2073 posts

Posted 16 April 2009 - 01:33 PM

Ken, I was thinking the same. However, when you do try File > Import > GEDCOM file in RM3, the default folder specified for GEDCOMs is indeed the one that is brought up.

From the RM4 help file for Options:

QUOTE
Folders allows you to enter default folders (directories) for the various types of files used by RootsMagic. Whenever you select a feature that accesses one of these file types, RootsMagic will first look in that folder. You can enter default folders for databases (data files), backups, Multimedia (digital images of people, places or documents, electronic files, or audio or video files), GEDCOM files, custom reports, and printouts. There is a button to the right of each field that you can click to bring up a folder list to browse and select the desired folder from. You must create the folders before you go to select the folder.


I suppose that since you're using/accessing/browsing/selecting/etc. when you do a GEDCOM import, the program really should be opening the default GEDCOM folder. Barry, you might want to send a message of what you've found to rm4beta@rootsmagic.com. File > Export in RM4 does seem to correctly bring up the GEDCOM folder default.

#7 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 16 April 2009 - 02:10 PM

It is a little bug that has yet to be stepped on.

In RootsMagic 3, I could browse for a multimedia item to add, add it and then add another and it would start in the same folder where I found the last selection. I liked that, especially when importing several photos from the same sub folder or something.

I just re-tested it with RM4, no such luck, it always starts looking in the Multimedia default folder.
Then when I went to Import a GEDCOM file, it DID remember where I found the last multimedia item and defaulted to My Pictures. I aborted the test GEDCOM import and tried a GEDCOM export. It went to my the folder I set for GEDCOM files.

So, it imports from the last used folder but exports where it should.
Alfred