Jump to content


Photo

Customer Support


  • Please log in to reply
3 replies to this topic

#1 Undertaker

Undertaker

    New Member

  • Members
  • Pip
  • 2 posts

Posted 18 September 2008 - 07:56 PM

On August 28, I submitted a ticket to Customer Suport from the RM Website. I have yet to receive an answer.
Does anyone know how long i have to wait for an answer from Customer Support?

My computer crashed and my RM program was installed by download, no CD. I found that I had a copy of the program on my thumb drive that i had copied when I started to have trouble with my hard drive, but when i try to run it, it tells me that it is a trial version and it needs registration information to be fully operational. I've tried to get an answer as to how to get my registration information from customer support, but so far I have received no answer.

Help anyone.



#2 txhsmom

txhsmom

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts

Posted 18 September 2008 - 08:49 PM

That doesn't seem normal to me, although I know they have been doing a lot of traveling. I would call them in the morning 1-800-766-8762 (this may be the order number, but you can try it). Or, you can enter a support request at http://support.roots...in/Default.aspx.

HTH,

Carol

#3 Undertaker

Undertaker

    New Member

  • Members
  • Pip
  • 2 posts

Posted 19 September 2008 - 03:14 PM

QUOTE(txhsmom @ Sep 18 2008, 10:49 PM)  

That doesn't seem normal to me, although I know they have been doing a lot of traveling. I would call them in the morning 1-800-766-8762 (this may be the order number, but you can try it). Or, you can enter a support request at http://support.roots...in/Default.aspx.

HTH,

Carol


Thanks, Carol,

When I got home from work, today, there was an answer from Bruce. Apparently the answer on the Customer Support site was made, but either it got lost or I didn't know how to access it.
Now all is well and I can get back to my genealogy.

Thanks again for your swift response to my post.



#4 txhsmom

txhsmom

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts

Posted 19 September 2008 - 03:52 PM

Great! I'm glad they've got you up and running. My experience with the RM folks is that they are very responsive to customer service issues.

Carol

QUOTE(Undertaker @ Sep 19 2008, 04:14 PM)  

Thanks, Carol,

When I got home from work, today, there was an answer from Bruce. Apparently the answer on the Customer Support site was made, but either it got lost or I didn't know how to access it.
Now all is well and I can get back to my genealogy.

Thanks again for your swift response to my post.