Jump to content


Photo

RM thinks photos are videos


  • Please log in to reply
3 replies to this topic

#1 NoŽl Sant

NoŽl Sant

    Member

  • Members
  • PipPip
  • 10 posts

Posted 11 March 2007 - 12:03 PM

I have some photos that show up as a monitor screen, in the Multimedia dialog box. If I double click the monitor, my image viewing program starts up and shows the photo (a JPG or whatever). If I open the properties dialog, the top left field says "Type of scrapbook item: Video clip", but it's greyed out so I can't change it to "Photo/Image".

I don't know how it happened that these photos were classified as videos. Not all of them are. Is there any easy way to get RM to reclassify them as photos, or is it a matter of delete and then add?

#2 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 11 March 2007 - 12:41 PM

You probably accidentally chose Video clip when you were adding the photo to the scrapbook.

From the properties of the "video clip" highlight and save the filename to the Windows clipboard, ) once it is highlighted or selected, [Ctrl]-[c] )
Then add a new item to the scrapbook, make sure you choose "Photo/Image", which is the default, paste the filename in the proper field ( [Ctrl]-[v] ). If you have caption and descriptions, you will have to copy and paste them seperately.

Once you have the photo properly entered, you can delete the mis-labeled one..
Alfred

#3 NoŽl Sant

NoŽl Sant

    Member

  • Members
  • PipPip
  • 10 posts

Posted 12 March 2007 - 09:21 AM

Ok, so add before delete. But basically the long way. Well, thanks, anyway

Regards,
NoŽl

#4 Alfred

Alfred

    Advanced Member

  • Members
  • PipPipPip
  • 5734 posts

Posted 12 March 2007 - 12:23 PM


If you have quite a few of them, and no real video files, you can edit a GEDCOM file to do them all at once.

Export a GEDCOM file of the entire database, checking all options.
Open the GEDCOM file in a word processor with search and replace capabilities.
search for "2 _TYPE VIDEO"
Replace with: "2 _TYPE PHOTO"
Save as a plain text file wtih the GED extension.
Import the modified GEDCOM file into a new database.
Work from there.

If you are doing it one at a time, my first suggestion.
You may want to do a Reports > Lists > Multimedia List
Listing ONLY the Video clips
Send it to a file so you can open it for reference while editing the ones that need it.

(I thought that copying and pasting the path and filename would be quicker than browsing to find the lost file.)
Alfred