Jump to content


Photo

Duplicated Media Entries?


  • Please log in to reply
4 replies to this topic

#1 strathglass

strathglass

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts

Posted 13 January 2021 - 06:10 PM

Do not believe I've seen this before: 

I have numerous instances of the same image appearing twice in the media gallery: the two entries point to the same file.

I am guessing it may be because of how I tagged the people in the media entry (drag and drop...onto each person).

In some cases where all family members are tagged, I see the one version has just the parents tagged, and the second/duplicate image has just the children tagged ... that is very odd.

 

Is there a nice easy way to fix this?

 

Secondary issue: I forget but do have an fading memory of a related issue:

In some cases one of the files has a caption entry and the other does not. Easy way to fix this particular issue in the process of fixing the above duplicate issue?



#2 strathglass

strathglass

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts

Posted 15 January 2021 - 06:23 PM

No one? Should I be posting the FB group instead?   I know supposedly this forum will be going away at some point :(



#3 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3982 posts

Posted 16 January 2021 - 08:04 AM

I have seen this problem occur very intermittently. I have never come up with a process that will reproduce the problem so that I can report it as a bug for correction. In my experience, simply adding a media file a second time doesn't actually produce the problem. Instead, after the second "add" it looks as if RM simply converted my request to Add From File into a request to Add From Gallery.

I think the only fix is going to be very manual. Namely, decide which one of the duplicates you are going to keep. Manually add media tags to the duplicate you are going to keep that match with the duplicate you are going to delete. Then delete the duplicate you no longer need. As a part of this process, you will also have to reconcile your captions for the duplicate media files.

Your mention of mismatching captions in otherwise duplicate media files is suggestive. It may be part of the problem. Before RM introduced the tagging process for media, the same media file could have different captions each time it was linked to something in RM. In those days, I would use different captions for the same photo depending on where it was linked. After the tagging process was introduced, a single media file could have only one caption and I lost many, many of my captions. I therefore no longer use RM's captioning facility. I handle my captions totally outside of RM. But nevertheless, I wonder if something in your captioning process might have caused this problem.

 

For example (and I'm just thinking out loud and guessing wildly), what if you link media file in to RM and give it a caption. And what if you later drag and drop the same media file somewhere else in RM, remembering that the drag and drop in and of itself does not provide a caption. Maybe that scenario will reproduce your problem. I seriously doubt that that exact scenario will reproduce your problem, but I bet the problem is related somehow or other to captioning.

 

Jerry



#4 strathglass

strathglass

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts

Posted 16 January 2021 - 11:41 PM

Thanks Jerry ... I am going to actually see if I can figure out the way to reproduce this. 



#5 strathglass

strathglass

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts

Posted 17 January 2021 - 06:10 PM

Was not able to reproduce this in my testing with a simple test database. :(

So I resorted to manually fixing this, which fortunately was not too bad, only a couple dozen duplicates it turns out.