Jump to content


Photo

Save to Dropbox for Apps - Authentication not working


  • Please log in to reply
4 replies to this topic

#1 Stephen G-F

Stephen G-F

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 04 September 2020 - 07:02 AM

I have previously used this function to put my tree in to the Roots Magic App on my Samsung J3 Android smartphone which worked fine. I now want to update my tree in the App. I have deleted the rmgc file from Dropbox but cannot now upload a new rmgc file from RM7. The Authentication dialog box opens OK when I do File, Save to Dropbox for Apps, but the dialog box is 'greyed out so I am unable to authenticate  to Dropbox; It won't take the Dropbox name and password. How can this be fixed; help please. I like the App for quick reference when out and about but it needs to be up to date. Thanks, Stephen.



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8779 posts

Posted 04 September 2020 - 07:55 AM

I just tested this and I as able to login using my Dropbox login and password. That would indicate the issue isn't with RM or the Dropbox API. Check if your firewall, antivirus or internet filtering software could be preventing you from accessing the login. Temporarily turn the off to check. 


Renee
RootsMagic

#3 Stephen G-F

Stephen G-F

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 04 September 2020 - 08:58 AM

Thanks Renee, I have turned off Windows Firewall and added Roots Magic to the Allow List in Malwarebytes; this latter doesn't show a Firewall option to turn off so this is the best I can do. Having done all this, still can't get the App to authenticate with Dropbox. On another desktop yesterday I was able to update/replace the tree in the App on that device and RM7 worked absolutely fine. Does this mean that there's a glitch in the RM7 hosting the tree I'm currently trying to update? This is otherwise working fine for all other functions. I have also run database tools all of which have come through fine. Any other help/suggestions would be gratefully received. Stephen.



#4 Stephen G-F

Stephen G-F

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 04 September 2020 - 10:18 AM

Renee, update maybe be relevant ? Just went into the RM7 Help and got an error message called a script error; "$ not defined". Went in again having closed it off and the got a different error message "Toggle" something? Is this indicative of an underlying problem affecting this installed RM7? Impacting on other functions? Stephen.



#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8779 posts

Posted 08 September 2020 - 05:41 PM

It could be or a Windows issue when you have a problem with Help. You could try uninstalling / reinstalling RM. 


Renee
RootsMagic