Jump to content


Photo

Unable to export Source Template


  • Please log in to reply
10 replies to this topic

#1 Johnj_au

Johnj_au

    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 30 April 2020 - 03:36 AM

When I try to export one of my Source Templates I receive the following dialog box:

 

"The save file operation failed

 

The save file operation failed to connect to the open

and save panel service."

 

Any suggestions as to how I can export a Source Template?

 

P.S. there quite a bit of traffic on the net reporting this same issue for a number of other apps after upgrading to Catalina.

 

TIA ... John.



#2 Robert-Leigh:Pritchett

Robert-Leigh:Pritchett

    Advanced Member

  • Members
  • PipPipPip
  • 138 posts

Posted 30 April 2020 - 07:30 AM

Can you write step-by-step the process you take to get to this message please?



#3 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8699 posts

Posted 30 April 2020 - 09:14 AM

We have tested exporting a user created Source Template using Lists>Source Templates>Export without any error messages or issue. Check where you are trying to save the file, and select a different location to see if it makes a difference. 

 

If you are getting any messages for the Gecko Wine Installer make sure you do install it. 


Renee
RootsMagic

#4 Johnj_au

Johnj_au

    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 03 May 2020 - 10:31 PM

The steps: open RootsMagic (7.6.3) in a MacBook running Catalina 10.15.4.  This opens my production .rmgc database.

 

I open Lists>Source Templates and navigate to one of the templates I created. I select that and check I can open it in RM.

 

I then click Cancel to get back to the list of Source Templates with my template highlighted, and click the Export button.

 

After a delay of 15-20 seconds I receive the error dialog box per my original post.  There are no Wine errors or other indicators or any variety.  I am not presented with any opportunity to select the export location.

 

P.S. this is Mac and there is quite a bit of traffic on the net reporting this same issue for a number of other apps after upgrading to Catalina.  I'm tempted to reinstall RM but wanted to check first.



#5 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 324 posts

Posted 04 May 2020 - 01:15 AM

The steps: open RootsMagic (7.6.3) in a MacBook running Catalina 10.15.4.  This opens my production .rmgc database.

 

I open Lists>Source Templates and navigate to one of the templates I created. I select that and check I can open it in RM.

 

I then click Cancel to get back to the list of Source Templates with my template highlighted, and click the Export button.

 

After a delay of 15-20 seconds I receive the error dialog box per my original post.  There are no Wine errors or other indicators or any variety.  I am not presented with any opportunity to select the export location.

 

P.S. this is Mac and there is quite a bit of traffic on the net reporting this same issue for a number of other apps after upgrading to Catalina.  I'm tempted to reinstall RM but wanted to check first.

There has been a tightening up of where programs have access in Catalina, so I wonder - do not know - whether you will need to allow access to wherever the template is intended to be stored. If it isn’t somewhere under Documents, Catalina may be stopping you writing to that location, though one would have expected a pop-up. Where are the “Windows” files - the equivalent of the C disk - located, as it may be trying to save it there. Somewhere under Library or something like that, maybe. Will investigate as I’’ve never tried saving templates.



#6 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 324 posts

Posted 04 May 2020 - 01:54 AM

There has been a tightening up of where programs have access in Catalina, so I wonder - do not know - whether you will need to allow access to wherever the template is intended to be stored. If it isn’t somewhere under Documents, Catalina may be stopping you writing to that location, though one would have expected a pop-up. Where are the “Windows” files - the equivalent of the C disk - located, as it may be trying to save it there. Somewhere under Library or something like that, maybe. Will investigate as I’’ve never tried saving templates.

Interesting.

 

I’m using RM under full CrossOver - I haven’t yet tried re-installing RM for Mac - but if I look in System Preferences/Security & Privacy/Privacy, under Files and Folders, I see CrossOver has access to my Documents folder and RootsMagic 7 has access to Network Volumes, Downloads Folder, Documents Folder and Desktop Folder. Under Full Disk Access, RoomsMagic 7 is in the list but not enabled.

 

When I create a copy of a source template and try to Export it, I get a pop-up window asking where I want to save it, with 3 high-level starting places - Desktop, My Documents and My Computer. The middle one is my Mac Documents, the last is to my “Windows” volumes, and the first seems to allow me to go anywhere. Quite what Catalina will allow me to access is an interesting question.

 

Not sure if this helps, but it may give you something to investigate.



#7 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 324 posts

Posted 04 May 2020 - 03:01 AM

Continuing my investigations.

 

Downloaded and installed RM for Mac, and got exactly the same result as yourself.

 

Looked in the Files and Folders settings for RM, but nothing there; nor in Full Disk Access. There is no way of adding RM to the Files and Folders settings - the plus and minus signs are greyed out - so tried adding RM to Full Disk Access. This requires a restart of RM to take effect, but has no effect on the base problem - export of a template doesn’t work because it can’t connect to the Save dialog. 
 

Continuing .......



#8 Johnj_au

Johnj_au

    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 04 May 2020 - 07:05 AM

Many thanks for your support JP - I will try out some of your suggestions tomorrow.

 

Regards ... John.



#9 Jim Byram

Jim Byram

    Advanced Member

  • Members
  • PipPipPip
  • 90 posts

Posted 04 May 2020 - 08:16 AM

The problem is the formation of the filename for the saved template file.

 

The suggested name is Untitled.* and the '.*' can result in a malformed filename and that causes the error.

 

Simply overwrite the entire suggested filename with your filename. For example change the 'Untitled.*' to 'Test'. Do not leave the hanging '.*'

 

Example of the problem... The suggested file name is Untitled.*. You change only the 'Untitled' part to 'Test. The resulting malformed filename will be 'Test.*.rmst' and saving that will result in the error.

 

Make sure that the file is saved where you want it. I tested saving in Documents and that worked fine.



#10 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 324 posts

Posted 04 May 2020 - 08:54 AM

The problem is the formation of the filename for the saved template file.

 

The suggested name is Untitled.* and the '.*' can result in a malformed filename and that causes the error.

 

Simply overwrite the entire suggested filename with your filename. For example change the 'Untitled.*' to 'Test'. Do not leave the hanging '.*'

 

Example of the problem... The suggested file name is Untitled.*. You change only the 'Untitled' part to 'Test. The resulting malformed filename will be 'Test.*.rmst' and saving that will result in the error.

 

Make sure that the file is saved where you want it. I tested saving in Documents and that worked fine.

No, this isn't the problem. I don't get as far as being able to set a file name and a location - that panel doesn't appear, which is what the error message is complaining about.

 

I've played around with the Files and Folders settings for my RM under full CrossOver but I can't recreate the problem with that. If one deselects all the options listed against my RM7 bottle (virtual machine), then I can't get at any of my RM files and need to enable at least access to Documents. RM for Mac seems to be able to access Documents without needing any such settings in Privacy.

 

I've run out of things to try, I'm afraid, but it would seem that this may well be nothing to do with the Privacy settings. Sorry tohave raised what appears to be a red herring.



#11 Jim Byram

Jim Byram

    Advanced Member

  • Members
  • PipPipPip
  • 90 posts

Posted 04 May 2020 - 09:50 AM

OK. I do get the Save dialog and can save following what I wrote above. (Catalina 10.15.4.02 and RM for Mac)

 

I don't have any idea why you can't get the Save dialog.