Jump to content


Photo

Source Issue

Sources

  • Please log in to reply
12 replies to this topic

#1 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 15 October 2019 - 09:54 AM

I am using Roots Magic for Mac. I converted a Family Tree Maker database to get started in Roots Magic.

 

I am finding facts that have a green check mark indicating that there is a source for that fact, but when i go into sources there is no source. For some reason Roots Magic thinks there is a source when there actually is not.

 

Any suggestions about what the problem might be.

 

Regards,

Dan Yaklin



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 15 October 2019 - 03:00 PM

On what line on the Edit Person screen are you seeing this green checkmark?


Renee
RootsMagic

#3 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 15 October 2019 - 09:07 PM

It varies. Sometimes it can be on a Census fact, sometimes on a Birth fact.

 

Regards,

Dan Yaklin



#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 16 October 2019 - 08:34 AM

I've seen hidden sources on the Person row because of the mismatch in fields in person and general sources, but not on Census or Birth facts. What version of FTM was the import from and how did you do it?


Renee
RootsMagic

#5 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 16 October 2019 - 08:39 AM

Converted from FTM Ver 17 for Mac. Had to convert Ver. 17 back to I believe, if I remember correctly, FTM Ver. 2012. Then converted to Roots Magic.

 

Dan



#6 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 16 October 2019 - 09:40 AM

I have determined that the sources that are blank have a source in the original FTM database for that fact. For some reason the source was not converted correctly and there is a blank source. 

 

I can't find a way to remove that blank source. If I add another source to that particular fact, then Roots Magic says there are two sources. When you go into sources it only shows the newly added source, even thought there are supposed to be two.

 

Dan



#7 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 16 October 2019 - 04:21 PM

See if a drag n drop into a new blank database will remove them. 

 

Using Drag and Drop in RootsMagic


Renee
RootsMagic

#8 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 17 October 2019 - 07:57 AM

I dragged and dropped an individual with the issue to a new database and that cleaned up the check mark issue. But now it is clear the bigger issue is all of the sources that didn't get converted. I checked the FTM Ver. 2012 database that I used to converted to Roots Magic and these missing sources were there in the samples that I checked. 

 

So the question is why didn't it convert these particular sources. It did convert many sources with no issue. Secondly how can I identify these in my Roots Magic database, so I can clean them up. It would be much easier to create a list of the ones with a problem, rather than having to look through each individual in the database and check each source for that individual to find them.

 

DAn



#9 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 17 October 2019 - 12:57 PM

Did you run the FTM version of Database Tools before importing?


Renee
RootsMagic

#10 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 17 October 2019 - 02:46 PM

No, not sure what you are referring to.

 

Dan



#11 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 17 October 2019 - 04:10 PM

If the FTM database has corruption in it there can be odd results. FTM has something similar to RM database tools. Just can't recall what it is. 


Renee
RootsMagic

#12 Dan Yaklin

Dan Yaklin

    Member

  • Members
  • PipPip
  • 23 posts

Posted 17 October 2019 - 05:08 PM

Yes I did a compress before exporting.



#13 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8472 posts

Posted 18 October 2019 - 07:47 AM

Open a support ticket and we can take a look.

https://support.root...us/requests/new


Renee
RootsMagic