Jump to content


Photo

Relationships disappeared, whats happened?


  • Please log in to reply
9 replies to this topic

#1 JACRISTA

JACRISTA

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 25 December 2018 - 08:42 AM

Hope someone can help with this please.

I have my database both on my PC and on my laptop, whilst working on the PC I noticed that my relationship to the person I was on, was not showing up as usual in the bottom left corner, on looking around the database I find that there are a number of people that don't show the relationship and yet most do, I have the Root Person set to me, and I have 'set relationships' again but nothing has altered. I had a look on the laptop and all the relationships show up correctly on there, am I missing something obvious here? as I just can't fathom it out.  Forgot to add that when a relationship doesn't show and I use 'Relationship Calculator' it shows as not being blood related when it really should be giving me a relationship as I'm very sure I'm related to them, 

anyone any ideas as to what's going on, or more to the point, what I've done wrong!!



#2 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3405 posts

Posted 25 December 2018 - 12:02 PM

When you Set Relationships again, are you sure you selected yourself as the reference person?

 

The situation you describe where the Set Relationship is showing up correctly on one machine but not the other seems impossible. Are you certain that you have the same database on both machines?

 

Jerry



#3 JACRISTA

JACRISTA

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 28 December 2018 - 06:05 AM

Hi Jerry, Thanks for the reply, I do appreciate it. Now then, I haven't explained myself very well, on the laptop I opened up an earlier date backup just to see if the missing relationships went back some months, but no, they are all as they should be on an earlier version, I am definitely using myself as the reference person when I do a 'Set Relationships' so somewhere along the line I have done something wrong, it's bound to be me  :rolleyes: duh!  The only thing is, I don't know where to start to sort it all out, you don't have a spare miracle tucked away you can spare me do you Jerry  :unsure:



#4 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6145 posts

Posted 28 December 2018 - 07:37 AM

It sounds like one or more parent-child links have been broken and the now unrelated people are in treelets separate from the one you're in.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8314 posts

Posted 28 December 2018 - 08:22 AM

If you cannot find what links were broken, restoring a backup from the database this is correct would be the easiest option. 


Renee
RootsMagic

#6 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3442 posts

Posted 28 December 2018 - 09:51 PM

Comparing the differences in Marriage List reports of each database may point up disconnected couples.
File -> Compare may also help.

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#7 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6145 posts

Posted 29 December 2018 - 06:24 AM

Because you have both the broken current version and the intact older version, it should be fairly easy to find the missing links. For any pair of unrelated persons whom you have identified that were previously, generate the relationship chart from the old one and, in the new one, traverse each person's lineage in the Pedigree View to locate the missing link.

Comparing the Kinship List reports relative to you from thevtwo versions may help you in identifying those who became disconnected.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#8 JACRISTA

JACRISTA

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 29 December 2018 - 08:48 AM

Thanks for all the help everyone, I'm going to try and digest all your ideas and see if I can 'do' any of these suggestions,(I worry about making things even worse, or worse still, losing it all together)  so with a deep intake of breath I'll see what I can make of it all, I'll be back to let you know how I got on, keep your fingers crossed for me!



#9 JACRISTA

JACRISTA

    Advanced Member

  • Members
  • PipPipPip
  • 48 posts

Posted 04 January 2019 - 09:35 AM

Oh dear, I'm having no luck sorting this lot out at all, I just can't seem to find out what's gone wrong.

 

TomH, I don't think I'm quite understanding what you mean for me to do ( For any pair of unrelated persons whom you have identified that were previously, generate the relationship chart from the old one and, in the new one, traverse each person's lineage in the Pedigree View to locate the missing link)

 

I've done that (I think) and I cant see any missing link, it all looks just exactly the same, either that or I've completely lost the plot!  :wacko: 

 

Renee, I know you said to restore from an earlier date but I'll lose all my gallery links won't I? I sorted out the gallery recently, renamed etc and had just got everyone linked as they should be and then noticed the missing kinship's, also some info that has been added/changed since the earlier backups would be lost won't it?

 

To say it's driving me nuts is putting it mildly, I am spending so much time trying to sort it out, it's got to be something I've done wrong I know that, but finding it is proving nigh on impossible as I've tried all your suggestions (apart from the restore) so if anyone can come up with anything I'd be very grateful.



#10 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8314 posts

Posted 04 January 2019 - 09:50 AM

If you have renamed media then yes, the media links would be broken with a restored backup. You could still restore the backup into a different location/folder. Look at the people that you feel should still be showing a relationship and check how they are related to you. You can have both databases open at the same time in the program. I would just File>Rename the restored one so you can tell them apart. 


Renee
RootsMagic