Jump to content


Photo

can't make a backup


  • Please log in to reply
23 replies to this topic

#21 woaple

woaple

    Member

  • Members
  • PipPip
  • 7 posts

Posted 02 December 2018 - 03:56 PM

Many thanks to all of you trying to help me.

 

Answering TomH:  (1) The only auto backup or other process accessing my *.rmgc db file that I am aware of is my cloud backup, Google Drive.  I have tried my RootsMagic Backup many times with Google Drive on Pause and also when sync is stopped.  Backup still won't work.  I get the same error message.  (2))  I have never heard of SQLiteSpy or SQLite manager.  I don't even know what they are.  (3) I don't know how to look for something that has the database file open.  (4) I am not running any concurrent versions of RootsMagic.  The latest v. 7.5.7 is the only one on my desktop computer.  I should also point out that I have the exact same v.7.5.7 and *.rmgc file on my Windows 10 laptop, and Backup works perfectly.  The difference is that I do not have Google Drive on my laptop.

 

Answering kbens0n:  (1) I followed your suggestion, but Backup still won't work.  I am absolutely positive I have not had more than one copy of the database open at the same time in the recent past.  (2) I will try to figure out how to run and interpret the Handle program.  I am an older guy, but fairly computer savvy.  However, I am certainly no computer nerd/geek.

 

Thanks again for your responses.



#22 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6080 posts

Posted 02 December 2018 - 04:37 PM

Rather than Handle, you could use the GUI version Process Explorer. When you have your database open, then enter the name of it in the Search field of Process Explorer and wait for results.

 

If you really think Google Drive is affecting your backup, move the database file elsewhere or make a copy of it in some other directory outside the scope of GDrive and try backing it up. 


Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#23 woaple

woaple

    Member

  • Members
  • PipPip
  • 7 posts

Posted 03 December 2018 - 10:41 AM

Answering TomH:  I copied my *.rmgc db file (that is in my Documents directory) to my Music directory (because my Google Drive does not backup music).  I then ran RootsMagic from the db file in my Music directory.  Backup works perfectly!  I do not get that error message!  This certainly appears to prove that Google Drive is the culprit.  I can live with this arrangement.

 

Thanks so much for your insightful suggestion!



#24 jbmccall47

jbmccall47

    New Member

  • Members
  • Pip
  • 2 posts

Posted 16 December 2018 - 11:09 AM

Appears to be fine now (24 hours after the problem began yesterday) and appears to have been brought on by down-time with Ancestry sync. I also tried Family Tree Maker 2017 and got the message that it had suspended synching with my Ancestry.com tree because of a problem at that site.