Jump to content


Photo

RM To-Go timestamp issue

It doesnt want to copy.

  • Please log in to reply
3 replies to this topic

#1 Don Newcomb

Don Newcomb

    Advanced Member

  • Members
  • PipPipPip
  • 1008 posts

Posted 03 August 2018 - 01:36 PM

Having a bit of a problem with RM 6 To-Go. I used my RM To-Go thumb drive at the LDS FHC, where I noticed that the PC's clock was two hours slow. I thought nothing of it until I tried to restore the database to my PC at home where RM To-Go reported that the file on my PC was smaller and newer than the one on the thumb drive and refused to copy the thumb drive's file to the PC. I assume I could just do a manual copy from the thumb drive to the PC but I wanted to check before doing that. Unfortunately I don't know of any Windows equivalent to the Unix "touch" command that would just update the time-stamp on the file. 



#2 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5876 posts

Posted 03 August 2018 - 01:55 PM

Just open the file on the thumb drive. Maybe make a minor edit and then close it.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#3 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3088 posts

Posted 03 August 2018 - 02:54 PM

There is another time of day problem with RM To-Go, or at least there used to be. I don't use it any more, but I used to use it very heavily. On rare occasions which were not repeatable, it would sync in the wrong direction, costing me several hours of work. These were on machines that I controlled and where the times were set very correctly and accurately. Every time I thought I had pinned down a repeatable situation so that I could report the problem to the RM developers, the repeatability would disappear.  Nevertheless, I think there is a problem. It does not occur very commonly, but it's not totally rare. If you use RM To-Go daily, it will bite you once every few weeks.

 

So my advice to RM To-Go users is to check the timestamps reported in the sync process very carefully. If things look wrong or if things look like they are going to sync in the wrong direction, back out of the sync and check the timestamps in Windows. If the timestamps in Windows confirm which database you think is the most current, sync it by doing a copy in Windows rather than doing the RM To-Go sync.

 

Jerry

 



#4 Trebor22

Trebor22

    Advanced Member

  • Members
  • PipPipPip
  • 127 posts

Posted 05 August 2018 - 04:20 AM

This may be unrelated but - I have 2 desktop PC's, a main one used daily and an older one with win 7 used less frequently, over the last couple of weeks the older PC has failed to retrieve  the correct date & time from an online 'time server' the other PC (win 10) is fine? while I have not tried RM to go on it, there have been problems with other programmes till I set the time correctly. I think I have 'cured' the problem, In the time / date settings there is a list of websites that can be used to set the time, I choose another one and today when I switched on the time set correctly, perhaps the LDS PC has tripped over the same problem?