Jump to content


Photo

Help does not work on High Sierra 10.3.6 (RM 7.5.7)


  • Please log in to reply
7 replies to this topic

#1 cdg

cdg

    New Member

  • Members
  • Pip
  • 2 posts

Posted 29 July 2018 - 07:12 AM

I am trying to evaluate a couple of different genealogy programs for us on a Mac, so I'm still working with RootsMagic Essentials.  The program looks pretty good, but I cannot use the Help.  The problem has become worse since upgrading to RM 7.5.7.

 

When I launch Help > Contents, the Help window displays but I cannot navigate through the content.

- when I click on a topic, such as Introduction the wrong topic is highlighted/expanded, such as The RootsMagic Interface

- the top-level buttons for Hide, Back, Forward, Home, Options, Print don't work

- the backward/forward buttons at the top of an article don't work 

- Internal links within a topic don't work

 

And since upgrading to RM 7.5.7 this morning, launching and closing Help > Contents results in the main UI for the application to become dysfunctional - I can't use the main menu items (File, Edit, Lists) or navigate through the persons index.

 

I'm using a MacBook Pro 15.4-inch (resolution 2880 x 1800) with High Sierra 10.3.6.

 

Does anyone know if there's a fix for this or is there an alternative source for the Help such as a PDF?  

 

I am close to liking and buying RootsMagic, but the Help is a deal breaker.

Thanks, Chris



#2 Jim Byram

Jim Byram

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 29 July 2018 - 10:06 AM

http://forums.rootsm...function-in-rm/



#3 cdg

cdg

    New Member

  • Members
  • Pip
  • 2 posts

Posted 29 July 2018 - 10:19 AM

Thanks, Jim. I figured the root cause was something like that.  

 

I managed to find a workaround/fix; after I noticed that the Help content opens as a second tab in the application window, I discovered that clicking on the Help tab header and dragging the Help tab out to become a separate window resolves the issue!

 

As a bonus I can use the Mac support for Split Screen to snap the app and Help windows side-by-side so now I can read the help while working in the app!  This is looking promising!



#4 veehb

veehb

    New Member

  • Members
  • Pip
  • 3 posts

Posted 16 August 2018 - 09:42 PM

Not sure if this is the place to ask this question, but:  I purchased RootsMagic at RootsTech in March in Salt Lake City.  Haven't really tried using it since then.  But I have a very large Ancestry tree and need to prune some of the branches and create a few new Ancestry trees.

 

I found a tutorial that was generated a year or so ago telling how to use the RootsMagic/Ancestry interface and how to download a tree, export new trees from the downloaded tree in  RootsMagic and then merge them into one new tree and upload it to Ancestry.  Looks pretty straight forward, so I tried it.  I had downloaded my tree a few months ago, and tried to use it.  When I connected to Ancestry, It found over 100 changes.  I was not able to edit the changes and make the two databases the same, so after a few frustrating tries, I deleted the tree in RootsMagic and downloaded my Ancestry tree again (about 13,000 names).  It took a while but it came down OK.  But the export function doesn't work as described in the video.  I finally got it to export a new tree, but it turned out to be a GEDCOM file and not a tree that I could upload to Ancestry.  

 

My biggest confusing is that I loaded RootsMagic a few months ago and today when I started it, it said that there was an update, so I updated it.  Now it says that it is running version 7.0.1.  I just joined this user forum and see that you are talking about a version 7.5.something.  Should I be running a later version and if so, how do I down load it.  I'm using an iMac about two years old (27 inch hi-rez screen) and running High Sierra 10.13.6.  I also don't see any recent videos from RootsMagic that will help with this.

 

I also find the help files not working at all.  Maybe I'll try your suggestion, cdg.

 

Maybe I should have started a new topic, rather than hijack this one.  Feel free to move this if necessary.

 

Any suggestions will be greatly appreciated.  I really don't want to try the new Family Tree Maker.

 

Thanks



#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8039 posts

Posted 17 August 2018 - 08:54 AM

The 7.0.1 on the the Apple menu for the CrossOver wrapper around RootsMagic. It should show under RootsMagic>About RootsMagic

 

Version 7.0.1 (7.0.1)
Copyright 2016 CodeWeavers, Inc

 

The RootsMagic program itself in the menu go to Help>About RootsMagic to see the version number. It should be 7.5.7.0.


Renee
RootsMagic

#6 veehb

veehb

    New Member

  • Members
  • Pip
  • 3 posts

Posted 18 August 2018 - 08:00 PM

Thanks, Renee.  Why don't they put the real version number in the "About RootsMagic" in the main Roots Magic menu?  This is most confusing and cost me many hours of trying to figure out how to get the latest version.  I had it all the time.



#7 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8039 posts

Posted 20 August 2018 - 12:14 PM

When you update RM you won't necessarily update the CrossOver wrapper. It takes a complete uninstall/reinstall to do that. That is why we need the version numbers in different places. I don't see this changing until we have the native Mac version where the CrossOver wrapper is no longer needed.


Renee
RootsMagic

#8 k1p2

k1p2

    New Member

  • Members
  • Pip
  • 4 posts

Posted 10 September 2018 - 06:50 PM

Does anyone know if there's a fix for this or is there an alternative source for the Help such as a PDF?  

 

I have High Sierra also.  But I only have the full RM7 program.

 

You may have a mouse problem.  My mouse points to one area and it click a tad bit lower.  I have a Logitech mouse and it does this on lots of things, so may be something in High Sierra as I don't really remembering it doing this before (or else I just didn't notice).

 

In Help>the guide, when you have your cursor over the 'forward or back' buttons and it "sees" them, the square the green arrow is on will outline.  That is how you can tell.

 

The reason I say that, is because when I put my cursor on 'Intro', it also opens the 'Interface' topic.  BUT it does this on lots of other programs too.  I do not think this applies to "the hand" icon, just the cursor icon.

 

Hope this helps.