Jump to content


Photo

RM7 Won't Start

Freeze Halts Error

  • Please log in to reply
8 replies to this topic

#1 jdfurny

jdfurny

    New Member

  • Members
  • Pip
  • 3 posts

Posted 23 May 2018 - 05:24 PM

Started using RM a couple weeks ago.  Had problems along the way with freeze ups, perhaps once an hour or two.  Usually, Force Quit works.  Sometimes afterward it would not start and I rebooted once or twice and got it to start.  Also, would occasionally get a small popup window with some type of program fault. 
 
Read through the forum today and performed the removal instructions precisely, recommended here: http://forums.rootsm...k-at-wikipedia/.
 
Now I am unable to open RM at all.  The icon does the "hop" with the dot underneath the icon, then after a few seconds a small window flashes for a split second and it displays "Please wait while your application shuts down".  

I appreciate any help.

#2 Robert-Leigh:Pritchett

Robert-Leigh:Pritchett

    Advanced Member

  • Members
  • PipPipPip
  • 82 posts

Posted 23 May 2018 - 07:41 PM

I was on the bottle version for the last 14 days because RM would not work at all with the previous beta version of Mac OS. As of this moment it works now. I'm excited! But the glitches are still very much alive in the Mac version of RootsMagic 7. I was told by support that version 8 will be the full-blown Mac native version. I am on pins and needles. We've patiently waited for so long for that version to surface.



#3 jdfurny

jdfurny

    New Member

  • Members
  • Pip
  • 3 posts

Posted 23 May 2018 - 08:14 PM

Mac version would be nice. The thought of dusting off and setting up my old Windows desktop has occurred to me in the last couple weeks just for RM.

#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8045 posts

Posted 24 May 2018 - 09:25 AM

Move the database it is trying to open with to a different location on the computer. Then see if RM will open without it. Once you do open RM then try to open the database. Go to File>Database Tools and run all options there in consecutive order.

 

Are you also using the latest beta version of the Mac OS?


Renee
RootsMagic

#5 jdfurny

jdfurny

    New Member

  • Members
  • Pip
  • 3 posts

Posted 24 May 2018 - 07:16 PM

Thank you Renee.  Working again.

 

Removing all .rmgb files did not work at first.  Uninstalled as before, then poked around and found two RM subdirectories.  One had a subdirectory called Bottle in it.  Deleted both, then RM started as new, requiring key, etc.

 

Not using beta OS.



#6 BradleyinDC

BradleyinDC

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 22 June 2018 - 11:28 AM

I was on the bottle version for the last 14 days because RM would not work at all with the previous beta version of Mac OS. As of this moment it works now. I'm excited! But the glitches are still very much alive in the Mac version of RootsMagic 7. I was told by support that version 8 will be the full-blown Mac native version. I am on pins and needles. We've patiently waited for so long for that version to surface.

We are waiting, increasingly impatiently!, for the native Mac version



#7 RWells1938

RWells1938

    Advanced Member

  • Members
  • PipPipPip
  • 202 posts

Posted 25 June 2018 - 08:22 AM

When you try to connect to FS and the PID number you have in RM is now invalid because of some changes in FS (merge) then RM hangs up. When you force quite RM it will then not start up. So I have to goto the Activity Monitor and kill all of the process called Wineloader then RM will restart with out having to restart the computer.

 

How can you unlink the person in RM when you can not connect to FS. If you could reconnect it is easy to unlink then but when you can't connect RM to FS how can you disconnect/unlink?

 

If I use RM7 running under Crossover I do not have this problem. I am using Rm version 7.5.7.0 (12 Jun 2018) in both cases.

 

Also once you get RM running under Crossover then revert to the version with just a wrapper it works.

 

Roger



#8 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8045 posts

Posted 25 June 2018 - 04:19 PM

Make sure you are logged in under File>FamilySearch Central before clicking on the FS icons. Once logged in you should be able to click any pop-up that appear and then UnMatch. The other option is to UnMatch under a relatives relationships to them. Click on their blue FS icon on the FS side and it will give the option to remove match.


Renee
RootsMagic

#9 pbooth99

pbooth99

    Member

  • Members
  • PipPip
  • 28 posts

Posted 29 July 2018 - 12:30 PM

I found that sometimes Rootsmagic won't start because there are still old wine processes remaining from the prior RootsMagic process. I wrote a little script to kill those and find I no longer have any problems with it starting.

 

peter@retina-2 ~/ $ cat ~/bin/cleanupWineSpills.sh 

#!/bin/bash -x

ps gauxww | grep -i rootsmag | grep -v grep | awk '{print $2}' | xargs kill 

ps gauxww | grep wine | grep -v grep | awk '{print $2}' | xargs kill