Jump to content


Photo

Roots7 won't start - failed to import cxutils module


  • Please log in to reply
1 reply to this topic

#1 miams

miams

    New Member

  • Members
  • Pip
  • 2 posts

Posted 22 April 2018 - 09:02 AM

Running on Mac High Sierra - 10.13.4

 

Beginning about 2 weeks ago, I'm no longer able to start Rootsmagic.   I get this error:

 

Initialization Failure


CrossOver is unable to initialize a critical component.

 

Failed to import cxutils module into Python.  See console for errors.

 

The program will now exit


I have performed the complete Rootsmagic re-install per the posted instructions but that has not resolved the issue.  A few weeks ago I was installing some python libraries and performed an upgrade to python via Homebrew, and I suspect that is the underlying cause.  I've since rolled back the python3 I had installed.  I tried the Rootsmagic re-install and that still fails.   

 

Are you able to provide specific dependencies Crossover requires?  I suspect Crossover is looking down a wrong path.   I've posted debug info below.  You assistance is appreciated.

 

 

miams:~ miams$ which python
/usr/bin/python
miams:~ miams$ python --version
Python 2.7.10
miams:~ miams$ python3 --version
Python 3.6.5
 
 

miams:~ miams$ pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
altgraph (0.10.2)
asn1crypto (0.24.0)
bdist-mpkg (0.5.0)
beautifulsoup4 (4.6.0)
bonjour-py (0.3)
boto3 (1.5.31)
botocore (1.8.45)
certifi (2018.1.18)
cffi (1.11.5)
chardet (3.0.4)
click (6.6)
colorama (0.3.7)
cryptography (2.2.2)
DataProperty (0.30.0)
docopt (0.6.2)
docutils (0.14)
dominate (2.3.1)
elasticsearch (6.2.0)
enum34 (1.1.6)
functools32 (3.2.3.post2)
futures (3.2.0)
idna (2.6)
ipaddress (1.0.19)
Jinja2 (2.8)
jmespath (0.9.3)
jsonschema (2.6.0)
Logbook (1.3.0)
macholib (1.5.1)
markdown2 (2.3.5)
MarkupSafe (1.0)
matplotlib (1.3.1)
mbstrdecoder (0.2.3)
modulegraph (0.10.4)
nassl (1.1.0)
numpy (1.8.0rc1)
packaging (16.8)
path.py (11.0.1)
pathvalidate (0.16.3)
pip (9.0.3)
pshtt (0.4.1)
publicsuffix (1.1.0)
py2app (0.7.3)
pycparser (2.18)
pyobjc-core (2.5.1)
pyobjc-framework-Accounts (2.5.1)
pyobjc-framework-AddressBook (2.5.1)
pyobjc-framework-AppleScriptKit (2.5.1)
pyobjc-framework-AppleScriptObjC (2.5.1)
pyobjc-framework-Automator (2.5.1)
pyobjc-framework-CFNetwork (2.5.1)
pyobjc-framework-Cocoa (2.5.1)
pyobjc-framework-Collaboration (2.5.1)
pyobjc-framework-CoreData (2.5.1)
pyobjc-framework-CoreLocation (2.5.1)
pyobjc-framework-CoreText (2.5.1)
pyobjc-framework-DictionaryServices (2.5.1)
pyobjc-framework-EventKit (2.5.1)
pyobjc-framework-ExceptionHandling (2.5.1)
pyobjc-framework-FSEvents (2.5.1)
pyobjc-framework-InputMethodKit (2.5.1)
pyobjc-framework-InstallerPlugins (2.5.1)
pyobjc-framework-InstantMessage (2.5.1)
pyobjc-framework-LatentSemanticMapping (2.5.1)
pyobjc-framework-LaunchServices (2.5.1)
pyobjc-framework-Message (2.5.1)
pyobjc-framework-OpenDirectory (2.5.1)
pyobjc-framework-PreferencePanes (2.5.1)
pyobjc-framework-PubSub (2.5.1)
pyobjc-framework-QTKit (2.5.1)
pyobjc-framework-Quartz (2.5.1)
pyobjc-framework-ScreenSaver (2.5.1)
pyobjc-framework-ScriptingBridge (2.5.1)
pyobjc-framework-SearchKit (2.5.1)
pyobjc-framework-ServiceManagement (2.5.1)
pyobjc-framework-Social (2.5.1)
pyobjc-framework-SyncServices (2.5.1)
pyobjc-framework-SystemConfiguration (2.5.1)
pyobjc-framework-WebKit (2.5.1)
pyOpenSSL (17.5.0)
pyparsing (2.0.1)
pytablereader (0.16.0)
pytablewriter (0.27.2)
python-dateutil (2.7.2)
pytz (2018.3)
PyYAML (3.12)
requests (2.18.4)
s3transfer (0.1.13)
sceptre (1.3.3)
scipy (0.13.0b1)
setuptools (39.0.1)
SimpleSQLite (0.20.1)
six (1.11.0)
SSLyze (1.4.1)
tabledata (0.0.6)
tls-parser (1.2.1)
toml (0.9.4)
typepy (0.0.23)
typing (3.6.4)
urllib3 (1.22)
wget (3.2)
xattr (0.6.4)
xlrd (1.1.0)
XlsxWriter (1.0.2)
xlwt (1.3.0)
zope.interface (4.1.1)
You are using pip version 9.0.3, however version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
 
 
 

miams:~ miams$ pip3 list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
pip (9.0.3)
setuptools (39.0.1)
wheel (0.30.0)
You are using pip version 9.0.3, however version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
 

miams:~ miams$ brew info python
python: stable 3.6.5 (bottled), devel 3.7.0b3, HEAD
Interpreted, interactive, object-oriented programming language
/usr/local/Cellar/python/3.6.5 (4,768 files, 100.2MB) *
  Poured from bottle on 2018-04-22 at 10:22:37
==> Dependencies
Build: pkg-config ✘, sphinx-doc ✘
Required: gdbm ✔, openssl ✔, readline ✔, sqlite ✔, xz ✔
Optional: tcl-tk ✘
==> Options
--with-tcl-tk
Use Homebrew's Tk instead of macOS Tk (has optional Cocoa and threads support)
--devel
Install development version 3.7.0b3
--HEAD
Install HEAD version
==> Caveats
Python has been installed as
  /usr/local/bin/python3
 
Unversioned symlinks `python`, `python-config`, `pip` etc. pointing to
`python3`, `python3-config`, `pip3` etc., respectively, have been installed into
  /usr/local/opt/python/libexec/bin
 
If you need Homebrew's Python 2.7 run
  brew install python@2
 
Pip, setuptools, and wheel have been installed. To update them run
  pip3 install --upgrade pip setuptools wheel
 
You can install Python packages with
  pip3 install <package>
They will install into the site-package directory
  /usr/local/lib/python3.6/site-packages
 
 
 
 
 
 


#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7918 posts

Posted 23 April 2018 - 08:10 AM

Probably best to call in so we can check to see what is happening.

 

Phone: 801-489-3102 - Mon-Fri 8:00am-5:00pm (MT)


Renee
RootsMagic