Jump to content


Photo

Several MyRootsMagic questions

myrootsmagic online pedigree view media gallery one person pubblish treeshare

  • Please log in to reply
6 replies to this topic

#1 Bram

Bram

    Member

  • Members
  • PipPip
  • 6 posts

Posted 14 April 2018 - 05:02 AM

Good morning all,

 

I am new around here and browsed around using the search engien for about an hr. But did not find an answer to my question.

 

Since a couple of months have been working on my tree using Ancestry.com

 

Last couple of days I looked into getting the data online so family members , or actually any one with an interest in my family tree, can see the data online without subscribing to the Ancestry website.

 

Since I like what Rootsmagic does I bought the Version 7 , downloaded my Ancestry tree (uing the Treeshare option) and uploaded it to sites-rootsmagic- com (using the Myrootsmagic option).

 

The first test is located overhere: http://sites.rootsma...-tree/index.php

 

Regarding the online result I have several questions. Hopefully one of you can help me out.

 

 

A)  Pedigree View - no pedigree

In the Pedigree View I see only one person at a time. I seem unable to get a result like this on the sample site: http://sites.rootsma...le/pedigree.php

Even for my self the Pedigree can not be shown

 

B)  Introduction Page Photo - how to include

Where / how do I select / define the photo visible in the introduction ? As can bee see here on the sample site: http://sites.rootsma...ample/index.php

 

C)  Color Coding Male & Female - how to

How do I give male and females a different color ?

 

D) Media Gallery - no large version

Some images open to full size when clicking on them but other stay at thumbnail size

As can be seen in this screenshot: https://postimg.cc/image/fabskjn23/

 

E) Media gallery - no buttons

My media gallery does not have the "image" and "list" buttons although the sample gallery does have them, as can be seen overhere: http://sites.rootsma...ple/gallery.php

 

Any suggestions what the solution for the above issues could be ?

 

Thanks in advance for your help



#2 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5689 posts

Posted 14 April 2018 - 02:12 PM

A. Pedigree view is working as expected

 

B. Look in the Help system under Contents > Internet features > MyRootsMagic and scroll down to the second last image showing the page on which you set the home page photo.

 

C. Also Help > Contents > Tools > Color Coding. You can set all males to one color and all females to another. Note that the website already uses a colored and different icon for males and females on Name lists, Individual Summaries but not on Pedigrees where developers must have thought it was redundant. That said, it should have been provided for at least the root person on a Pedigree page.

 

D. Only two of the images on the 1st page open up for me. That's a question for Support. Maybe the image uploads or the processing of them failed to complete.

 

E. Another question for Support. I'll hazard a guess that the Sample site is running a different script that has not been deployed generally. I can make your site show a list - click this http://sites.rootsma...y.php#view=list


Tom user of RM7230 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a growing bundle of RootsMagic utilities.


#3 Bram

Bram

    Member

  • Members
  • PipPip
  • 6 posts

Posted 14 April 2018 - 02:53 PM

Thanks Tom !

 

A) Too my surprise it is working correctly now. No idea why. Perhaps me uploading the data a few times during the course of the day fixed it.

 

B) A few hrs ago I found a work around by inserting html code in the introduction text. Would like to try what you wrote though and do it the official way. But I do not understand your instructions. I see the help text, but seems the only way is to delet my data first. Certainly there must be a more sensible method ?

 

C) Read that help text this morning but have no clue how to set male / female colors. In the help text they even do not tell me where in the menu structure the color coding options are hidden. I did find the tools menu, but seems impossible to have color depending on sex.

 

D) I will contact them and keep you guys posted.

 

E) Thanks for the workaround !



#4 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5689 posts

Posted 14 April 2018 - 03:18 PM

B. A few hrs ago I found a work around by inserting html code in the introduction text. Would like to try what you wrote though and do it the official way though. But I do not understand your instructions. :-(

You set the photo on the same page where you set the site title and description.

C) Read that help text this morning but have no clue how to set male / female colors. In the help text they even do not tell me where in the menu structure the color coding options are hidden. I did find the tools menu, but seems impossible to have color depending on sex.

I don't think it adds much to colour code by sex. Colour is more useful in distinguishing paternal ancestors from maternal, your ancestors from your spouse's, or for geographic origin, or other things that are not already easily discerned from the display. Sex is already handled well enough except for the root person on the pedigree view.

 

Nonetheless, the steps are through the menu > Tools > Color Code People to bring up the color coding dialog window.

  • Select the color you want to apply to the males
  • then "People selected from a list"
  • OK to open the "Select the people to color code" dialog window
  • Click "Mark Group" and, from the dropdown list, "Select people by data fields"
  • Click the 1st "<<Select field>>" dropdown list and scroll down to select "Sex"
  • Leave the "is male" field as is and click "OK"
  • OK the status report that says how many people were marked
  • OK the dialog window
  • the view should refresh showing the males coloured.
  • Repeat with a different colour but change "is male" to "is female".
  •  

Tom user of RM7230 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a growing bundle of RootsMagic utilities.


#5 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7582 posts

Posted 16 April 2018 - 01:01 PM

D. Only two of the images on the 1st page open up for me. That's a question for Support. Maybe the image uploads or the processing of them failed to complete.

 

Check in RM under Lists>Media Gallery if those thumbnail type images have a red x in the lower right corner. If the media links are broken then it will only upload the thumbnails to the website. Use Tools>Fix broken media links in the Media Gallery to repair them. Right now if you do reupload it will create thumbnails you will want to delete the website first to upload a fresh copy.

 

E. Another question for Support. I'll hazard a guess that the Sample site is running a different script that has not been deployed generally. I can make your site show a list - click this http://sites.rootsma...y.php#view=list

 

I'm pretty sure that hasn't been updated since it was created. Changes were made to the media gallery afterwards. 


Renee
RootsMagic

#6 Bram

Bram

    Member

  • Members
  • PipPip
  • 6 posts

Posted 16 April 2018 - 01:16 PM

Thanks for the help Renee,

 

 

Check in RM under Lists>Media Gallery if those thumbnail type images have a red x in the lower right corner. If the media links are broken then it will only upload the thumbnails to the website. Use Tools>Fix broken media links in the Media Gallery to repair them. Right now if you do reupload it will create thumbnails you will want to delete the website first to upload a fresh copy.

 

Nope, no red crosses.

 

Bram



#7 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7582 posts

Posted 17 April 2018 - 09:49 AM

If you take those same people, with images that are only thumbnails, and upload them do you get the larger images? Just drag n drop them to another database to upload for testing. 


Renee
RootsMagic