Jump to content


Photo

Drag and Drop no longer working


  • Please log in to reply
10 replies to this topic

#1 momakid

momakid

    Member

  • Members
  • PipPip
  • 29 posts

Posted 14 February 2018 - 05:30 AM

I did a Windows 10 update. I also did a RootsMagic update to 7.5.5. Prior to the updates, I was dragging a jpg file from windows explorer into the Media Album screen instead of clicking Add New Media button. Can I pretty please have the drag and drop feature back?



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7659 posts

Posted 14 February 2018 - 08:13 AM

Drag n Drop media is working in the Media Gallery and Media Album for me. Check that your image is not corrupt somehow. 


Renee
RootsMagic

#3 momakid

momakid

    Member

  • Members
  • PipPip
  • 29 posts

Posted 17 February 2018 - 06:18 AM

It is working now.  I have a feeling the drives index was being rebuilt after the windows 10 update was done. There was other strange stuff going on after i reported it. Windows did reboots after the update but i did another and then it started working. Go figure/



#4 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 2908 posts

Posted 17 February 2018 - 07:33 AM

In some ways this comment has nothing to do with RM and only has to do with Windows 10, but I'll make the comment anyway because it has impacted my work with RM.

 

As compared to previous versions of Windows, Windows 10 Update can be a very major pain. By default, it is completely automatic and you have virtually no control over it. It updates if it wants to and anytime it wants to. I have had great difficulty finding an option whereby I can maintain some control over it. For example, I'm going to be giving a presentation about RM in a few weeks and I fear that my machine might start updating Windows 10 in the middle of my presentation. And more recently, I have had an occasion where I was working in RM and RM became exceedingly slow - and I mean exceedingly, exceedingly slow. I thought something was wrong with RM. But upon further review with Windows Task Manager, the problem was simply that Windows 10 was updating itself behind the scenes without my knowledge or consent. Under these circumstances, Windows 10 will eventually reboot itself without my consent. I have found a couple of remedies, but so far I have not found a really good one that doesn't involve crippling Windows 10 Update.

 

Jerry



#5 Bob C

Bob C

    Advanced Member

  • Members
  • PipPipPip
  • 152 posts

Posted 17 February 2018 - 01:04 PM

Jerry,

 

have you looked at "Active Hours" settings?

 

Set active hours to let Windows know when you're typically at your PC. We'll use that info to schedule updates and restarts when you're not using the PC. Select the Start button, select Settings > Update & security > Windows Update , then select Change active hours

 

I use this to allow updates at night when I am not using the computer (after 10:00pm)

 

Bob



#6 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 2908 posts

Posted 17 February 2018 - 03:01 PM

We are about to get pretty off subject here, but I will continue briefly anyway. I'm aware of the Active Hours setting, but it doesn't do what I want. I never want a Windows Update to commence without my explicit authorization, and I have to be at the keyboard to give that explicit authorization. I'm not at the keyboard at 2:00 a.m. so that's not when I want the Windows Update to commence. There is simply too much chance of a project I'm working on getting killed. So I want to give explicit authorization for a WIndows Update only when I have closed all open windows myself and made very sure that all my projects are backed up and safe.

 

I have many active projects that are not RM. But to use RM as an example and to remain slightly on topic, I want to be able to walk away from my computer in the evening, to leave an RM window open, and to come back to my computer the next morning and pick up exactly where I left off. Having an open RM session killed by an automatic Windows Update is not something I want to happen. I'm not worried about leaving my machine on. My "desktop" machine is a laptop with a mouse, so it's automatically got battery backup. I have whole house surge protection. And in the event of whole house power failure for an extended period, Windows does a very good job on a laptop of putting the whole machine to sleep without any loss of anything in the event of a low battery condition.

 

Jerry

 



#7 Ludlow Bay

Ludlow Bay

    Advanced Member

  • Members
  • PipPipPip
  • 859 posts

Posted 17 February 2018 - 04:18 PM

Just stop and start the Windows Update Service at your discretion.



#8 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3366 posts

Posted 17 February 2018 - 09:47 PM

One can choose how updates are delivered, choose how updates are installed, request Notify to schedule restart and choose a time in the future, etc.
I just update/restart my machine in between tasks or before starting one.

https://www.lifewire...ettings-2625778

---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#9 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 2908 posts

Posted 17 February 2018 - 10:54 PM

If you go to the referenced pages, you will find the following text.

 

Tip: There is no official way to turn off automatic updating in Windows 10, nor is there a straightforward way to disable Windows Update altogether. You could try setting your Wi-Fi connection as metered, which would prevent update downloading (and of course installing) but I don't recommend that you do that.

 

The tip above basically confirms my experience. When I go to the Windows 10 Update Advanced Settings, all the old useful settings such as "Download without updating" or "Alert me when updates are available" are gone. The only thing you seem to be able to do is to tell it some times when your machine can be updated without my consent. Can you imagine how we would yell at Bruce if RM started updating itself without our consent?

 

There are some ways to turn Windows 10 Update off completely (ways that are not supported by Microsoft), but then it's off completely and gives you no alerts that updates are available and no opportunity to download the updates without installing them. For some of my apps such as RM, a reasonable bypass is simply to close the lid on my laptop or otherwise put my entire machine to sleep. Waking it up the next morning doesn't take very long and the open apps are still there. But I also have an app I run (a program I wrote) which often I want to run continuously without my machine ever sleeping. I think Microsoft is just way off base on this one. And it really is an RM issue because the Microsoft Update tries to cause RM to exit which tries to do a backup and there is nobody at the keyboard to approve the backup, etc. And that assumes I haven't left RM in a modal window where I was working so I can remember where to pick up where I left off. RM cannot exit cleanly out of a modal window any more than it can exit cleanly without keyboard intervention if backups are enabled on exit.

 

Jerry

 



#10 momakid

momakid

    Member

  • Members
  • PipPip
  • 29 posts

Posted 17 February 2018 - 11:34 PM

Yes, I do have the active hours selected. Unfortunately, I am doing things at all times of day and night. If I can't sleep, I am up working on RM.

I found this article (https://www.easeus.c...lly-update.html) and I am trying it to see if it stops the automatic updates. I have been in the middle of doing updates to Ancestry and it reboots without notice.  I plan to check manually to see if there are updates on a monthly basis. 



#11 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7659 posts

Posted 19 February 2018 - 04:03 PM

I have found shutting down my computer at night and restarting every morning seems to get the updates to happen first thing in the morning. A pain, but at least the deed is over and I can work the rest of the day.


Renee
RootsMagic