Jump to content


Photo

Search person list not working?


  • Please log in to reply
2 replies to this topic

#1 jgd

jgd

    Member

  • Members
  • PipPip
  • 9 posts

Posted 13 January 2018 - 09:45 AM

I was trying to search my database for possible Civil War participants, so I used 

Search -> Person List

Sex is male 

and Birth date before 1850

and Birth date after 1820

and Death date after 1861

 

The search didn't seem to do anything.  In fact, just a search of 'Sex is male' returns males and females.

 

-John



#2 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5593 posts

Posted 13 January 2018 - 12:01 PM

Maybe you should run File > Database Tools on your database.

Tom user of RM7230 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a growing bundle of RootsMagic utilities.


#3 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 2750 posts

Posted 13 January 2018 - 03:04 PM

Your search appears as if it should work correctly, except there is a missing click. After Search -> Person List and Sex is male, you need to click Find. I suspect you did click Find and just didn't report it.

 

In any case, when you tried just Sex is male, exactly what happened? Did it go to the very first person in your database, and then to the second, and then to the third, etc.?  Or did it do nothing?

 

It really should work, except it should go only to the males and skip the females.

 

Jerry