Jump to content


Photo

Media Tagging in Master Source List

media tag master source list

  • Please log in to reply
7 replies to this topic

#1 Rosemv

Rosemv

    New Member

  • Members
  • Pip
  • 4 posts

Posted 19 December 2017 - 05:14 AM

Hello Everyone, 

I'm not getting consistent results with my Source Media. I hope someone will be able to tell my where I'm going wrong.

 

The birth, marriage and death facts for the majority of my family tree persons prior to 1900 are from about 4 villages in Croatia, familysearch.org has microfilmed each of the complete parish books.  There is at least 1 book for each of the 3 life facts, the books cover varying number of years (dependent on the parish), so you may have a single book of births covering a 11 year period, others 6 years and so on. (none of which are indexed by the way)

 

My idea was to attach (tag) an image of the front of each book and an image of the microfilm details (this shows which parish, years, date filmed, etc) as media to my Master Source and then I would just need to attach (tag) an image of the relevant birth, death or marriage of the person as the Detail.

 

These are the steps I took.

  1. I copied a Source Template which I thought would best suit my needs and re-named it.
  2. Made a couple of amendments to the Field area, Footnote, Bibliography to suit my needs.
  3. Opened the edit screen for a person to add the Birth Source, I selected "Add new source".
  4. Selected my newly created source, added the relevant details in Master Source area and Source Details area.
  5. Added new media of the 2 images identifying the book as source only and the birth record of the individual as Detail only. Clicked on Source and Details and 3 images showed.  So far so good. 
  6. Clicked ok,
  7. Named this new Master Source Name so as to easily identify and differentiate based on the parish,fact,years covered.
  8. Moved on to the next person, this time I selected "Cite existing source" and selected the one I had just created, changed the Master Source name to suit, made relevant amendments to the Master Source and added Source Details information. 
  9. When I clicked on the Media button, it showed the 2 media I had tagged as the source in the original Master Source. 
  10. So I deleted the tags and added the appropriate media, clicked ok. I had to to do this for each of the 4 Master Sources I created.

 

My Master Sources are - Births (1888-1893), Births (1894-1898), Births (1899) and Marriages (1888-1899) and each time I edit a person and select "Cite an existing source" in Citation Manager, it is remembering the previously added source media.

So, for instance if I add a citation of a birth (1888-1893) and then move to someone else and add a marriage citation Marriages (1888-1899), the media shown is that of the births (1888-1893).

 

Not sure what I'm doing wrong but it would be great if someone could steer me in the right direction.

 

Thank you in advance.

 

Rose

 

 

 



#2 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5876 posts

Posted 19 December 2017 - 10:52 AM

Step 8 is wrong. When you cite an existing source and edit the Master area and name, you have changed the original master source for the previously entered citations. Go into Lists > Source Lists and create your master sources there first. Now you have your multiple master sources existing from which you can select the one you want to cite.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#3 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3089 posts

Posted 19 December 2017 - 11:52 AM

Just to further clarify what Tom has said, suppose you are entering three people. The source for the first person is  Births (1888-1893) page 17, the source for the second person is  Births (1899) page 52, and the source for the third person is  Births (1888-1893) page 103.

  • For the first person, you would create a new Master Source and Source Detail with the name of the Master Source being called something like  Births (1888-1893), with the image of the cover page being linked to the Master Source, and with the image of page 17 being linked to the Source Detail.
  • For the second person, you would create a new Master Source and Source Detail with the name of the Master Source being called something like Births (1899), with the image of the cover page being linked to the Master Source, and with the image of page 52 being linked to the Source Details.
  • For the third person, you would use an existing Master Source, namely the Master Source called Births (1888-1893). The cover page image would already be linked. In the Source Details, change the data value to page 103 and link in the image of page 103.

I'm not sure exactly that your Source Template looks like, but in addition to linking the specific page images to the Source Details, any data associated with those specific page images needs to be in the Source Details.

 

Jerry



#4 Rosemv

Rosemv

    New Member

  • Members
  • Pip
  • 4 posts

Posted 20 December 2017 - 07:14 AM

Despite following instructions posted by Jerry and TomH, I'm still getting same results.

 

Not sure how to attach images to this post to show my screen shots of what I'm doing.  I don't seem to have access and cannot find it in the Help section.



#5 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5876 posts

Posted 20 December 2017 - 08:08 AM

Upload images to a public web server such as postimages.org. Copy the direct link (with the full filename in it) and paste it into the image widget dialog of the forum message editor.

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#6 Rosemv

Rosemv

    New Member

  • Members
  • Pip
  • 4 posts

Posted 29 December 2017 - 06:02 AM

Thanks for your help TomH and Jerry Bryan.  

I worked out that I need to tag my 2 relevant Source Media to each of my Master Sources first,

then create a citation for an individual and only tag their specific media (certificate) as Detail Media. 

What I didn't realise is that I don't see the Source Media already tagged until I complete the citation. 

Click on the citation, Edit, Media and now all 3 media are shown.



#7 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3089 posts

Posted 29 December 2017 - 06:20 PM

What I didn't realise is that I don't see the Source Media already tagged until I complete the citation. 

 

There are several areas of the user interface for the Edit Person screen that have this problem. I'm not sure that 100% strictly speaking this could be regarded as a bug, but it can certainly be confusing and irritating sometimes. At the highest level of the Edit Person screen, pretty much everything you do shows up right away and there is no confusion. But complete use of Edit Person screen can involve several levels of sub-windows including sources, citations, and media. Sometimes changes made at these lower levels of Edit Person do not become visible to the higher levels of Edit Person until and unless you first exit out of the Edit Person screen and then re-enter the screen. I have reported some of these problems before and I have tried a couple of times to find and document them all. But some of the problems do not seem to be 100% repeatable. It can be very hard to document and report problems that are not repeatable.

 

Given that RM is being completely rewritten as RM8 (at least I assume that will be the name of the new program), it seems very unlikely that these problems will ever be addressed in RM7. Indeed, I would think it would be a great waste of programmer time to be fixing obscure bugs in RM7 when the goal needs to be to get RM8 out the door. So we can only hope that the programmers will very attentive to the minutest details of this situation in RM8. When any changes are made at any level of the Edit Person screen, the changes should immediately be refreshed and be visible at that level of the Edit Person screen and at any other level of the Edit Person screen.

 

Jerry



#8 Rosemv

Rosemv

    New Member

  • Members
  • Pip
  • 4 posts

Posted 29 December 2017 - 07:11 PM

Yes, certainly confusing and irritating but now that I know, I can live with it.  Although, wasting at least a couple of hours of my time trying to replicate the issue wasn't ideal.

 

I have a bigger issue with TreeShare for Ancestry.  

After I have created a Source in RM.  I only tick the Media to Update existing event on Ancestry and NOT the Source, yet in Ancestry, it will create a new Source made up of a mixture of the details I added in RM each time. 

 

The issue is then to delete this newly created and unusable Source in Ancestry. 

As I was advised by one of the Expert Help people - I need to pretend to be adding a Source for a person in order to delete a Source it created without my prompting. 

 

Now that is a total waste of my time.

 

Rose