Jump to content


Photo

Narrative report cuts off first letter of first sentence on 2 pages


  • Please log in to reply
12 replies to this topic

#1 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 27 October 2017 - 11:31 AM

I generated a 4 generation ancestor narrative report yesterday and in 2 places, the first letter of the person's name is omitted. ie. Charles is harles and John is ohn.

 

The first occurrence was on page 2 and was the burial sentence for my 1st generation person. It is the first sentence on the page.

 

The second occurrence was on page 8 and was a custom fact sentence for a 3rd generation person. It is also the first sentence on the page.

 

Any ideas on what to look for?

 

I did post this on the facebook group also in case anyone thinks they've already seen this.



#2 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3388 posts

Posted 27 October 2017 - 08:26 PM

Maybe Reports->Narrative->Reset ?


---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#3 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 28 October 2017 - 01:57 AM

Thanks. No change. I mean at least once I change my settings back to preferred.  And I spotted a 2nd issue also. When I change from endnotes to footnotes, one of the footnotes prints twice on the same page despite only being used once.

 

My narrative report options are as follows:

 

Ancestors and children

4 generations

Options - the only ones checked are: Start each new generation on a new page, Print uplines, print notes, include private facts, include private notes

New paragraph after every fact

Sources: Footnotes at bottom; Reuse endnote numbers, Use "ibid"

 

 

I changed fonts which altered which sentence is affected. The first letter of the first word on the 2nd page became "tates" instead of "States" and I still have a double footnote citation but it is a different one...#8 instead of #9.

 

The second instance of the letter cutting off became page 10 instead of page 9 but still happens. Also, the duplicate footnote issue appears there as well.



#4 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 28 October 2017 - 02:04 AM

The first occurrence, on page 2, seems to happen if I select "New paragraph after every fact".  The second occurence on page 9 happens when both "New paragraph after every fact" and "Start each generation on a new page" are selected.



#5 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 12:36 AM

I suppose someone should move this to the RM7 Issues section because I have had the opportunity to try it under RM 7 and it still occurs.



#6 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5876 posts

Posted 29 October 2017 - 12:00 PM

I recall there was an issue with the photo obscuring the first bit of the first sentence.

You might save to RTF and open it in MS Word. Show control codes. Inspect. Is the text there? Is there an image, even an empty frame for one? Is there a first event as seen in Edit Person of a fact type different from others?

Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#7 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 01:00 PM

Hmm...now this is interesting.

 

The Report Viewer inside RM has the problem. Therefore if I print directly from the Report Viewer, the problem prints.  However....if I save to RTF, that version does NOT have the problem. Due to font sizes or something, the spacing is different on the RTF too. There is less text per page on the RTF file than on the RM file.

 

So, I still don't know why the report is screwed up directly in RM, but at least the RTF version is clean. I don't generally want to save these reports...they are generally for temporary usage, but at least this option works.



#8 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 02:35 PM

Harold has been making suggestions on the facebook group. I have made some pics of my settings and what I am seeing.  Those pics are on my imgur page. https://imgur.com/a/2OER7



#9 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1363 posts

Posted 29 October 2017 - 04:40 PM

 Those pics are on my imgur page. https://imgur.com/a/2OER7

 

Once you have images on "imgur" or "postimage" (and probably other image sites) you can have them display here by pasting the direct link into the Image dialog box here (11th icon from the left).



#10 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 05:00 PM

So, I just tried and I keep getting an error that I am not allowed to use that file extension? Weird. I will try again.



#11 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 05:03 PM

Initial Report Settings

nCmecw8.jpg

 

 

Options

WQYPFGe.jpg

 

 

Font

rVe4vpr.jpg

 

 

Sources

QGQCgZV.jpg

 

 

First occurrence of problem; first letter of first sentence is missing

SSwHliF.jpg

 

 

Duplicate footnote that always shows when the first letter is missing

p4rsLrz.jpg



#12 texas_nightowl

texas_nightowl

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 29 October 2017 - 05:07 PM

Also, I can tell you that when I change the font down to 9, the problem went away.

 

So, I am fairly convinced there is some sort of weird spacing bug.



#13 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7957 posts

Posted 30 October 2017 - 12:18 PM

Confirming this issue is noted on the development list.


Renee
RootsMagic