Jump to content


Photo

Error: Application made attempt to call method of already deleted object

error copy note bug report

  • Please log in to reply
16 replies to this topic

#1 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 29 August 2017 - 06:05 AM

I'm using the very latest update of RootsMagic 7 (Version 7.5.3.0) and received this error:

Application made attempt to call method of already deleted object: $0AAF88D0 OBJECT [?] 244 bytes.

 

This happened while in a "Notes" window. The error came after copying text Ctrl C, then Ctrl X to delete the text.

 

I filled in the box, "What were you doing when you received this message?" then clicked "Send Errors Report" and it took well over 2 minutes before the error report was sent.

 

Afterward, I was unable to close RootsMagic the normal way and had to "end task" in Task Manager. This error happened 2 times before the latest update which I had hoped was going to fix it.


~ Debbie

#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 29 August 2017 - 03:56 PM

Where exactly are you in the program when this happens?


Renee
RootsMagic

#3 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 29 August 2017 - 04:20 PM

In the Notes window


~ Debbie

#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 29 August 2017 - 04:34 PM

What antivirus software are you using?


Renee
RootsMagic

#5 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 29 August 2017 - 04:36 PM

Windows Defender Antivirus


~ Debbie

#6 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 29 August 2017 - 04:38 PM

Temporarily turn it off and see if you can use copy/paste now.  Do you have any internet filtering software on too?  Is so disable it for testing.


Renee
RootsMagic

#7 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 29 August 2017 - 04:42 PM

The problem exists randomly, not all the time. Maybe it's a Windows 10 problem as well since I saw a clipboard error while in a different program. Could be I'm copy/cutting too fast for Windows to keep up. But I never saw the error at any time since the last couple weeks. I don't know what internet filtering software is, so I guess I don't have it.


~ Debbie

#8 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 29 August 2017 - 05:14 PM

Internet filtering software is like NetNanny or K9 Web Protection. Families use it to control their kids access to the internet.

 

I will have to continue to investigate this copy/paste issue. It's not happening for everyone so there has to be some setting blocking things.  In the past we had Webroot that was silently blocking it in applications and a setting in their program fixed it. 


Renee
RootsMagic

#9 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 30 August 2017 - 01:14 AM

These are other security programs that are installed:
Malwarebytes (free) is installed but I think it only scans when I tell it to.
HitmanPro.Alert and HitmanPro 3.7
SpywareBlaster
Secunia PSI

 

AddBlock Plus - today disabled in Firefox and Chrome

 

Puretext is running in the taskbar - it converts formatted text to pure text. I had not clicked it right before I was copy/cutting text from RootsMagic. http://stevemiller.net/PureText/


~ Debbie

#10 mjashby

mjashby

    Advanced Member

  • Members
  • PipPipPip
  • 117 posts

Posted 30 August 2017 - 01:05 PM

Debbie,

 

If you have the PureText app set to run at start up (the default) and have also accepted its default HotKey shortcut settings, or have set any shortcuts to use the same keystrokes as the normal Windows shortcuts then there might, potentially, be a conflict with the use of those standard Windows shortcuts.  I would disable the PureText app to test.

 

Mervyn


MJA

"A Mac User with Windows Tendencies"


#11 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 30 August 2017 - 02:32 PM

I have Malwarebytes (free) on my computer and don't have the copy/paste issue so we can rule that one out. The others I don't have so test turning each off and see if there is a difference. I think I would turn them all off first and then turn each on one at a time. It's possible a couple could be conflicting with each other. 


Renee
RootsMagic

#12 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 01 September 2017 - 05:03 PM

I disabled PureText. I had no problems copy/cutting in RootsMagic notes.

I enabled PureText. I still had no problems copy/cutting in RootsMagic notes.

 

So right now, I don't have a problem. Until it happens again.

 

Now I saw this other thread. Is it the same thing?

http://forums.rootsm...y-pasting-data/


~ Debbie

#13 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 01 September 2017 - 05:07 PM

Yes, I believe they are the same issue.


Renee
RootsMagic

#14 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 10 September 2017 - 04:43 AM

I'm still experiencing the problem with RM crashing when doing CTRL X in Notes. I had renabled Adblock Plus in Chrome and Firefox browsers since my earlier report of Sept. 1.

 

I then disabled Adblock Plus in Chrome and tried to crash RM. It took several tries before I finally crashed it doing CTRL X in Notes. I just saw over at the other thread that you have confirmed this is a problem.


~ Debbie

#15 Mad dog

Mad dog

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 10 September 2017 - 10:39 AM

Just use CTRL-C then delete the notes. CTRL-V to paste where you want it to be. 



#16 mapleleaf

mapleleaf

    Advanced Member

  • Members
  • PipPipPip
  • 534 posts

Posted 10 September 2017 - 10:54 AM

Thanks Mad dog, I'll try that!


~ Debbie

#17 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7093 posts

Posted 11 September 2017 - 09:23 AM

Confirming that the issue with Ctrl-X has been reported to development. 


Renee
RootsMagic





Also tagged with one or more of these keywords: error, copy, note, bug report