Jump to content


Photo

RootsMagic 7.5.2 Out of Memory error when importing a tree from Ancestry

RootsMagic 7.5.2 Out of Memory

  • Please log in to reply
8 replies to this topic

#1 amoffet

amoffet

    New Member

  • Members
  • Pip
  • 3 posts

Posted 31 July 2017 - 05:08 PM

RootsMagic 7.5.2 blows up because of an Out of Memory error when importing a tree from Ancestry. I couldn't figure out how to attach a screen shot of the dialog that appears.  Please let me know how I can provide that information.

 

Alan



#2 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 5541 posts

Posted 31 July 2017 - 07:48 PM

You should submit a support request to RM Inc. with the screen shot and description of the problem.

 

To include an image in a post here, you need to upload it to an image host such as postimages.org and use the URL it provides in the image widget in your message.


Tom user of RM7230 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> Rmtrix_tiny.png app, a growing bundle of RootsMagic utilities.


#3 Mad dog

Mad dog

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 31 July 2017 - 09:27 PM

How much RAM do you have? More is better - 16 if your system can handle it.



#4 mjashby

mjashby

    Advanced Member

  • Members
  • PipPipPip
  • 133 posts

Posted 01 August 2017 - 06:30 AM

@amoflet,

 

Not sure what version of Windows you're using, but have a look at this Microsoft explanation and Guide on addressing 'Out of Memory' errors.

 

https://support.micr...-of-the-desktop

 

Note: The error has nothing to do with the amount of physical memory installed; and if you happen to be running a 32-bit version of Windows, you are limited to 4Gb anyway.

 

Mervyn


MJA

"A Mac User with Windows Tendencies"


#5 Kennywood

Kennywood

    New Member

  • Members
  • Pip
  • 1 posts

Posted 06 August 2017 - 02:08 AM

Hi..

 

I am having the same issue - importing a tree from Ancestry - and about 38% at the Importing your Ancestry tree - I get a out of Memory error - and that is as fare as it goes - I have to close and stop it will not get past this error.

 

Small trees I have imported without issue - this tree is 100K people so rather large..

 

16GB Memory on computer, Windows 10, 32 Bit version (so only 4GB in use)

 

Interested also in the resolution to this problem.

 

Regards

 

David

 



#6 jherald

jherald

    New Member

  • Members
  • Pip
  • 2 posts

Posted 06 August 2017 - 06:39 PM

Ditto.

 

Having this same issue in both Windows and Mac versions.  16GB ram.

 

It usually just hangs - the progress bar completely stops at importing tree.  I've let it churn for an entire 24 hours with no luck.  I can see my processor activity for the task is spiked but it's not doing anything.  When I try to cancel, I get an access violation error.

 

Tree size is 21,000 people.

 

The odd thing is it worked before.  I imported my tree.  I did a bunch of stuff on Ancestry and decided going one by one through the identified changes was way too tedious so I decided to just re-download the tree.  It no longer works.  I tried uninstalling/reinstalling RM as well - no effect.

 

Jim



#7 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7271 posts

Posted 08 August 2017 - 11:46 AM

Development is aware of this and working on it. Its not really out of memory. We are testing a build to see if this issue is resolved.


Renee
RootsMagic

#8 JNG30047

JNG30047

    New Member

  • Members
  • Pip
  • 3 posts

Posted 18 August 2017 - 08:39 AM

Renee, glad to hear they are working on this issue (which I also have [in both the Windows and Mac versions]).  

 

My tree is large (80,000), but not very much larger than it was in the beta test phase.  I was able to download the tree flawlessly with more than one of the beta versions (in case that bit of information helps resolve the problem).

 

Hope it is fixed soon.

 

Thanks.



#9 JNG30047

JNG30047

    New Member

  • Members
  • Pip
  • 3 posts

Posted 28 August 2017 - 08:21 AM

This problem was fixed for me with the latest update (and I was able to download my entire tree and all media).  Thanks!

 

(By the way, I should note that [at least for me] my tree was able to continue downloading media even though I moved the computer in the middle of the process and was without an internet connection overnight.)







Also tagged with one or more of these keywords: RootsMagic 7.5.2, Out of Memory