Jump to content


Photo

Tree name invalid?


  • Please log in to reply
14 replies to this topic

#1 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 05 July 2017 - 09:40 PM

Any ideas as to why i keep getting "Tree name invalid" message when i try and complete establishing an online RM website? 

 

Cant seem to get past this hurdle.

 

Thanks,

 

Ian

 

 



#2 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1520 posts

Posted 06 July 2017 - 05:07 AM

It would help if you would tell us exactly what tree name you are proposing. Any characters that are non-alphanumeric? What length is the name?



#3 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3608 posts

Posted 06 July 2017 - 05:46 AM

You are probably using some special character in the name that TreeShare doesn't like.

 

I work in many different computing environments that each have their own rules for naming things. I usually can remember what the rules are for each environment, but not always. So I take a conservative approach for the names of things of using only letters, numbers, and underscores with the first character always being a letter. Such a procedure is usually vast overkill, but also it's usually pretty safe. For example, Windows will accept blanks in file names, but I never use blanks in Windows file names because so many other computing environments do not accept blanks in the names of things. And for another example, I have no idea what the naming rules are for TreeShare and I haven't seen any documentation of what those rules might be. But my simple minded TreeShare names have all worked so far.

 

Jerry



#4 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 06 July 2017 - 06:13 AM

Hi Guys,

No special characters, just upper case and lower case 3 words. Australian Fleetwood History

I tried different combos of words but same result. ??

Cheers,
Ian

#5 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3608 posts

Posted 06 July 2017 - 07:01 AM

Try removing the blanks.

 

Jerry



#6 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8491 posts

Posted 06 July 2017 - 09:17 AM

Tree names can have lowercase and uppercase letters, digits, underscores, and hyphens. No other characters. No spaces.


Renee
RootsMagic

#7 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 06 July 2017 - 09:25 AM

Thanks folks I will give it another try later today. I have spaces.

Renee it would be nice to get that info in the message dialog box with the "Tree name invalid" message. Just flags the users what the correct format should be.

Just a thought.

Cheers,

Ian

#8 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8491 posts

Posted 07 July 2017 - 10:30 AM

Confirming that is on the enhancement list.


Renee
RootsMagic

#9 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 08 July 2017 - 05:53 PM

Hi Renee...Thanks for confirming its on your list of to do's.

 

 

Off topic can you activate the ability to "Like This" post? I have not every been able to like a post it just tells me i have reached my quota for positive posts. It is nice to be able to quickly like a post.

 

Regards,

 

Ian



#10 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8491 posts

Posted 10 July 2017 - 08:45 AM

I'll have development take another look at liking a post, it to see if they can get it working. 


Renee
RootsMagic

#11 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 July 2017 - 06:55 PM

Ok finally finished the long haul of putting in the family database into RM7. Overall a good experience. How looking at the publishing online.

 

Thanks for the "no spaces" this was the cause it would not upload and publish. Any after it uploaded I got a confirmation window pop up with the URL. Put the provided URL in (http://myrootsmagic.com/mychosenname) but continually got a 403 Forbidden Access denied from my browser. So I went back in to RM online to see if there were any settings or something I might be able to do to correct this. Anyway whilst there there is a little magnifying glass that is "view this website" so I click on this and it opens up the online website OK however the URL it put is sites.rootsmagic.com/mychosenname

 

The other thing is it doesn't publish the photo I pointed to, is there any particular format it must have and or file size?

 

Lastly i was lead to believe that there was a basic security level that enables selected access with a password, I can't seem to find anything like that. Am I missing something?

 

Cheers,

 

Ian 



#12 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8491 posts

Posted 17 July 2017 - 10:57 AM

Go to Internet>MyRootsMagic (Publish Online) and sign-in

 

Click the Gears icon next to your website to launch the setting in the browser. On the Privacy tab is the password setting.


Renee
RootsMagic

#13 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 17 July 2017 - 11:24 AM

Cheers Renee

Lastly on the publishing online is there anyway I can change to picture and or where RM Publisher online looks for where it is located? When I setup the publish online I pointed to photo however RM doesn't like probably the file format or size or something as it just shows up as a very small what looks like a broken picture as it tries to load the image.

So I would like to firstly confirm what type of image RM is happy to load and then be able to re-point to where to look for it. I have scratched around trying find where the image pointer is in the online Publisher but for the life of me can't find it??

Regards,

Ian

#14 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8491 posts

Posted 17 July 2017 - 12:21 PM

It should upload a compressed image as long as it was added with the file type Image in RM.  If you have republished the website and you now have really tiny images its best to delete the website and add it again. You can reuse the the website name. Just make sure its completely deleted first. 


Renee
RootsMagic

#15 Fleetz

Fleetz

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 17 July 2017 - 12:27 PM

It should upload a compressed image as long as it was added with the file type Image in RM.  If you have republished the website and you now have really tiny images its best to delete the website and add it again. You can reuse the the website name. Just make sure its completely deleted first.


Thanks Renee......much appreciated.