Jump to content


Photo

Blank names in records


  • Please log in to reply
4 replies to this topic

#1 AKHummingbird

AKHummingbird

    New Member

  • Members
  • Pip
  • 1 posts

Posted 23 June 2017 - 07:39 PM

RM7 : When I unlinked a child from his parents (to move him to the other wife of the father), the father's name disappeared, but the information remained in the record. I tried retyping the name in the record, but that didn't work. Created a new record for the man, then merged it with the no-name record (using RIN). The wife shows up with two marriages, one with a name and one without. 

 

Also tried to copy children from FS Family Tree into RM, and the record came into RM with a blank name. Adding the record manually leaves me with the one I can read, plus a blank one. 

 

Tried clearing phantom records, but that didn't help. I can't figure out how to get rid of the records without the name, short of deleting the person (and losing all the data). 

 

Any suggestions?



#2 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1138 posts

Posted 23 June 2017 - 07:50 PM

I use a sorta brute force approach when this happens to me.

 

Click on the "blank name" record, and you should be prompted to add a new person. At this point I input a dummy name such as "aa  aa" that will be super-easy to jump to. Next I navigate to the correctly named record, right-click and merge and select the "aa aa" record. After completing the merge, edit the record and delete the Alternate Name of "aa aa"



#3 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7084 posts

Posted 26 June 2017 - 09:36 AM

I can't follow what you were doing. Did you actually unlink the father instead of the child in the family? Unlinking the child shouldn't remove the primary name of the parent. If you removed the father the marriage fact with still display since its on the mother's fact.


Renee
RootsMagic

#4 Jan Herdsman

Jan Herdsman

    New Member

  • Members
  • Pip
  • 3 posts

Posted 12 September 2017 - 07:59 AM

I have been doing some merging after importing my Ancestry.com file , and sometimes I am left with a child number in a family with no child except sex, and no way to add info or delete the child, it is obviously some sort of glitch in the system any ideas how to resolve it.



#5 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1138 posts

Posted 12 September 2017 - 09:31 AM

When your database seems a bit off, its a good idea to run the File > Database Tools. It may not be technically necessary to run all 4 tools, but I almost always DO RUN ALL 4.

 

That will usually get rid of phantom records (records that look like they might exist, but don't have a name or RIN.

 

Otherwise, have you tried the "brute force" method I described above?