Jump to content


Photo

Rootsmagic 7 with Wine 2.0 works on Ubuntu 16.04


  • Please log in to reply
1 reply to this topic

#1 uberdorf

uberdorf

    Member

  • Members
  • PipPip
  • 11 posts

Posted 19 February 2017 - 04:29 PM

I had trouble with the Wine 1.6 from the Ubuntu repositories and Rootsmagic 7 on Kubuntu 16.04, and didn't want to track down the missing dependencies.  So I purged 1.6 and installed Wine 2.0, the latest stable version right now, following the instructions at the Wine website.  https://www.winehq.org/ It works fine without manually having to add any libraries, just change the default setting in Wine from XP to Windows 7 and install the stuff that Wine automatically pops up, like the two Gecko engines and something else.  I've tested this with Kubuntu 16.04 using stable 2.0, and Ubuntu Gnome 16.04 using the developmental branch (2.2 right now).

 

So if you are considering the Wine route on linux for Rootsmagic 7, Wine 2.0 works better as is than 1.x.



#2 DORowell

DORowell

    New Member

  • Members
  • Pip
  • 2 posts

Posted 17 October 2018 - 08:46 AM

RootsMagic 7 also runs very well on Wine 3.0.3 on Linux Mint 9 MATE and LMDE 3 Cinnamon

 

I had very bad experiences installing Wine from the Software Manager and eventually followed the detailed directions on the WineHQ.org. After that all was smooth - PAF and RootsMagic installed and functioned well.