Jump to content


Photo

Cannot Upgrade


  • Please log in to reply
3 replies to this topic

#1 Islanderuk

Islanderuk

    New Member

  • Members
  • Pip
  • 3 posts

Posted 24 October 2016 - 08:07 AM

My computer crashed and I had to get a new hard drive.

 

I have downloaded Version 4 which I had on my old hard drive and have entered the Registration Key.

 

When I tried to run the program I got a message saying my database was created in an older version.

 

I then purchased an upgrade to the latest version using PayPal.

 

I downloaded the latest version but when I tried to install the upgrade I got an error message saying that

 

An error occurred while trying to rename a file in the destination directory

​MoveFile failed code 183

​Cannot create a file when that file already exists

 

​I hit retry and the same thing happened so I hit ignore and it appeared to install

 

When I tried to run Roots Magic I got an error message

 

​CreateProcessfailed Code 2

The system cannot find the file specified

 

​How can I proceed please



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 7090 posts

Posted 24 October 2016 - 08:17 AM

Are you using RootsMagic 7 now?  Do you have a RMGC database file? If so using File>Open should convert it the new file format.  If you have a backup RMGB you can use File>Restore to open it again.  I'm not sure why you are trying to rename it. Make sure you haven't renamed the RootsMagic database outside of the program. It won't open if you do that. The file name needs to match the internal database name.


Renee
RootsMagic

#3 Islanderuk

Islanderuk

    New Member

  • Members
  • Pip
  • 3 posts

Posted 24 October 2016 - 08:53 AM

Thank you for responding so quickly

 

No I am not using RootsMagic 7 as the program will not run. The database name is Master File.rmgc but I cannot check if this is the same as the internal database name as I cannot open the program.

I tried copying my master RMGC file into the RootsMagic directory but it still will not open.

 

 

When I try to use Roots Magic 4 I get a message telling me that my data base (RMGC file) has been created by a later version. This probably means that I upgraded to a version later than Version 4 on my old hard drive.

 

 

 

Should I remove the version 7 upgrade I downloaded that does not work and download the full Version 7 and if I do this will the Version 7 Key I have been sent work.



#4 Islanderuk

Islanderuk

    New Member

  • Members
  • Pip
  • 3 posts

Posted 24 October 2016 - 11:22 AM

Hi

 

Further to my earlier message, I uninstalled the version of Windows 7 on my C/ Drive, and changed the name of the RootsMagic directory which Windows 10 would not let me delete as I did not have administrators permission ?????????????

 

I then downloaded RootsMagic 7 again and it opened fine with all my information. I was then able to enter the key I was sent and I now have a fully operational working version.  I HOPE