Jump to content


Photo

Starting RM7


  • Please log in to reply
3 replies to this topic

#1 Totnor

Totnor

    Advanced Member

  • Members
  • PipPipPip
  • 130 posts

Posted 06 September 2016 - 01:35 AM

I have two main databases on RM7, the smaller of which I only use infrequently. When I start up RM  both bases flicker alternately and then the main one settles down and I can use it. Please can anyone explain why this is happenening? I've been a user of RM for many years, and have never had problems before in this way. It started when I added the smaller database mentioned above. I use Windows 7.



#2 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3978 posts

Posted 06 September 2016 - 06:23 AM

Just a guess, but I suspect you actually have two different windows open, one window for each database, with the window for the main database on top. You probably only notice during start up because RM has to open both databases, even though the window for smaller database will be covered up. It is probably the opening of both databases that is causing the little flickering that you are seeing.

 

Click Window on the menu bar to see if there are two windows. If there are, select the window for the smaller database to put it on top, and then close it by clicking its X in the upper right hand corner. Do not click the red X that's for the whole RM program. Click the black X that's just under the red X. Doing so will close the window for the smaller database, leaving the window for the larger database open. The next time you start RM, only the window for the larger database will be there and there will be no flickering.

 

The following is a very personal preference, but I personally choose the option that when I start RM there is no database open at all.This gives me an extra step every time I start RM because I have to open the database manually, but it gives me a sense of a cleaner start up. Also, if ever I get a corrupted database that won't open and prevents RM from starting, my RM will start just fine. I'm sure that 99% of RM users prefer just to have RM go ahead and open their main database automatically. That's why I said it's a very personal preference. The option may be found at Tools->Program Options->Open databases from last session where I uncheck the option and most users leave the option checked.

 

Jerry



#3 Renee Zamora

Renee Zamora

    Advanced Member

  • Admin
  • PipPipPip
  • 8779 posts

Posted 06 September 2016 - 07:17 AM

I haven't seen any reports of flickering. What operating system are you using? Where is the database being stored?


Renee
RootsMagic

#4 Totnor

Totnor

    Advanced Member

  • Members
  • PipPipPip
  • 130 posts

Posted 06 September 2016 - 07:21 AM

Jerry, you were right! I had not only the two databases open, but an extra copy of the main one there as welll!! All working fine now. The clue was an extra tool bar with the database' name on them. Thank you so much,

 

Anne