Jump to content


Photo

Unable to import custom "fact types" into personal historian

fact types roots magic personal historian

  • Please log in to reply
4 replies to this topic

#1 tgarrett56

tgarrett56

    New Member

  • Members
  • Pip
  • 3 posts

Posted 28 June 2016 - 07:17 PM

I created several new "fact types" in roots magic 7. I purchased Personal Historian. When i do the "import genealogy file" into Personal Historian it does not show the custom fact types as available to import. How do i get personal historian to see and import the custom fact types? I have a lot of info in those custom fact types but now I can't import the info into the historian books i create. Anyone know how to fix this?



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8207 posts

Posted 29 June 2016 - 10:30 AM

I just tested this and I am seeing my custom facts in RootsMagic listed to import into PH2. Are you using PH1?  I didn't test that version.  What type of fact is it - individual or family fact?


Renee
RootsMagic

#3 tgarrett56

tgarrett56

    New Member

  • Members
  • Pip
  • 3 posts

Posted 29 June 2016 - 06:19 PM

Using PH2.  Fact type = individual. I created 3 new fact types. None show up. Strange. I just started using PH2 so maybe i am doing something wrong.  I think I will try exporting to a Gedcom then import into PH2. Thank you for confirming it should work. 



#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8207 posts

Posted 30 June 2016 - 07:08 AM

Run the File>Database Tools all options in consecutive order. Just to rule out it isn't something with the database itself.


Renee
RootsMagic

#5 tgarrett56

tgarrett56

    New Member

  • Members
  • Pip
  • 3 posts

Posted 30 June 2016 - 07:23 PM

Took your advice and ran all of the database tools. Although it did not find any errors it appears to have fixed my issue. I found a user with all 3 custom facts, created a PH2 for that user and all the facts were available to me upon import. Thank you!!