Jump to content


Photo

RM7 - SQLite Error 10 - disk I/O error

SQLite Error 10

  • Please log in to reply
4 replies to this topic

#1 Terri Stern

Terri Stern

    New Member

  • Members
  • Pip
  • 1 posts

Posted 09 May 2016 - 07:02 AM

I just returned from a research trip and used RM to Go to load the updated file. Started using it and suddenly got this error. What does it mean and what should I do now? I pushed the button to "Send Error Report" and can close the error message. But if I click on anything else in RM7, the error appears again, even when I try to close RM7.



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8471 posts

Posted 09 May 2016 - 07:17 AM

This is an indication there is corruption in the database. I would recommend restoring a backup file. (File>Restore). Then go to File>Database Tools and run all options there in consecutive order. If you receive errors run them through a second time. 


Renee
RootsMagic

#3 Pheney

Pheney

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 31 January 2017 - 01:31 AM

I get the 'Error 10' message if I leave RM7 open while the computer goes to sleep and the hard disk turns off.  The message appears after the computer is started again, and I then click on an individual's name in RM7. Also, RM7 will not shut down - I need to do so via Task Manager, and then restart the computer to remove the problem.  The RM7 database is not corrupt. I have noticed similar issues with other software, such as File Manager and Excel.  I suspect that this problem started after a Windows 10 update.  My current solution is to not let the hard disk turn off. Other ideas are welcome.



#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8471 posts

Posted 31 January 2017 - 01:28 PM

If you getting this with other programs then I would check with your computer specialist in troubleshooting what that error message could mean. Maybe your hard drive is failing.


Renee
RootsMagic

#5 aecreations

aecreations

    Member

  • Members
  • PipPip
  • 7 posts

Posted 03 June 2017 - 06:02 PM

they tell you to run the tools and create another file, but it works for a while and then it starts all over again.  I think there is something in the RM software.   but that is just my opinion.

every time they do an update, something always pops up.