Jump to content


Photo

Pasting issue in any type of "Note"


  • Please log in to reply
10 replies to this topic

#1 dixieau

dixieau

    Member

  • Members
  • PipPip
  • 14 posts

Posted 18 April 2016 - 02:44 AM

Hi,

 

I am having pasting issues in RootsMagic 7 on Mac, Version 7.0.1 (13.0.1.27705local).

 

If I copy an item outside of RootsMagic to paste into any form of "Note" (Person Details Note, To Do, Research Log), it pastes "BLANK", I literally have to paste it into TextWrangler or Textedit and then copy it from there into RM7.

 

Is there a setting that needs to be changed? Or has anyone else had this issue? I couldn't find anything in search.

 

Thanks for any tips.

Rhonda

 

 



#2 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3978 posts

Posted 18 April 2016 - 06:28 AM

The "pasting of blanks symptom" is a little strange, but there is an RM setting that might solve your problem. It may be found at Tools->Program Options->Use plain text when pasting to notes.

 

Here is a little history lesson about RM and its predecessor which was called Family Origins. For many years, the only kind of paste that RM had was an unformatted paste. That meant that the pasting always worked well, but it also meant that you lost any formatting such as bold or italics. The ability to paste with formatting was much wished for by RM users, and one day the paste with formatting feature was added.  But there were huge complaints from users because some users found that the formatted paste gave them all kinds of crazy results and that the only solution was to paste somewhere else than RM and then copy and paste it a second time into RM. The second copy and paste worked because it removed the formatting. That is what you are doing with TextWrangler or Textedit.

 

As a result of the user complaints about formatted paste, RM provided an option whereby formatted paste could be turned off and RM would go back to doing unformatted paste. That's the option I'm suggesting that you might want to use.

 

I don't know what percentage of RM users turn off formatted paste but it's probably pretty high. I personally find formatted paste to be absolutely invaluable and I leave it turned on all the time. For whatever reason, I don't seem to have too much trouble with it. But on those rare occasions where it does cause a problem, I simply paste into Notepad (lots of other programs work as well) and then copy and paste out of Notepad and into RM to remove the formatting. You just need to set the option in whatever way best meets your needs.

 

I think a slightly better way to handle the user interface would be to get rid of the option entirely and have the default to be paste unformatted. Then for users like me who usually prefer paste formatted, provide a right click option for the paste that would allow me to select paste formatted. But that's not the way it works, and changing the way it works at this point would probably just cause confusion.

 

Jerry



#3 dixieau

dixieau

    Member

  • Members
  • PipPip
  • 14 posts

Posted 18 April 2016 - 04:35 PM

Thank you Jerry, this fixed the problem.  Thank you also for the history lesson, I much prefer formatted text so I think I better get used to double pasting!

 

Regards

Rhonda



#4 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3978 posts

Posted 18 April 2016 - 07:37 PM

Then for users like me who usually prefer paste formatted, provide a right click option for the paste that would allow me to select paste formatted. 

 

Oops, just realized that I'm responding to a problem on a Mac with a comment that's more appropriate to PC's.. Mac's don't come with a two button mouse, and Mac users seem to get by without a right click just fine. Or else they replace their Apple provided mouse with a two button mouse and the Mac supports the right button just fine.

 

I do hope that when the RM8 rewrite comes out supporting both PC's and Mac's that it makes both PC users and Mac users happy with the user interface. I for one would be very unhappy if the right click capability went away.

 

Jerry



#5 J P

J P

    Advanced Member

  • Members
  • PipPipPip
  • 336 posts

Posted 19 April 2016 - 01:28 AM

Oops, just realized that I'm responding to a problem on a Mac with a comment that's more appropriate to PC's.. Mac's don't come with a two button mouse, and Mac users seem to get by without a right click just fine. Or else they replace their Apple provided mouse with a two button mouse and the Mac supports the right button just fine.
 
I do hope that when the RM8 rewrite comes out supporting both PC's and Mac's that it makes both PC users and Mac users happy with the user interface. I for one would be very unhappy if the right click capability went away.
 
Jerry


Jerry, The Mac may not come with a 2-button mouse but it has the function just fine. It all depends on what device you use, but typically a 2-finger touch on a touchpad does exactly what you are after. Mice also tend to use a click on the right side For the same function. It's just that in the search for simplicity (or maybe cost savings) the number of moving parts seems to have been reduced.

#6 History Hunter

History Hunter

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 12 April 2020 - 05:24 PM

Jerry;

Whether I've turned off formatting or not, I've an issue with RM7 stripping spaces at the beginning of a line.

Sometimes I use spaces to indent things. It looks fine in the RM7 internal editor, but they disappear once the note is saved.

Do you know of any solutions?



#7 zhangrau

zhangrau

    Advanced Member

  • Members
  • PipPipPip
  • 1591 posts

Posted 12 April 2020 - 06:03 PM

Sometimes I  enter indents as "period-space-space" instead of "space-space-space".

 

.  Works equally well in online forums, etc. that strip out leading spaces.



#8 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3978 posts

Posted 12 April 2020 - 07:58 PM

Jerry;

Whether I've turned off formatting or not, I've an issue with RM7 stripping spaces at the beginning of a line.

Sometimes I use spaces to indent things. It looks fine in the RM7 internal editor, but they disappear once the note is saved.

Do you know of any solutions?

 

I don't seem to be able to reproduce this problem. I put in the leading spaces and saved the note. I reopened the note and the leading spaces were still there. I printed the person the note and the leading spaces were still there. I'm a PC user if that makes any difference. Do you have any more specifics on reproducing the problem?

 

Jerry



#9 History Hunter

History Hunter

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 13 April 2020 - 05:18 AM

Jerry;
Do the spaces appear in the window that shows the citation and the research notes? I find that when I open the editor for the notes, the spaces are there, but hey are not shown in the noted window.

#10 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3978 posts

Posted 13 April 2020 - 07:21 AM

Jerry;
Do the spaces appear in the window that shows the citation and the research notes? I find that when I open the editor for the notes, the spaces are there, but hey are not shown in the noted window.

 

I think I can now reproduce the symptoms you are describing. See if this sounds right.

I created a new source with notes in all four note fields for the source - source details, source comments, citation details, and citation comments. Citation details are also known as research notes

If I indent them with spaces and save them and exit out of the Note Editor, the spaces are still there when I go back into the Note Editor.

If I print the notes in a narrative report by enabling the Sources > Print research notes with each citation option and by enabling the Sources > Print detail comments of sources with each citation option, the spaces are still there in the report in the footnotes.

But if I look at the notes by clicking on the green check mark for sources for a fact or person in the Edit person screen, the leading spaces are missing. They appear still to be in the database and they appear to print correctly if those notes are printed. But the leading spaces appear to be missing when the notes are displayed in the Person Sources or Fact Sources screen. If my understanding of the situation is correct, this seems to me to be a cosmetic but still important bug in RM7 but a bug with no loss of actual data. If this analysis is correct, I would not expect the bug to be fixed in RM7 but perhaps RM8 will display the leading spaces correctly in whatever its equivalent screen is for the Person Sources and Fact Sources screens.

 

Jerry



#11 History Hunter

History Hunter

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 13 April 2020 - 11:03 AM

Jerry;
Yes. You have recreated the bug I found.
Thank you for taking the time to confirm it as a bug.
I was not sure if I’d done something wrong.

It is aggravating, because I don’t use the editor or print a report when I am just checking data has been entered.
Not seeing what will be printed makes one doubt that it was entered correctly, since one could have forgotten the indentation.

Like you, I am sure it won’t be addressed in RM7. I also doubt we’ll see RM8 for a very long time.
Guess I’ll put RM7 on the shelf and keep my documentation manually in word-processor files and spreadsheets.
At some point, I’ll scrape together enough to buy FTM and will enter my data then.
ARGGG!!! This foot-dragging on RM8 is really starting to annoy me.