Jump to content


Photo

Websearch causes crash after update to 7.0.10.0

Websearch crash

  • Please log in to reply
13 replies to this topic

#1 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 01 January 2016 - 12:23 PM

After updating to 7.0.10.0 the program crashes whenever I try to use web search. Tried turning on External Browser switch to no avail. Have already installed registry patch for Windows 10.

 

RM7_Error.jpg



#2 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 01 January 2016 - 12:25 PM

Here's what the system error log had ...

 

Faulting application name: RootsMagic.exe, version: 7.0.10.0, time stamp: 0x56848562
Faulting module name: KERNELBASE.dll, version: 10.0.10586.0, time stamp: 0x5632da1c
Exception code: 0x4000001f
Fault offset: 0x001382e2
Faulting process id: 0x3798
Faulting application start time: 0x01d144bea84245af
Faulting application path: C:\Program Files (x86)\RootsMagic 7\RootsMagic.exe
Faulting module path: C:\WINDOWS\SYSTEM32\KERNELBASE.dll
Report Id: 742e430a-9700-4ae8-8e7b-c41f781209a8
Faulting package full name: 
Faulting package-relative application ID: 


#3 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 01 January 2016 - 12:56 PM

Found a temporary fix ...

 

Uninstall >>> Security Update for Internet Explorer Flash Player for Windows 10 Version 1511 for x64-based Systems (KB3132372)



#4 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 01 January 2016 - 01:11 PM

Microsoft is aware that this Flash update has broken applications ...

 

https://support.micr...n-us/kb/3132372

 

Perhaps it's time for Rootsmagic to abandon Flash and go with HTML5 ?



#5 kbens0n

kbens0n

    Advanced Member

  • Members
  • PipPipPip
  • 3444 posts

Posted 01 January 2016 - 01:24 PM

Microsoft is aware that this Flash update has broken applications ...

 

https://support.micr...n-us/kb/3132372

 

Perhaps it's time for Rootsmagic to abandon Flash and go with HTML5 ?

 

RootsMagic does not use flash, but it does use Internet Explorer, which uses flash ...when enabled. Prolly just disabling flash in the browser would have been enough (until they fix it).


---
--- "GENEALOGY, n. An account of one's descent from an ancestor who did not particularly care to trace his own." - Ambrose Bierce
--- "The trouble ain't what people don't know, it's what they know that ain't so." - Josh Billings
---Ô¿Ô---
K e V i N


#6 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 01 January 2016 - 01:30 PM

 

RootsMagic does not use flash, but it does use Internet Explorer, which uses flash ...when enabled. Prolly just disabling flash in the browser would have been enough (until they fix it).

 

Good point. I've decided to set the "Use External Browser"  as Google Chrome (my default) doesn't crash with this security update. 



#7 diopter

diopter

    Member

  • Members
  • PipPip
  • 6 posts

Posted 01 January 2016 - 10:47 PM

New to RM and Windows 10, but had the same problem when I did a search. Can you give me a brief and basic  summary as to how to solve this problem? Thanks!



#8 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 02 January 2016 - 06:06 AM

To disable the built-in Flash plug-in for Internet Explorer on modern versions of Windows, open Internet Explorer, click the gear menu, and select “Manage add-ons.” Click the Show box and select “All add-ons.” Locate “Shockwave Flash Object” under “MIcrosoft Windows Third Party Application Component,” select it, and click the Disable button



#9 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8375 posts

Posted 04 January 2016 - 05:36 PM

This is only effecting Windows 10 users and it appears to have happened after their recent update. It appears to be effecting FamilySearch, Ancestry and Find A Grave. For now you will need to use the external browser.


Renee
RootsMagic

#10 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8375 posts

Posted 06 January 2016 - 10:19 AM

To disable the built-in Flash plug-in for Internet Explorer on modern versions of Windows, open Internet Explorer, click the gear menu, and select “Manage add-ons.” Click the Show box and select “All add-ons.” Locate “Shockwave Flash Object” under “MIcrosoft Windows Third Party Application Component,” select it, and click the Disable button

 

Development wants to know more about this. I have been testing and I can't seem to get these steps to turn off Flash in IE and Edge to make any difference. I have even uninstalled Adobe Flash on my computer. Can you give me any more steps on this. Has this helped anyone else with this issue?


Renee
RootsMagic

#11 TomH

TomH

    Advanced Member

  • Members
  • PipPipPip
  • 6179 posts

Posted 06 January 2016 - 12:37 PM

I disabled Flash in IE and Edge and neither benefited the integrated browser crashing the program.


Tom user of RM7550 FTM2017 Ancestry.ca FamilySearch.org FindMyPast.com
SQLite_Tools_For_Roots_Magic_in_PR_Celti wiki, exploiting the database in special ways >>> RMtrix-tiny.png app, a bundle of RootsMagic utilities.


#12 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 06 January 2016 - 12:51 PM

I disabled Flash in IE and it had no benefit on the integrated browser crashing the program.


Ditto!

#13 Jerry Bryan

Jerry Bryan

    Advanced Member

  • Members
  • PipPipPip
  • 3487 posts

Posted 06 January 2016 - 01:10 PM

I disabled Flash in IE and Edge and neither benefited the integrated browser crashing the program.

I don't use the integrated browser, but your description of the symptoms makes me wonder if disabling Flash in IE and Edge also disables Flash in the integrated browser.

 

Jerry



#14 rickster

rickster

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 06 January 2016 - 01:12 PM

My thought too.