Jump to content


Photo

Pictures resized to tiny thumbnails when uploaded to internet

upload picture size

  • Please log in to reply
21 replies to this topic

#1 dsheridan

dsheridan

    Member

  • Members
  • PipPip
  • 8 posts

Posted 25 September 2015 - 08:54 PM

I'm using RM 7.0.7.0.

 

Last time I updated my tree and uploaded it to the internet I'd added about 36 pictures. I only had about a dozen or so to start.  But the new pictures all come up in tiny a thumbnail size. I tried deleting, rescanning, and attaching them and got the same result.  I tried editing a few in photoshop so they'd be the same size as one of the normal pictures, and then attaching them. Same result.  I even attached one of the pics that shows up normal to a new record, and got the same tiny result even the the exact same file was used, the picture with the new record was tiny.  The original dozen are fine but every picture I added since comes up like a thumbnail on the internet.  The original pictures look fine, and it's only on the internet upload.  If I go into RM and look at the pictures they look perfectly fine.

 

Within my RM files on my computer, I see one called "Media" and it appears to have 3 versions of all my pictures with a suffix of normal, medium, and tiny.   This wasn't a folder I created, so it must be created as part of the export process.  I tried deleting the medium and tiny versions but still ended up with the tiny version on the internet.

 

Has anyone else had this issue?  My tree is fairly large- about 5500 people.  Could it be a size issue with the database that's forcing the smaller pictures?  

 

 



#2 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 26 September 2015 - 09:56 AM

This is the same thing I am seeing. I've been through the webinars, help, and a lot of the forum posts and still cannot find an answer. I'm baffled, but know it's some tiny detail I have forgotten about.

 

TomD


It's been real... It's been fun...


#3 Laura

Laura

    Advanced Member

  • Members
  • PipPipPip
  • 4276 posts

Posted 26 September 2015 - 10:38 AM

Where are you uploading the database on the internet?

Where are you viewing the media files to see the tiny thumbnail on the internet?

What folder path on your computer are these different sized media files being saved. Is it in the same folder as your database?

#4 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 26 September 2015 - 03:35 PM

Hi Laura,

 

The correct answer was behind door number 3. Sometime, over the past three or four days, I had changed my path/directory and promptly forgot about it. Problem solved. At one time in my life I knew a lot about nothing. Luckily, now that I'm old, I still have more things I can forget. Thank you for clearing some cobwebs from my memory

 

TomD


It's been real... It's been fun...


#5 dsheridan

dsheridan

    Member

  • Members
  • PipPip
  • 8 posts

Posted 27 September 2015 - 09:50 PM

Wait, what??  It works for you now, Tom?

 

I use the website generated by RM7.

 

I'm using RM7, so I just go to the Internet menu across the top of the screen, and select "MyRootsMagic" publish online.  My pictures are on my backup drive (which is my K drive) with as is my Rootsmagic program database. But now that you mention it, the media files I see are (where I mentioned I see the 3 versions of the files with a tiny, normal and medium names) is on my C drive/Documents. So they are in different places.

 

Ok, so when I go to Internet/Generate Files For My Website/RM6 Style/ where it says "Project folder" I think I left it default to my C drive.  So I should change that to the same location as where my pictures are?   Or at least the same top folder (I've got a subfolder for family pics, one for pdfs, and one for other related pics)?



#6 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 27 September 2015 - 10:24 PM

I put my pictures in a separate folder on my D drive. Called it R2RMedia. Then I went to RM, Program Options, Folders. In the Multimedia files entry I put D:\R2RMedia. That was all I did and, yes, the very next upload worked.

 

TomD


It's been real... It's been fun...


#7 dsheridan

dsheridan

    Member

  • Members
  • PipPip
  • 8 posts

Posted 28 September 2015 - 10:17 PM

Thank you so much regarding the program options/folders note.  I don't think I had that correct, but it still doesn't seem to be working.  I think I've got myself all balled up because I don't know which site I had (RM6 or new RM7) so I was using both options. 

 

I wish there was some kind of final dialogue box- it's really frustruating because I've uploaded this database a dozen times tonight.  After the "edit settings" I usually hit cancel and then nothing else happens.  or if I actually select "edit settings" I just hit "save in the next dialogue box and nothing happens.  But either way I can't tell for sure if it actually uploaded.  I wish it was would say "upload complete" or "website ready" or something so I'd know it was ready.

 

I started from scratch using the RM6 method and when I look at the folder properties, it's 27MB but the "on disk size" (whatever that means) is 59MB and I recall on the RM6 webinar it mentions a 50MB size limit so maybe that's why I'm getting small pictures now in some cases.



#8 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 29 September 2015 - 08:25 AM

It's beyond me, dsheridan. I'm down to trying things like clear your cache, restart your computer, and use RM Database Tools. That's pretty standard stuff, but it's all I've got. Now you need a RM "heavy hitter" to help with the problem. 

 

TomD  :wacko:


It's been real... It's been fun...


#9 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8470 posts

Posted 29 September 2015 - 10:11 AM

I am confirming that after publishing a website if you later republish it the images become smaller. They should remain the same size. I have reported this to development for resolution. 


Renee
RootsMagic

#10 dsheridan

dsheridan

    Member

  • Members
  • PipPip
  • 8 posts

Posted 29 September 2015 - 09:05 PM

Thanks!  :)



#11 dsheridan

dsheridan

    Member

  • Members
  • PipPip
  • 8 posts

Posted 07 November 2015 - 11:55 PM

Any updates on this?  Would this be part of a future software update?



#12 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8470 posts

Posted 09 November 2015 - 11:16 AM

I have no time frame when this will be implemented. It could either be an update to RootsMagic or to the website itself. Don't honestly know where the change has to take place. For now you could delete the website and publish it again. Then all the full size images will be there. It's only on republish that you have this issue. You should be able to use the same website name if you do it back to back and no one else grabs it.


Renee
RootsMagic

#13 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 10 November 2015 - 10:17 AM

Apparently I missed out on the "full size images will be there" episode. I followed Renee's instructions to the letter and "all the full size images" were not there. Following is an extract of the HTML from the picture box:

 

<div id="colorbox" class="" style="padding-bottom: 42px; padding-right: 42px; top: 376px; left: 631px; position: absolute; width: 600px; height: 462px;">

<div id="cboxWrapper" style="height: 504px; width: 642px;"><div>

<div id="cboxTopLeft" style="float: left;"></div>

<div id="cboxTopCenter" style="float: left; width: 600px;"></div>

<div id="cboxTopRight" style="float: left;"></div></div>

<div style="clear: left;">

<div id="cboxMiddleLeft" style="float: left; height: 462px;"></div>

<div id="cboxContent" style="float: left; width: 600px; height: 462px;">

<div id="cboxLoadedContent" style="width: 600px; overflow: auto; height: 434px;">

<img class="cboxPhoto" src="cache/media/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-large.jpg" style="float: none;"></div>

 

It appears that pictures are limited to 600px width. Hm-m-m-m, the last time I checked 600px and full size were two different things.

 

TomD


It's been real... It's been fun...


#14 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 10 November 2015 - 11:11 AM

I might add that there should also be a method available to zoom in/out on the picture. Perhaps by clicking on the picture, taking the user to another screen and getting rid of the box constraints.

 

TomD


It's been real... It's been fun...


#15 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8470 posts

Posted 10 November 2015 - 01:30 PM

Ok, I said that wrong. The website never uploads the full images. There is a size limitation on images. But, the issue I was referring to was when you Re-Publish the website. When you re-published the images were even smaller than the original ones uploaded. Never full-size but I called them that. That is what's being worked on. The images are suppose to be identical to the size of the original upload of the website. 


Renee
RootsMagic

#16 Lethdun

Lethdun

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 10 November 2015 - 07:09 PM

Ok, I said that wrong. The website never uploads the full images. There is a size limitation on images. But, the issue I was referring to was when you Re-Publish the website. When you re-published the images were even smaller than the original ones uploaded. Never full-size but I called them that. That is what's being worked on. The images are suppose to be identical to the size of the original upload of the website. 

With those stipulations, I wonder if anyone uses the website for anything other than 5x7 head shot or gravestone photos? Thinking about it, gravestone photos could be very difficult to decipher under those conditions.

 

TomD


It's been real... It's been fun...


#17 gerwally

gerwally

    Advanced Member

  • Members
  • PipPipPip
  • 104 posts

Posted 02 December 2015 - 08:41 AM

Has this issue been resolved?  I republished my database and some of the pictures are so small they cannot be seen. 



#18 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8470 posts

Posted 02 December 2015 - 08:46 AM

No, this issue has not been resolved yet. Still being worked on.


Renee
RootsMagic

#19 Allen Prunty

Allen Prunty

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts

Posted 13 December 2015 - 02:37 AM

I am very disappointed in this as I am moving my website to the roots magic generated website.  I would like my images to at least be the 600px wide if they must be resized but right now everything is as big as a postage stamp.  I have some very interesting headstones that come from the 1700's in my family and the only way to even be able to read them is to have them at a higher resolution.

I trust that this is being worked on.  Also I am publishing to Roots Magic's server I have my own but am testing it there.

Is it possible to pay you guys to host the bigger images?

Thanks

 

Allen



#20 gerwally

gerwally

    Advanced Member

  • Members
  • PipPipPip
  • 104 posts

Posted 13 December 2015 - 07:41 AM

When I attempted to upload my database to Publish Online using primary photos ony, it took forever and then gave me the message that the database was too large.  I only have a handful of pictures of people so I suspect it is trying to upload census and other images also.  When I upload the database without pictures, it does it quickly.  If I then go in and edit the settings checking include photos and primary photos only without doing anything else, the pictures of the people appear.  This is very odd.  The pictures are small but are viewable if they are a headshot.  If they are a full body shot, they are difficult to view.  Clicking on the picture does not give you a larger image.  Does Roots Magic resize the pictures when they are uploaded to Publish Online?  I saved the small image which is 2 to 3 KB. I am just trying to understand what is happening.  Hopefully the new version of Roots Magic will address this.