Jump to content


Photo

Windows 10 - Read only files


  • Please log in to reply
13 replies to this topic

#1 AlJones

AlJones

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2015 - 12:21 PM

This is a known problem since as early as June 2015 without a solution to date (08/20/15).

 

From personal experience, all the files in the <user>\Documents folder are being set to ReadOnly.  Since RootsMagic seems to default to the users documents folder for its RMGC files (this is not accusatory, simply a statement), this means that an attempt to open the file results in "Error: unable to open database file (8)" or "... file (14)"

 

I've tried to change the RO attribute thorugh file properties.  It says that it's done, but the file remains RO.

I've also through both Cmd.exe and SuperShell to "attr -r -a -s -h *.* /s" on the documemts folder, after performing the operation, the file (and folder?) remain RO.

Taking ownership of the file, either directly or with MS's TakeOwnership add on to the menu provided me with access once at which time it returned to being RO.

 

Renee (tech support here) pointed me toward, among other things, http://superuser.com...der-windows-8-1 which - at the moment - seems to work.  Note that some of the text is different between v10 and v8.1 but the steps are the same.

 

I'll follow up if I find any more information on this.  And thanks Renee

//al


Edited by AlJones, 20 August 2015 - 12:23 PM.


#2 Laura

Laura

    Advanced Member

  • Members
  • PipPipPip
  • 4276 posts

Posted 20 August 2015 - 02:04 PM

You can put your database and other RM data files where ever you like on your computer.

Go to Tools, Program options, Folder and tell RM where to find your files.

This tells RM where to find your files and where to save them.

RM only defaults to the RM default folders when we haven't told it where to go otherwise.

#3 AlJones

AlJones

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2015 - 02:14 PM

Laura, I realize I can, but accepting the default - with most programs - puts the files where you (support) and I know where to normally expect them.

 

My reason for posting this thread is that the problem of having Win 10 set the RO attrib has been encountered many, many times and I assume that other RootsMagic users either have or will encounter it.  I thought that posting a "heads up" might be helpful for others who need a solution.

 

I've been in and out of RM several times today after using the information at the link that Renee provided and I copied into my first post.  That seems to have worked, though the I'd like to know the reason that MS decided that the Documents folder should be RO? 



#4 Laura

Laura

    Advanced Member

  • Members
  • PipPipPip
  • 4276 posts

Posted 20 August 2015 - 04:00 PM

I am not an employee of RootsMagic. I am just another user.

#5 slimjim

slimjim

    Member

  • Members
  • PipPip
  • 26 posts

Posted 20 August 2015 - 05:09 PM

I have experienced this problem with various programs and a temporary solution seems to be to run software 'as administrator' until microsoft sort out a proper solution.

 

To be honest in the end I got fed up with it, backed up all my data and settings to an external drive, downloaded a copy of Windows 10 onto a USB flash, using the Microsoft utility. https://www.microsof...nload/windows10, and did a clean install of windows 10. This seems to have completely solved the problem - of course the downside is that re-installation of software is required.



#6 AlJones

AlJones

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2015 - 05:25 PM

I am not an employee of RootsMagic. I am just another user.

 

Laura, oops, mea culpa ....



#7 Ludlow Bay

Ludlow Bay

    Advanced Member

  • Members
  • PipPipPip
  • 868 posts

Posted 20 August 2015 - 06:30 PM

...  I'd like to know the reason that MS decided that the Documents folder should be RO? 

 

Folder read-only status can occur when the folder was created by a different version of Windows, by a different operating system, by a different file system, by a different user, by a system administrator; created as a custom folder or created on a different drive, to name a few possibilities.  Windows does not default to this status.



#8 AlJones

AlJones

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2015 - 06:49 PM

Ludlow, the problem is that while the folder was created by Win 8.1 (<user>\Documents) it operated properly for several days after upgrading to Win 10 before it decided to become RO (all on its own :) ).

I realize that windows doesn't default to RO; something - and I have to feel it's within the OS - is causing the folder to change to RO with no rhyme nor reason that we can determine (we is me and the many users who have encountered this problem).  People have encountered this when trying to save an Excel worksheet; altering the internal data of MP3 files; me trying to open an RMGC file ... in all the cases I've read about, Win 10 was happily accessing these file until "it decided not to".  And that's the conundrum .....



#9 Nevada Kid

Nevada Kid

    Advanced Member

  • Members
  • PipPipPip
  • 201 posts

Posted 22 August 2015 - 08:46 PM

I'll stay with Windows 7 for now. I have talked to others that had Win 10, and they come across problems with their Apps also. Going back to Win 7 solved their problems.



#10 ulfberht

ulfberht

    New Member

  • Members
  • Pip
  • 1 posts

Posted 23 August 2015 - 12:11 AM

I had this problem crop up earlier this year and tried many different things to fix the issue of Permissions related to file attributes. I was finally able to change the Read Only attribute on my photo and data files by following the steps listed below (which I found on some tech forum - sorry about the weak source here).

 

1.  Right-click on the folder
2.  Select Properties.
3.  Click Security tab.
4.  Click Advanced.
5.  Change the owner on clicking "Change" link.
6. Click Advanced tab to select obj name.
7.  Click 'Find Now' button.
8.  Select 'Administrators' and then click OK.
9.  Again press Ok on owner panel.
10.  Check Replace owner on subcontainer check box
11. Click "Enable inheritance" if disabled.
12.  Click “Replace all child object…” check box
13. Click Ok.


Now you are able to access your files without any interruption

 

I hope this helps you!

 

Steve in Duvall



#11 Stephen G-F

Stephen G-F

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts

Posted 29 October 2015 - 10:42 AM

I hope I've not missed the point here in making this reply; apologies if so.

 

I am keen to update to Windows 10 but as my Roots Magic 7 database is probably the most important data on my computer, I'm concerned about the implications of going to Windows 10. So, the short question is will there be an update to RM7 to deal with the Read Only problem being experienced by users and or will RM8 deal with the issue. In either case, when might this be? I'm obviously keen to take the free upgrade.

 

Thanks, Stephen.



#12 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 29 October 2015 - 12:00 PM

I don't believe there is anything RootsMagic can do about Window 10 upgrades marking files read-only. It's a Windows issue, but can be resolved with steps listed in this thread.


Renee
RootsMagic

#13 Stephen G-F

Stephen G-F

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts

Posted 30 October 2015 - 11:45 AM

Many thanks for this Renee, much appreciated; I now better understand the position. Do you know if Microsoft will fix this in Windows 10 and, if so, when? I guess it's been flagged up to them (likely to be among a multitude of glitches affecting third party software?). Stephen.



#14 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8457 posts

Posted 30 October 2015 - 03:19 PM

Not sure, but it wouldn't hurt to report this as feedback to Microsoft about your Windows 10 upgrade experience. The more users reporting issue usually makes a difference in resolution priority. Once its happened I don't know how they would change all the files back on everyone because some file do need to be read-only on the computer. 


Renee
RootsMagic