Jump to content


Photo

Problems with Sort Order of Spouses and Children in Publish Online

Publish Online Sort Order

  • Please log in to reply
3 replies to this topic

#1 karibeth61

karibeth61

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts

Posted 29 July 2015 - 08:48 AM

Today was my first attempt to publish my tree online, but the sort order of some of the spouses and children didn't come across correctly. (I confirmed they are correct in RM.) The issue with the sort order of the children appears to be totally random and I was able to fix the problem by going back to RM7 and resorting them, but I haven't had a chance to go through all of the families yet so I'm hoping that it will be that easy on the any others who are out of order.

 

The spouses, on the other hand, I cannot get to sort in the correct order on the website. I've tried both manually rearranging them with the up/down arrows and sorting by marriage date. Neither seems to have any affect.

 

My RM7 file was originally created in FTM2014. I'm mentioning this because that program requires that one of the spouses be a "Preferred Spouse" (defaults to the first spouse entered but can be manually changed). When I imported the Gedcom file the preferred spouse came across as the first spouse, regardless if it was their first spouse or their third spouse and I have been manually rearranging them. I don't know if there is still a hidden field or flag that is causing this issue with the web page and has to be removed from my file (and how to go about doing it) or if this is a issue with the Online Publishing program.


Kari


#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8332 posts

Posted 29 July 2015 - 09:55 AM

Kari, I think we will need to take a look at your FTM Gedcom to see how that file comes over. Can you open a support ticket and send a copy of the GEDCOM, backup of the RootsMagic database, URL of the website, and some couples to look at.

 

http://support.roots...us_requests/new


Renee
RootsMagic

#3 karibeth61

karibeth61

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts

Posted 29 July 2015 - 10:16 AM

Renee.. Well, I wasn't expecting this... I exited out of RM and when I went back into it, the link to my website was gone. I did back it up before closing out of the program so I'll try restoring that first to see if the link is still there. If not, I'll have to redo it before I can send you anything.

 

UPDATE: I was able to access the site directly from my RM account so it appears that the link is just missing from my family tree.

 

2nd UPDATE: Boy do I feel stupid... I wasn't signed in. Is there a way to stay signed in? (So I'm already signed in when I open that particular tree?)


Kari


#4 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8332 posts

Posted 29 July 2015 - 02:36 PM

If you go to Internet>MyRootsMagic (Publish Online) it will remember your login during the session. Once you close RootsMagic the next time you open you need to login.


Renee
RootsMagic