Jump to content


Photo

Ordinances tab incorrectly loading wrong person

ordinances familysearch

  • Please log in to reply
2 replies to this topic

#1 tralston

tralston

    Member

  • Members
  • PipPip
  • 8 posts

Posted 20 May 2015 - 04:46 AM

Sometimes when I am trying to copy over ordinance data from Family Tree, it loads the wrong person on the right half of the window. I have to be very careful, because one time I didn't verify and it copied over the wrong information. I've attached pictures.

 

First image. As you can see, the person is Caleb Shreve, and his parents are James and Mary, and is married to Ressler. The right hand side it says his parents are Samuel and Sophia, and is married to Anna Slack. I just happened to know that this information is another Caleb Shreve in my tree, but it's not consistent.

 

ordinances_before.png

 

Second image. To workaround this, I will usually just select another person in the index on the left, and go back to the person I want. This refreshes the data download, and the correct person is fetched. As you can see, the information on the left and right are now consistent.

 

ordinances_after.png

 

Fortunately this bug doesn't occur every time. On average it seems that every 1 of 15 or so this happens. Please advise.



#2 Renee Zamora

Renee Zamora

    Advanced Member

  • Support
  • PipPipPip
  • 8447 posts

Posted 20 May 2015 - 11:32 AM

I have seen this happen myself. But, I can never recreate so we can determine how it happens. All I can guess right now is that FamilySearch just wigs out for a minute. If you close and reopen that screen again the issue is resolved. 


Renee
RootsMagic

#3 tralston

tralston

    Member

  • Members
  • PipPip
  • 8 posts

Posted 20 May 2015 - 01:07 PM

I may have some information on how to better reproduce the bug. Go into FamilySearch mode with the sidebar index open. Open the Ordinances tab. I tried it two ways:

 

1) Starting on a random person who was matched with FS. I then proceeded to use the down arrow of my keyboard to advance until the next matched person and then waited for the ordinances to load. I tried it ~50 times in a row, with no bug.

 

2) This time, I typed the name of the ancestor who was matched. I didn't necessarily go down to the immediately next matched person, but 1/3 down the page or so each time. Once I hit ~14 times, it happened. The person was always at the top of the sidebar (naturally, since it scrolls it so your focused person is first). So it seems that typing in the name does it.

 

I then noticed that the incorrect data on the right side of the ordinances screen is for the first connected person before the currently highlighted person. And it's not the last person I selected (I had skipped over them). I've confirmed this is the case all 3 times it's happened (it's happened more, but I've only been paying attention for 3). See the pictures below.

 

wrong_data.png

 

last_person.png